Subject: [Teep] I-D Action: draft-ietf-teep-architecture-00.txt

From: [email-masked]
Date: Wed, 04 Jul 2018 07:49:07 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Trusted Execution Environment Provisioning WG of the IETF.

        Title           : Trusted Execution Environment Provisioning (TEEP) Architecture
        Authors         : Mingliang Pei
                          Hannes Tschofenig
                          Andrew Atyeo
                          Dapeng
	Filename        : draft-ietf-teep-architecture-00.txt
	Pages           : 24
	Date            : 2018-07-02

Abstract:
   A Trusted Execution Environment (TEE) was designed to provide a
   hardware-isolation mechanism to separate a regular operating system
   from security- sensitive applications.

   This architecture document motivates the design and standardization
   of a protocol for managing the lifecyle of trusted applications
   running inside a TEE.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-teep-architecture/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-teep-architecture-00
https://datatracker.ietf.org/doc/html/draft-ietf-teep-architecture-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Wheeler, David M" <[email-masked]>
Date: Thu, 5 Jul 2018 16:58:40 +0000

Another comment on the new architecture draft:

Section 3 is titled scope and assumptions, however the introduction of security domains and TA binaries seems to creep past the listed title, and jump into concept definition. A Security Domain "feels" like a system component, and yet section 5 does not have any such section - instead it has a section on SD owners and cryptographic binding.

I suggest a more complete section on security domains be added to section 5, and section 3 paragraph be modified to something like the following:

This specification assumes the existence of a Security Domain (SD) concept which enables easier management of multiple Trusted Applications (TAs) by Service Providers (SPs) and the TAM. The SD concept is further described in section 5.x.

The other confusion (for me) is the paragraph on TA binary and configuration data coming from two different sources. This paragraph is not clearly stated as an assumption, IMHO. The last sentence of the paragraph
                  "The second case calls for an extension when a TAM is absent."
Does this mean that the current architecture does not provide for a Client Application providing the TA binary? This seems problematic for me, because this vector (Client App supplying the TA) is the exact vector used by Intel SGX.

Is the assumption here that such vector will not be covered by the architecture? Why? Perhaps we can help correct that so it does not have to be deferred until an extension.

Thanks,
Dave Wheeler

-----Original Message-----
From: TEEP [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, July 4, 2018 7:49 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Teep] I-D Action: draft-ietf-teep-architecture-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
TEEP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teep

---

From: Dave Thaler <[email-masked]>
Date: Thu, 5 Jul 2018 17:50:23 +0000

David Wheeler wrote:
> Does this mean that the current architecture does not provide for a Client Application providing the TA binary?
> This seems problematic for me, because this vector (Client App supplying the TA) is the exact vector used by Intel SGX.

As shown in the original BOF poster, and the chairs presentations at IETF meetings, the WG needs to solve the case
where the TA binary comes via either of two paths.  So yes the architecture needs to provide for it.

Dave

---

From: Mingliang Pei <[email-masked]>
Date: Thu, 5 Jul 2018 17:50:36 +0000

Hi David,

Thank you for reviewing the draft, and your suggestions. We made SD usage and TA binary as part of "assumptions" for the system design. In the section 5, system components tried to cover the high level major components where SD and TA are part of entities used inside a TEE for support the TEEP. I agree with your suggestion; thanks. A section on SD alone in section 5 alone can help clarify this better.

On the TA binary distribution from a client app, I would like to hear your suggestions too. The reason that "configuration data" needs to be from a different source is how a client has dynamic data per device if it is downloaded from an app store (mobile case). But I would like to see how SGX case be covered here. Appreciate your help on how you would suggest to support dynamic configuration data in a SGX from a client app, or the case doesn't apply?

Thanks,

Ming

On 7/5/18, 9:59 AM, "TEEP on behalf of Wheeler, David M" <[email-masked] on behalf of [email-masked]> wrote:

    

    
    
    Thanks,
    Dave Wheeler

    -----Original Message-----
    From: TEEP [mailto:[email-masked]] On Behalf Of [email-masked]
    Sent: Wednesday, July 4, 2018 7:49 AM
    To: [email-masked]
    Cc: [email-masked]
    Subject: [Teep] I-D Action: draft-ietf-teep-architecture-00.txt

    
    Abstract:

    The IETF datatracker status page for this draft is:
    https://clicktime.symantec.com/a/1/7-w2_FQOXRMi2Dn5WwKD_0y9pw2EFIW9xkAbUzoV7-4=?d=K39n0WluzqACMejbr5vpmQiwxDPelyCEOUqpfKBrzyzdJACpYCMxQBtYv28YSRBrwpjQzvhcuoxFm27wv3QkX-v09YpdOyzaGtAy_0SvJX0gBZNlvYUSzmzimO9nhXQ-xzXmv0awrtIorWMY0HglGekLu8ZTUchfqboPmWuu1w9GuE3bdcBPlflBBSupHNObASx1XfJmjDA6snUzPScV47tFvt0mA28NZtZluGNI1WdBmwtNKcJ0xPBBCj4jSqhod3p4Xs1T9tgiYby0huapNW582OmzHGmX7axKuSl62wfyE3YXdbt7EodKXev2KQyabeWXQ59MiMy6q9zBP4lhVbTYTXQJGq8uUYZwS4GriH5lVW04OPKWZioxMcgoa7mAE-t_Oy5qJaibcDJG2zjcb0S_n0QF9AaJYYZ3yLlDWBVbiF27HX8c&u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-teep-architecture%2F
    
    There are also htmlized versions available at:
    https://clicktime.symantec.com/a/1/4RYxgwAO1HPig7bLdaF3E7-btbufcBjmAUDdrRSm2iE=?d=K39n0WluzqACMejbr5vpmQiwxDPelyCEOUqpfKBrzyzdJACpYCMxQBtYv28YSRBrwpjQzvhcuoxFm27wv3QkX-v09YpdOyzaGtAy_0SvJX0gBZNlvYUSzmzimO9nhXQ-xzXmv0awrtIorWMY0HglGekLu8ZTUchfqboPmWuu1w9GuE3bdcBPlflBBSupHNObASx1XfJmjDA6snUzPScV47tFvt0mA28NZtZluGNI1WdBmwtNKcJ0xPBBCj4jSqhod3p4Xs1T9tgiYby0huapNW582OmzHGmX7axKuSl62wfyE3YXdbt7EodKXev2KQyabeWXQ59MiMy6q9zBP4lhVbTYTXQJGq8uUYZwS4GriH5lVW04OPKWZioxMcgoa7mAE-t_Oy5qJaibcDJG2zjcb0S_n0QF9AaJYYZ3yLlDWBVbiF27HX8c&u=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-teep-architecture-00
    https://clicktime.symantec.com/a/1/LK2HMivk0_SQXsB1UY5HxTPrvtpp_cXtyaKaswh-mDw=?d=K39n0WluzqACMejbr5vpmQiwxDPelyCEOUqpfKBrzyzdJACpYCMxQBtYv28YSRBrwpjQzvhcuoxFm27wv3QkX-v09YpdOyzaGtAy_0SvJX0gBZNlvYUSzmzimO9nhXQ-xzXmv0awrtIorWMY0HglGekLu8ZTUchfqboPmWuu1w9GuE3bdcBPlflBBSupHNObASx1XfJmjDA6snUzPScV47tFvt0mA28NZtZluGNI1WdBmwtNKcJ0xPBBCj4jSqhod3p4Xs1T9tgiYby0huapNW582OmzHGmX7axKuSl62wfyE3YXdbt7EodKXev2KQyabeWXQ59MiMy6q9zBP4lhVbTYTXQJGq8uUYZwS4GriH5lVW04OPKWZioxMcgoa7mAE-t_Oy5qJaibcDJG2zjcb0S_n0QF9AaJYYZ3yLlDWBVbiF27HX8c&u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-teep-architecture-00

    
    _______________________________________________
    TEEP mailing list
    [email-masked]
    https://clicktime.symantec.com/a/1/ZcxMMGRl15rav_u7PvOG0EzaKgAMeLu64a-1htJtQX8=?d=K39n0WluzqACMejbr5vpmQiwxDPelyCEOUqpfKBrzyzdJACpYCMxQBtYv28YSRBrwpjQzvhcuoxFm27wv3QkX-v09YpdOyzaGtAy_0SvJX0gBZNlvYUSzmzimO9nhXQ-xzXmv0awrtIorWMY0HglGekLu8ZTUchfqboPmWuu1w9GuE3bdcBPlflBBSupHNObASx1XfJmjDA6snUzPScV47tFvt0mA28NZtZluGNI1WdBmwtNKcJ0xPBBCj4jSqhod3p4Xs1T9tgiYby0huapNW582OmzHGmX7axKuSl62wfyE3YXdbt7EodKXev2KQyabeWXQ59MiMy6q9zBP4lhVbTYTXQJGq8uUYZwS4GriH5lVW04OPKWZioxMcgoa7mAE-t_Oy5qJaibcDJG2zjcb0S_n0QF9AaJYYZ3yLlDWBVbiF27HX8c&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep
    
    _______________________________________________
    TEEP mailing list
    [email-masked]
    https://clicktime.symantec.com/a/1/ZcxMMGRl15rav_u7PvOG0EzaKgAMeLu64a-1htJtQX8=?d=K39n0WluzqACMejbr5vpmQiwxDPelyCEOUqpfKBrzyzdJACpYCMxQBtYv28YSRBrwpjQzvhcuoxFm27wv3QkX-v09YpdOyzaGtAy_0SvJX0gBZNlvYUSzmzimO9nhXQ-xzXmv0awrtIorWMY0HglGekLu8ZTUchfqboPmWuu1w9GuE3bdcBPlflBBSupHNObASx1XfJmjDA6snUzPScV47tFvt0mA28NZtZluGNI1WdBmwtNKcJ0xPBBCj4jSqhod3p4Xs1T9tgiYby0huapNW582OmzHGmX7axKuSl62wfyE3YXdbt7EodKXev2KQyabeWXQ59MiMy6q9zBP4lhVbTYTXQJGq8uUYZwS4GriH5lVW04OPKWZioxMcgoa7mAE-t_Oy5qJaibcDJG2zjcb0S_n0QF9AaJYYZ3yLlDWBVbiF27HX8c&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep

---

From: "Wheeler, David M" <[email-masked]>
Date: Thu, 5 Jul 2018 18:41:34 +0000

Ming,
We can definitely chat in Montreal, and perhaps a short discussion of how SGX works may be appropriate. If others on the mail list are interested, perhaps we can find time for me to do a presentation (I'll be in Montreal all week).
It may not be good for the TEEP session since we have so much to discuss and only 2 hours.

I am open to suggestions.

I also must admit that I am not clear on the dynamic configuration data required. Perhaps you can clarify a bit more for me.
Thanks,
Dave Wheeler

-----Original Message-----
From: Mingliang Pei [mailto:[email-masked]] 
Sent: Thursday, July 5, 2018 10:51 AM
To: Wheeler, David M <[email-masked]>; [email-masked]
Subject: Re: [Teep] I-D Action: draft-ietf-teep-architecture-00.txt

Hi David,

Thanks,

Ming

    

    
    
    Thanks,
    Dave Wheeler

    -----Original Message-----
    From: TEEP [mailto:[email-masked]] On Behalf Of [email-masked]
    Sent: Wednesday, July 4, 2018 7:49 AM
    To: [email-masked]
    Cc: [email-masked]
    Subject: [Teep] I-D Action: draft-ietf-teep-architecture-00.txt

    
    Abstract: