Subject: [Teep] Friday interim WebEx info

From: Dave Thaler <[email-masked]>
Date: Tue, 14 May 2019 23:48:57 +0000

Here's the connection info for our upcoming interim meeting.

(Friday May 17, 8am PDT / 5pm CEST)

JOIN WEBEX MEETING

https://ietf.webex.com/ietf/j.php?MTID=mf6f92a266d315cea4b535f7bee713e62

Meeting number (access code): 643 407 490

Meeting password: cPHTG3MM

JOIN BY PHONE

1-650-479-3208 Call-in toll number (US/Canada)

Tap here to call (mobile phones only, hosts not supported): tel:%2B1-650-479-3208,,*01*643407490%23%23*01*

Can't join the meeting? Contact support here:

https://ietf.webex.com/ietf/mc

Dave

---

From: Dave Thaler <[email-masked]>
Date: Fri, 17 May 2019 14:52:45 +0000

Reminder, WebEx info at bottom.

  1.  Agenda bashing, Logistics -- Chairs (5 mins)
               https://<https://datatracker.ietf.org/meeting/interim-2019-teep-01/session/teep>datatracker.ietf.org/meeting/interim-2019-teep-01/session/teep<https://datatracker.ietf.org/meeting/interim-2019-teep-01/session/teep>
               Notes: https<https://etherpad.tools.ietf.org/p/teep-20190517>://<https://etherpad.tools.ietf.org/p/teep-20190517>etherpad.tools.ietf.org/p/teep-20190517<https://etherpad.tools.ietf.org/p/teep-20190517>

  1.  draft-<https://tools.ietf.org/html/draft-ietf-teep-architecture>ietf<https://tools.ietf.org/html/draft-ietf-teep-architecture>-teep-architecture<https://tools.ietf.org/html/draft-ietf-teep-architecture> issues
               https<https://github.com/ietf-teep/architecture/issues>://<https://github.com/ietf-teep/architecture/issues>github.com/ietf-teep/architecture/issues<https://github.com/ietf-teep/architecture/issues>

  1.  SUIT Manifest introduction - Brendan Moran
               https<https://tools.ietf.org/html/draft-moran-suit-manifest>://<https://tools.ietf.org/html/draft-moran-suit-manifest>tools.ietf.org/html/draft-moran-suit-manifest<https://tools.ietf.org/html/draft-moran-suit-manifest>

  1.  AOB

JOIN WEBEX MEETING

https://ietf.webex.com/ietf/j.php?MTID=mf6f92a266d315cea4b535f7bee713e62<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dmf6f92a266d315cea4b535f7bee713e62&data=01%7C01%7Cdthaler%40microsoft.com%7C12a15ab0cd34421ade7f08d6d8c6c17d%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=O4DoxwKApdf%2FpFerLSaEOiP32wEE32dEGiTwoHPQhz8%3D&reserved=0>

JOIN BY PHONE

https://ietf.webex.com/ietf/mc<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fmc&data=01%7C01%7Cdthaler%40microsoft.com%7C12a15ab0cd34421ade7f08d6d8c6c17d%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=HUetlprwyBliMxnWcdTzUPRnaPk5S3m90zW3I8FaFKU%3D&reserved=0>

Dave

---

From: Anders Rundgren <[email-masked]>
Date: Fri, 17 May 2019 18:55:37 +0200

We ran out of time for the GitHub issues but that's OK.

However, it would be cool to get a comment or two on https://github.com/ietf-teep/architecture/issues/52 which among many things would eliminate quirky protocol constructs like:
https://tools.ietf.org/html/draft-ietf-teep-opentrustprotocol-02

       "The top element "<name>[Signed][Request|Response]" cannot be fully
        trusted to match the content because it doesn't participate in the
        signature generation.  However, a recipient can always match it with
        the value associated with the property "payload".  It purely serves
        to provide a quick reference for reading and method invocation"

Using attested sessions and MAC-protected APIs, secure management protocols potentially get considerably cleaner while the CBOR versus JSON issue is moved out of the TEE space.

Note: this proposal is not related to my earlier suggestion to use JSON canonicalization (KeyGen2 nowadays also only relies on session key based security).

Yes, anything along these lines would indeed be a major revision...

Thanx,
Anders

On 2019-05-17 16:52, Dave Thaler wrote:
> https:// <https://datatracker.ietf.org/meeting/interim-2019-teep-01/session/teep>datatracker.ietf.org/meeting/interim-2019-teep-01/session/teep <https://datatracker.ietf.org/meeting/interim-2019-teep-01/session/teep>
> 
>                 Notes: https <https://etherpad.tools.ietf.org/p/teep-20190517>:// <https://etherpad.tools.ietf.org/p/teep-20190517>etherpad.tools..ietf.org/p/teep-20190517 <https://etherpad.tools.ietf.org/p/teep-20190517>
> 
>  2. draft- <https://tools.ietf.org/html/draft-ietf-teep-architecture>ietf <https://tools.ietf.org/html/draft-ietf-teep-architecture>-teep-architecture <https://tools.ietf.org/html/draft-ietf-teep-architecture> issues
> 
> https <https://github.com/ietf-teep/architecture/issues>:// <https://github.com/ietf-teep/architecture/issues>github.com/ietf-teep/architecture/issues <https://github.com/ietf-teep/architecture/issues>
> 
>  2. SUIT Manifest introduction – Brendan Moran
> 
> https <https://tools.ietf.org/html/draft-moran-suit-manifest>:// <https://tools.ietf.org/html/draft-moran-suit-manifest>tools.ietf.org/html/draft-moran-suit-manifest <https://tools.ietf.org/html/draft-moran-suit-manifest>
> 
>  2. AOB
> 
> Here’s the connection info for our upcoming interim meeting.
> 
> https://ietf.webex.com/ietf/j.php?MTID=mf6f92a266d315cea4b535f7bee713e62 <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dmf6f92a266d315cea4b535f7bee713e62&data=01%7C01%7Cdthaler%40microsoft.com%7C12a15ab0cd34421ade7f08d6d8c6c17d%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=O4DoxwKApdf%2FpFerLSaEOiP32wEE32dEGiTwoHPQhz8%3D&reserved=0>
> 
> https://ietf.webex.com/ietf/mc <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fmc&data=01%7C01%7Cdthaler%40microsoft.com%7C12a15ab0cd34421ade7f08d6d8c6c17d%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=HUetlprwyBliMxnWcdTzUPRnaPk5S3m90zW3I8FaFKU%3D&reserved=0>
> 
> Dave
> 
> 
> _______________________________________________
> TEEP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teep
>