Subject: Re: [Teep] Confirming consensus and way forward

From: Jeremy O'Donoghue <[email-masked]>
Date: Wed, 23 Oct 2019 09:44:33 +0000

I am happy with the new name.

Rationale: The choice to break backward compatibility with the original TEEP contribution to IETF, thus breaking interoperability with the published GlobalPlatform solution requires a name change to eliminate confusion in the market. TEEP seems an appropriate name, deriving clearly from the IETF workstream, and identifying it as something different to the GlobalPlatform solution.

Note that GlobalPlatform specifications implementing the original contribution of OTrP on a GlobalPlatform compliant TEE are now public documents. See:

  *   https://globalplatform.org/specs-library/tee-management-framework-open-trust-protocol/ (OTrP implementation profile on a GlobalPlatform TEE – published May 2019)
  *   https://globalplatform.org/specs-library/otrp-profile-initial-configuration-v1-0-gpd_gui_125/ (minimal and extended configurations for OTrP compliant implementations on a GlobalPlatform TEE – published July 2019)

Best regards
Jeremy

On 23/10/2019, 02:27, "TEEP on behalf of Nancy Cam-Winget (ncamwing)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

CAUTION: This email originated from outside of the organization.
TEEP Participants,
We discussed and there was general consensus to allow the current solution document (OTrP) break compatibility from what may get evolved by the GlobalPlatform.  This email is to confirm the consensus and to further work towards consensus on:

·         What should TEEP’s solution document be named?
To accelerate discussion and conversion to a name, the chairs propose that we call it TEEP
Please comment on whether you agree to this new name, or if not, provide rationale and alternate names.

Best,
   Your TEEP chairs.

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 23 Oct 2019 08:56:19 -0400

Sent from my mobile device

> On Oct 23, 2019, at 5:44 AM, Jeremy O'Donoghue <[email-masked]> wrote:
> 
> 
> https://globalplatform.org/specs-library/tee-management-framework-open-trust-protocol/ (OTrP implementation profile on a GlobalPlatform TEE – published May 2019)
> https://globalplatform.org/specs-library/otrp-profile-initial-configuration-v1-0-gpd_gui_125/ (minimal and extended configurations for OTrP compliant implementations on a GlobalPlatform TEE – published July 2019)
>  
+1 and TEEP is descriptive on the purpose of the protocol.

Best regards,
Kathleen 

> Best regards
> Jeremy
>  
> On 23/10/2019, 02:27, "TEEP on behalf of Nancy Cam-Winget (ncamwing)" <[email-masked] on behalf of [email-masked]> wrote:
>  
> _______________________________________________
> TEEP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teep