Subject: [Teep] I-D Action: draft-ietf-teep-otrp-over-http-02.txt

From: [email-masked]
Date: Tue, 22 Oct 2019 17:21:41 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Trusted Execution Environment Provisioning WG of the IETF.

        Title           : HTTP Transport for Trusted Execution Environment Provisioning: Agent-to- TAM Communication
        Author          : Dave Thaler
	Filename        : draft-ietf-teep-otrp-over-http-02.txt
	Pages           : 14
	Date            : 2019-10-22

Abstract:
   The Open Trust Protocol (OTrP) is used to manage code and
   configuration data in a Trusted Execution Environment (TEE).  This
   document specifies the HTTP transport for OTrP communication where a
   Trusted Application Manager (TAM) service is used to manage TEEs in
   devices that can initiate communication to the TAM.  An
   implementation of this document can (if desired) run outside of any
   TEE, but interacts with an OTrP implementation that runs inside a
   TEE.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-teep-otrp-over-http/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-teep-otrp-over-http-02
https://datatracker.ietf.org/doc/html/draft-ietf-teep-otrp-over-http-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-teep-otrp-over-http-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Dave Thaler <[email-masked]>
Date: Wed, 23 Oct 2019 00:32:10 +0000

[speaking as an individual participant, the editor of the transport spec]

This update addresses the two issues filed prior to IETF 105:

* Terminology alignment on transport layer implementation
	https://github.com/ietf-teep/otrp-over-http/issues/1
* HTTP Bindings
	https://github.com/ietf-teep/otrp-over-http/issues/2

I believe the above issues are ready to be closed. 

Separately, I filed a new issue to track future changes needed for the discussion started at IETF 105:

* Relationship to OTrPv2 proposal
	https://github.com/ietf-teep/otrp-over-http/issues/3

That issue is not addressed, but I might be able to address prior to the IETF 106 deadline
if corresponding changes are made in other docs, such as agreeing on the resolution to the
protocol name issue and adoption of the otrpv2-draft.

Dave

-----Original Message-----
From: TEEP <[email-masked]> On Behalf Of [email-masked]
Sent: Tuesday, October 22, 2019 5:22 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Teep] I-D Action: draft-ietf-teep-otrp-over-http-02.txt

Abstract:

The IETF datatracker status page for this draft is:
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-teep-otrp-over-http%2F&amp;data=02%7C01%7Cdthaler%40microsoft.com%7Cdff71f6b289a4ea16f2108d7574efd77%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637073869092026377&amp;sdata=hecosctFVbsmuvwi9mYDkTqwc7Wm5c6mk%2FtaEJ1nyzU%3D&amp;reserved=0

There are also htmlized versions available at:
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-teep-otrp-over-http-02&amp;data=02%7C01%7Cdthaler%40microsoft.com%7Cdff71f6b289a4ea16f2108d7574efd77%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637073869092026377&amp;sdata=Vx0wrLLEKtxbM3dTU3cyjiRW0OWJScCHPl%2B5wZP5HAI%3D&amp;reserved=0
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-teep-otrp-over-http-02&amp;data=02%7C01%7Cdthaler%40microsoft.com%7Cdff71f6b289a4ea16f2108d7574efd77%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637073869092026377&amp;sdata=LJBn1jtYlaoGdMWcDLxre7inuATGG5at7Y37vkpZ1ZU%3D&amp;reserved=0

A diff from the previous version is available at:
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-teep-otrp-over-http-02&amp;data=02%7C01%7Cdthaler%40microsoft.com%7Cdff71f6b289a4ea16f2108d7574efd77%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637073869092036370&amp;sdata=ZLWvboLAT4LQh%2FzlKZTck9FrHjQtKWkRyXv2W7RmO3Q%3D&amp;reserved=0

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
TEEP mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep&amp;data=02%7C01%7Cdthaler%40microsoft.com%7Cdff71f6b289a4ea16f2108d7574efd77%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637073869092036370&amp;sdata=6yCWiVpM8Wt13%2BXJ9Gd7Jvhi1m8EihbcwqjNiXol8R8%3D&amp;reserved=0