Subject: RE: inter-domain te

From: Jim Boyle <[email-masked]>
Date: Thu, 18 Oct 2001 20:18:17 -0400 (EDT)

On Thu, 18 Oct 2001, Tom Scott wrote:

> Jim,
>
> I think you're referring to the manipulation of attribute values in
> BGP updates to do traffice engineering among autonomous systems. That
> brings up a related issue: the use of non-routers such as network
> management system consoles in traffic engineering. Iin
> draft-ietf-idr-bgp4-14.txt, authors Rekhter and Li mention:
>
>    A non-routing host could exchange routing information with routers
>    via EGP or even an interior routing protocol. That non-routing host
>    could then use BGP to exchange routing information with a border
>    router in another Autonomous System. The implications and
>    applications of this architecture are for further study.

Mr. Rekhter can best tell us what in particular this means, but if I had
to take my guess, this is not an "NMS".  It is a host, running routing
software, and distributing routing information, though it has no
forwarding responsibilities (maybe "non-forwarding" would be better than
"non-routing" ?).  This might have been one way an AS would
communicate routes between other ASes and within their own AS, though I
am not aware of anyone who does this.

Things that are "similar" but not quite like this are:

o) 3rd party Route Servers in peering locations
	- http://www.rsng.net/

o) SS7 inter-domain signalling (which is done on a network totally
seperate from the forwarding network)
	- dunno, SS7 on google ;)

Jim

> > Can you refer me to any documents about
that architecture:
> specifically BGP inter-domain traffic engineering embedded in NMS?
>
> -- TT
>
>
> -------- Original Message --------
> Subject: RE: inter-domain te
> Date: Tue, 16 Oct 2001 09:29:46 -0400 (EDT)
> From: Jim Boyle <[email-masked]>
> To: <[email-masked]>
> CC: <[email-masked]>
>
>
>
> What more is needed than what is outlined in sections 5.1.3 through
> 5.1.5
> of draft-ietf-idr-bgp4-13.txt ?
>
> Jim
>
>
> On Tue, 2 Oct 2001 [email-masked] wrote:
>
> > > I was wondering if any work has been done regarding inter-domain
> > > traffic-engineering?  Can anyone direct me to information on this subject?
> > >
> > > Graham Vaughan
> > > Level (3) Communications
> >
>

---

From: Yakov Rekhter <[email-masked]>
Date: Thu, 18 Oct 2001 20:14:04 -0700

Jim,

> to take my guess, this is not an "NMS".  

Your guess is correct.

> It is a host, running routing
> "non-routing" ?).  

Correct.

Yakov.