Subject: [TICTOC] I-D Action: draft-ietf-tictoc-1588overmpls-06.txt

From: [email-masked]
Date: Mon, 28 Apr 2014 09:04:10 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Timing over IP Connection and Transfer of Clock Working Group of the IETF.

        Title           : Transporting Timing messages over MPLS Networks
        Authors         : Shahram Davari
                          Amit Oren
                          Manav Bhatia
                          Peter Roberts
                          Laurent Montini
	Filename        : draft-ietf-tictoc-1588overmpls-06.txt
	Pages           : 36
	Date            : 2014-04-28

Abstract:
   This document defines the method for transporting Timing messages
   such as PTP and NTP over an MPLS network.  The method allows for the
   easy identification of these PDUs at the port level to allow for port
   level processing of these PDUs in both LERs and LSRs.

   The basic idea is to transport Timing messages inside dedicated MPLS
   LSPs.  These LSPs only carry Timing messages and possibly Control and
   Management packets, but they do not carry customer traffic.

   Two methods for transporting Timing messages over MPLS are defined.
   The first method is to transport Timing messages directly over the
   dedicated MPLS LSP via UDP/IP encapsulation, which is suitable for
   MPLS networks.  The second method is to transport Timing messages
   inside a PW via Ethernet encapsulation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tictoc-1588overmpls/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-tictoc-1588overmpls-06

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-tictoc-1588overmpls-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Mon, 28 Apr 2014 16:09:28 +0000

Hi Yaakov,

This version addresses the final set of comments that we received as per the MPLS and TICTOC WG last call.

Can we move it further now?

Cheers, Manav

> -----Original Message-----
> From: TICTOC [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Monday, April 28, 2014 9:34 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [TICTOC] I-D Action: draft-ietf-tictoc-1588overmpls-06.txt
> 
> 
>  This draft is a work item of the Timing over IP Connection and
> Transfer of Clock Working Group of the IETF.
> 
> _______________________________________________
> TICTOC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tictoc

---

From: "Meyer, Peter" <[email-masked]>
Date: Mon, 28 Apr 2014 16:40:48 +0000

Hi Manav,

I notice a number of changes to BC support that I did not see discussed on the reflector between draft-05 and draft-06.   Moving from draft-04 to draft-05 there was a significant effort to understand how TC (both P2P and E2E) and BC work with LER and LSR and there seemed to be agreement on the draft-05 text on that topic (I worked a good deal with Shahram on the text).

Related, I would note that the ITU-T has finished the first network deployment scenarios, clock chain and performance specs for IEEE1588 with phase/time support and it uses BC in every network element (see ITU-T G.8275, G.8271, G.8273.2, etc.).

Specifically my comments on draft-06 changes

1) Section 15.2 the following text has been deleted
"When a Timing-capable/aware LSR behaves as a Boundary clock and receives a Timing message from a Timing-capable/aware MPLS interface.  The LSR performs the functions of a Boundary Clock in terminating the received Timing message and re-generating a new timing message over another (or the same) MPLS interface."

2) Section 15.3 the following text has been deleted
"or BC"

3) Section 18, the Applicability statement was removed from draft-04 to draft-05.  It has now be re-introduced.  Text should include the draft-04 proposal (before the entire section was removed)
"o  An LSR receives MPLS encapsulated Timing messages from a Timing LSP and terminates them, while performing the OC or BC functionality."

Regards,
Peter

-----Original Message-----
From: TICTOC [mailto:[email-masked]] On Behalf Of Bhatia, Manav (Manav)
Sent: April 28, 2014 12:09 PM
To: [email-masked]
Subject: Re: [TICTOC] I-D Action: draft-ietf-tictoc-1588overmpls-06.txt

Hi Yaakov,

Cheers, Manav

---

From: Manav Bhatia <[email-masked]>
Date: Mon, 28 Apr 2014 22:23:03 +0530

Hi Peter,

This wasnt intentional. Let me take a look at why certain sections got
removed -- i think its an editorial issue.

Cheers, Manav