Subject: [TICTOC] operational experience with NTP symmetric mode

From: Sharon Goldberg <[email-masked]>
Date: Thu, 5 May 2016 12:30:41 -0400

Dear WG,

As part of the NTS effort, I think it would be helpful to understand the
importance of symmetric peering mode.

Can folks on this list please share their experience about using symmetric
mode?  Do you use it, and if so why (or why not), and if so in what
operational environment are you using it?

Thanks,
Sharon

-- 
Sharon Goldberg
Computer Science, Boston University
http://www.cs.bu.edu/~goldbe

---

From: Sharon Goldberg <[email-masked]>
Date: Thu, 5 May 2016 12:32:59 -0400

Note also that our network measurements have found evidence of symmetric
mode in the wild, and I am wondering why. Please see Section 5 of our paper:

https://eprint.iacr.org/2016/055.pdf

---

From: Greg Dowd <[email-masked]>
Date: Thu, 5 May 2016 17:33:21 +0000

My two main experiences with symmetric packet modes are:

1)      Peer groups.  If you look at various materials on configuration of ntp servers which are intended to operate as a group (e.g., within a campus for scaleability/reliability), you will see recommendations to use the peer association.  Peer association implies the willingness to both provide and consume synchronization.  A prime example of this material is http://www.ntp.org/ntpfaq/NTP-s-config-adv.htm .

2)      Microsoft Windoze ntp clients.  Older clients used a weird symmetric mode packet to indicate an alternative hmac scheme request.

Also, as you are a known security reviewer, I should point out that using the term “symmetric mode” is ambiguous since my first thought is that you were talking about symmetric key hmac.  I would recommend mode 1/mode 2 packets or symmetric assocation packets or something more specific.

….Greg

From: TICTOC [mailto:[email-masked]] On Behalf Of Sharon Goldberg
Sent: Thursday, May 05, 2016 9:31 AM
To: NTP Working Group; [email-masked]
Subject: [TICTOC] operational experience with NTP symmetric mode

EXTERNAL EMAIL
Dear WG,

As part of the NTS effort, I think it would be helpful to understand the importance of symmetric peering mode.

Can folks on this list please share their experience about using symmetric mode?  Do you use it, and if so why (or why not), and if so in what operational environment are you using it?

Thanks,
Sharon

---

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 09 May 2016 08:44:28 +0200

>>> Sharon Goldberg <[email-masked]> schrieb am 05.05.2016 um 18:30 in Nachricht
> operational environment are you using it?

We used peering about as long as we used NTP (since 1993 or so). Unfortunately the latest NTP release broke NTP peering with authentication (bug 3001), so we turned it off until 
the issue is fixed.

---

From: Hal Murray <[email-masked]>
Date: Mon, 09 May 2016 00:33:37 -0700

[email-masked] said:
> We used peering about as long as we used NTP (since 1993 or so).
> Unfortunately the latest NTP release broke NTP peering with authentication
> (bug 3001), so we turned it off until  the issue is fixed. 

Did you turn off peering or authentication?

Peering seems natural for the case where you have 2 equal servers and you 
want them to keep an eye on each other.  Aside from reducing the number of 
packets by a factor of 2, are there any reasons for using peer rather than 
server?  Is there any extra information exchanged?

-- 
These are my opinions.  I hate spam.

---

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 09 May 2016 09:42:30 +0200

>>> Hal Murray <[email-masked]> schrieb am 09.05.2016 um 09:33 in

> Did you turn off peering or authentication?

Peering.

> server?  Is there any extra information exchanged?

If you operate clusters, you may have a tendency to let all the cluster nodes peer, because when in doubt it's more important that the nodes agree on a common time rather than having the correct time (if very odd things happen). Despite of that using "peer" instead of "two-way "server" is self-documentation: It's more clear from ntp.conf what happens  (is expected to happen) ;-)

---

From: Miroslav Lichvar <[email-masked]>
Date: Mon, 9 May 2016 10:24:34 +0200

> server?  Is there any extra information exchanged?

Two reasons:
- ability to push synchronization to the other host, which may
  simplify configuration management a bit as only one peer (active)
  has to be configured with the address of the other peer (passive)
- interleaved mode, which allows the peers to exchange transmit
  timestamps after packets are sent in order to improve accuracy with
  HW timestamping

-- 
Miroslav Lichvar