Subject: RE: [TLS] I-D ACTION:draft-ietf-tls-ecc-11.txt

From: "Ari Medvinsky" <[email-masked]>
Date: Mon, 26 Sep 2005 13:33:33 -0700

Also,  since you proposed to move this to informational RFC status there
are other values that are left undifined that need to be filled in:

        enum {
            ecdsa_sign(??), rsa_fixed_ecdh(??),
            ecdsa_fixed_ecdh(??), (255)
        } ClientCertificateType;

       enum { elliptic_curves(??), ec_point_formats(??) } ExtensionType;

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ari Medvinsky
Sent: Monday, September 26, 2005 1:21 PM
To: [email-masked]; Eric Rescorla
Subject: RE: [TLS] I-D ACTION:draft-ietf-tls-ecc-11.txt 

What are the values for the new ECC ciphersuites? In the current draft
they are still not specified, here is what is currently in draft 11:

     CipherSuite TLS_ECDH_ECDSA_WITH_NULL_SHA           = { 0x00, 0x?? }
     CipherSuite TLS_ECDH_ECDSA_WITH_RC4_128_SHA        = { 0x00, 0x?? }
     CipherSuite TLS_ECDH_ECDSA_WITH_DES_CBC_SHA        = { 0x00, 0x?? }
     CipherSuite TLS_ECDH_ECDSA_WITH_3DES_EDE_CBC_SHA   = { 0x00, 0x?? }
     CipherSuite TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA    = { 0x00, 0x?? }
     CipherSuite TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA    = { 0x00, 0x?? }
   
     ...

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
Sent: Monday, September 19, 2005 7:50 AM
To: [email-masked]
Cc: [email-masked]
Subject: [TLS] I-D ACTION:draft-ietf-tls-ecc-11.txt 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Transport Layer Security Working Group
of the IETF.

	Title		: ECC Cipher Suites for TLS
	Author(s)	: V. Gupta, et al.
	Filename	: draft-ietf-tls-ecc-11.txt
	Pages		: 36
	Date		: 2005-9-19
	
This document describes new key exchange algorithms based on Elliptic
   Curve Cryptography (ECC) for the TLS (Transport Layer Security)
   protocol.  In particular, it specifies the use of Elliptic Curve
   Diffie-Hellman (ECDH) key agreement in a TLS handshake and the use of
   Elliptic Curve Digital Signature Algorithm (ECDSA) as a new
   authentication mechanism.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-tls-ecc-11.txt

To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of
the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the
username "anonymous" and a password of your e-mail address. After
logging in, type "cd internet-drafts" and then
	"get draft-ietf-tls-ecc-11.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html or
ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-tls-ecc-11.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: "Simon Blake-Wilson" <[email-masked]>
Date: Mon, 26 Sep 2005 16:56:02 -0400

Hi Ari,

I guess the ECC draft is the first post TLS1.1 document to go through this
process. My expectation is that these values will get assigned by IANA at
some point in the RFC publication process. So I expect the RFC when it
happens to have the values filled in, but don't know at what time before
that the values will get assigned.

Hopefully someone will speak up if they know differently.

Best regards. Simon

> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Ari Medvinsky
> Sent: Monday, September 26, 2005 4:34 PM
> To: Ari Medvinsky; [email-masked]; Eric Rescorla
> Also,  since you proposed to move this to informational RFC
> status there are other values that are left undifined that
> need to be filled in:
>
>
>         enum {
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Ari Medvinsky
> What are the values for the new ECC ciphersuites? In the
> current draft they are still not specified, here is what is
> currently in draft 11:
>
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of
> [email-masked]
> A New Internet-Draft is available from the on-line
> Internet-Drafts directories. This draft is a work item of the
> Transport Layer Security Working Group of the IETF.
>
> To remove yourself from the I-D Announcement list, send a
> message to [email-masked] with the word
> unsubscribe in the body of the message.
> Internet-Drafts are also available by anonymous FTP. Login
> with the username "anonymous" and a password of your e-mail
> address. After logging in, type "cd internet-drafts" and then
> 	a MIME-compliant mail reader.  Different MIME-compliant
> mail readers
> Below is the data which will enable a MIME compliant mail
> reader implementation to automatically retrieve the ASCII
> version of the Internet-Draft.
>

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Mon, 26 Sep 2005 21:53:28 -0400

In message <02e801c5c2dc$b44aecd0$af00a8c0@simon>, "Simon Blake-Wilson" writes:
>This is a multi-part message in MIME format.
>
>
>Hi Ari,
>

You're quite corrrect; that's how the values are assigned.  Note 
Section 8 of the draft.

		--Steven M. Bellovin, http://www.cs.columbia.edu/~smb

---

From: David Hopwood <[email-masked]>
Date: Wed, 28 Sep 2005 02:45:07 +0100

> that the values will get assigned.

Some values have been used by SSLv3 and TLS implementations despite not being
registered, and so should not be used for new assignments. Perhaps IANA needs
to be told that.

I remember that someone on this list had spent a lot of effort collecting all
of the numbers that have been defined in draft documents, but I can't remember
who (and there are hundreds of messages about number allocation in the archives).

-- 
David Hopwood <[email-masked]>

---

From: Bodo Moeller <[email-masked]>
Date: Tue, 27 Sep 2005 22:06:34 -0600

> who (and there are hundreds of messages about number allocation in the archives).

It's here:

    http://people.nokia.net/~pasi/tls-numbers.txt

Pasi has compiled lists for ciphersuites, content types, handshake
types, alerts, client certificate types, and extensions.  These lists
come with an elaborate set of references and footnotes explaining what
is defined where.  (Various assignments are essentially only sample
values in old Internet Drafts -- something the the current ECC draft
avoids --, others are used in practice.)