Subject: [TLS] SHA-224, etc.

From: Mike <[email-masked]>
Date: Mon, 29 Jan 2007 21:53:26 -0800

Does anyone know of a TLS server that sends a
certificate containing a signature using any
of the newer SHA algorithms?  I just added
support for them and want to make sure my code
works.

Thanks,

Mike

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Mike <[email-masked]>
Date: Wed, 31 Jan 2007 10:35:15 -0800

Since I got no responses, I decided to add a certificate
signed with RSA/SHA-256 to my test server.  If you connect
to https://www.mikestoolbox.org, it will use that cert.

Mike

---

From: Mike <[email-masked]>
Date: Wed, 31 Jan 2007 10:38:12 -0800

I forgot to mention that you need to send it a server name
extension of www.mikestoolbox.org for it to respond with
the SHA-256 cert since it shares an IP address with
www.mikestoolbox.net (which uses SHA-1).

Mike