Subject: [TLS] Question about SIP on TLS

From: [email-masked]
Date: Fri, 22 Aug 2008 10:39:20 +0200

Hello ! 

here is my goal : 
=> i have some phones as SIP TLS clients
=> and a proxy/registrar as SIP-TLS server

And without TLS everthing working fine :
1) When a client needs to send a message, he opens its session with the
server. OK.
2) When the server needs to send a message he has to open his session with
the registred phone. No problem for TCP layer.

But with TLS :

For the case 2), there is a problem for TLS layer as the Phone (TCP server)
is not a TLS server.

I mean that in order to have it working, do we need to keep a TLS session
always valid ?

Nabil Hamzi
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 22 Aug 2008 07:33:05 -0700

> I mean that in order to have it working, do we need to keep a TLS session

This is not a TLS question. It's a SIP question.

That said (2) doesn't work as well with SIP without TLS as you think it does
because of NATs, firewalls, etc. There is a solution for both the TLS
and non-TLS cases: draft-ietf-sip-outbound.

-Ekr