Subject: [TLS] DTLS interop servers

From: Rob Dugal <[email-masked]>
Date: Thu, 29 Jan 2009 09:20:57 -0500

Are there any DTLS servers available for interop testing?

-----------------------------------------------
Robert Dugal
Member of Development Group
Certicom Corp.
EMAIL: [email-masked]
PHONE: (905) 501-3848
FAX  : (905) 507-4230
WEBSITE: www.certicom.com

_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: Michael Tüxen <[email-masked]>
Date: Thu, 29 Jan 2009 17:57:42 +0100

Hi Rob,

I do not know of any. But we can set up one in my lab. It
would run the OpenSSL implementation with all the patches
Robin Seggelmann provided. It would run DTLS/UDP and DTLS/SCTP?

What else is required? I would suggest using an echo and an
discard service? Anything else?

Best regards
Michael

---

From: Rob Dugal <[email-masked]>
Date: Thu, 29 Jan 2009 12:51:39 -0500

An echo server running DTLS/UDP would be sufficient.

> -----Original Message-----
> From: Michael Tüxen [mailto:[email-masked]]
> Sent: Thursday, January 29, 2009 11:58 AM
> To: Rob Dugal
> Cc: [email-masked]
> Subject: Re: [TLS] DTLS interop servers
> 
> Hi Rob,
>

---

From: Michael Tüxen <[email-masked]>
Date: Thu, 29 Jan 2009 19:32:51 +0100

We'll set it up and publish the details (address, port, ...) on the  
list.

Best regards
Michael

---

From: Ben Laurie <[email-masked]>
Date: Fri, 30 Jan 2009 08:54:08 +1100

> Robin Seggelmann provided. It would run DTLS/UDP and DTLS/SCTP?

What's wrong with the DTLS implementation that's already in there?

---

From: Robin Seggelmann <[email-masked]>
Date: Thu, 29 Jan 2009 23:26:33 +0100

> What's wrong with the DTLS implementation that's already in there?

Renegotiation isn't working at all, timers are incomplete, so that on  
packet loss most likely nothing gets retransmitted and the connection  
stalls, message reordering can cause the connection to fail,  
abbreviated handshakes are not supported.

And that's only what I have fixed to far :)

---

From: Michael Tüxen <[email-masked]>
Date: Fri, 30 Jan 2009 00:39:05 +0100

Hi Ben,

have a look at
http://sctp.fh-muenster.de/dtls-patches.html
for a description of the bugs Robin found up to now.

We found this because we are using the DTLS implementation
also for DTLS/SCTP. Most problems found by testing this
are actually bugs also showing up for DTLS/UDP. Some bugs
found will only show up only for DTLS/UDP.

Best regards
Michael