Subject: [TLS] New cached info draft 02 posted

From: Stefan Santesson <[email-masked]>
Date: Tue, 15 Sep 2009 13:04:58 +0200

I have just posted a new version 02 of the cached info draft.
http://www.ietf.org/id/draft-ietf-tls-cached-info-02.txt

As there has been no further comments on the draft responding to my
questions after last IETF, I have nothing further to add.

I think this document is ready for a WGLC.

/Stefan

---

From: Martin Rex <[email-masked]>
Date: Tue, 29 Sep 2009 03:07:17 +0200 (MEST)

> I think this document is ready for a WGLC.

I already mentioned twice in the discussion of this document
that I would REALLY appreciate if it was enhanced to provide
a much better cache control (for the client, that is).

The extension should allow the client to determine
 (a) whether the server supports the caching extension
 (b) for which elements the server supports caching
 (c) which hash algorithm the server supports for caching

on the first connect to a server, so that the client does
not have to make guesses and populate/maintain its cache
for servers that do not support this extension.

-Martin

---

From: Stefan Santesson <[email-masked]>
Date: Wed, 30 Sep 2009 08:36:51 +0200

Martin,

For clarification. I have understood your position before that the server
should not need to determine if it will replace data with its hash until the
very moment that data is to be sent in the handshake.

I would then understand your position in the following way:

In the server hello, the server should tell in general;
  (a) whether the server supports the caching extension
  (b) for which elements the server supports caching
  (c) which hash algorithm the server supports for caching

This would not tell anything whether the server actually will replace any
data with its hash in the following handshake.

> for servers that do not support this extension.

This is already the case for the current draft, as (a) is already satisfied.

Supporting (b) and (c) will probably require a different syntax in the
client and server hello extensions.

/Stefan