Subject: Re: [TLS] Accept draft-turner-ssl-must-not-02 as WG item

From: Sean Turner <[email-masked]>
Date: Wed, 06 Oct 2010 12:41:10 -0400

Simon Josefsson wrote:
> Martin Rex <[email-masked]> writes:
> 
>> Peter Gutmann wrote:
>>> Martin Rex <[email-masked]> writes:
>>>
>>>> Personally I can not think of a reason to move away from what rfc-5246
>>>> appendix E.2 says.
>>> I can.  That language has been in there more or less forever, and it's had
>>> pretty much zero effect in encouraging implementations to drop the SSLv2
>>> handshake (some implementations gradually have over time, but probably not
>>> because of text that says "well, you know, it would be really uncool if you
>>> kept sending SSLv2 hello's for the next twenty years").  Without a clear MUST
>>> NOT for the server to finally get clients to switch off SSLv2 hellos, we're
>>> never going to get rid of these things.
>>  client MUST NOT negotiate or use SSL 2.0  is fine with me
>>  client MUST NOT send SSL 2.0 CLIENT-HELLO is fine with me
>>  server MUST NOT negotiate or use SSL 2.0  is fine with me
>>
>> but
>>
>>  server SHOULD NOT accept SSL 2.0 CLIENT-HELLO as the first message
>>  of a TLS handshake is not sensible and is in clear
>>  conflict with rfc2119 section 6.
> 
> This is exactly my preference too.  Thanks for expressing it so clearly.

I'll update the section to have the three bullets Martin listed above 
(without the "is fine with me" of course).

spt

---

From: Martin Rex <[email-masked]>
Date: Wed, 6 Oct 2010 19:22:12 +0200 (MEST)

> (without the "is fine with me" of course).

Thanks.

The missing sentence what rfc-5246 Appendix E.2 describes:

   TLS servers that do not support SSL 2.0 MAY accept
   version 2.0 CLIENT-HELLO messages [as the first message of
   a TLS handshake for interop with old clients].

MAY indicates a true option (for the implementor).  I'm fine with
servers removing code to parse an SSLv2 CLIENT-HELLO and
servers not adding it.  

-Martin

---

From: Sean Turner <[email-masked]>
Date: Wed, 06 Oct 2010 18:51:14 -0400

> servers removing code to parse an SSLv2 CLIENT-HELLO and

I wasn't going to include this additional sentence because it's 
already in 5246.  But, I can see that we should.  I put something 
like: As described in [TLS], TLS servers that do not support SSL 2.0 
MAY accept version 2.0 CLIENT-HELLO messages [as the first message of 
a TLS handshake for interop with old clients]

I'll get a new version posted on Friday.

Thanks for helping me get this right.

spt