Subject: [TLS] Request for review: ARIA cipher suites for TLS

From: Woo-Hwan Kim <[email-masked]>
Date: Mon, 4 Oct 2010 10:50:49 -0500

TLS experts,

Let me make a request for the TLS WG review
on the draft regarding ARIA cipher suites for TLS.

ARIA is a general-purpose block cipher algorithm developed in 2003
and is published as a RFC (RFC 5794) in March 2010.
ARIA is used in Korea e-Government.
In particular, ARIA will be used in VoIP for Korea government.

The internet draft includes
- SHA2 variants
- ECDH(E) and ECDSA
- GCM mode of operation
- Pre-shared key
I included all the cipher suites in a single document to make it
easier on implementers.

Please find the internet draft from the below.

http://tools.ietf.org/html/draft-nsri-tls-aria-00

Best regards,
Woo-Hwan Kim

---

From: Wan-Teh Chang <[email-masked]>
Date: Wed, 6 Oct 2010 08:49:25 -0700

Hi Woo-Hwan,

Could you comment on the relation between ARIA and the other Korean
cipher, SEED, and their relative importance?  Is ARIA replacing SEED?

Wan-Teh Chang