Subject: [TLS] Definition of SSL proxies

From: Paul Hoffman <[email-masked]>
Date: Tue, 3 Apr 2012 16:21:24 -0700

In his review of the TLSA protocol, Stephen Farrell asked: "Do we have a reference for SSL proxies that's not just a product data sheet? Be nice to add if it exists. (I doubt it'll be an RFC, but I'd bet there's a paper to be found on the topic.)"

I don't know of one; if someone here does, that would be grand.

--Paul Hoffman

---

From: "Hill, Brad" <[email-masked]>
Date: Tue, 3 Apr 2012 23:47:47 +0000

> Stephen Farrell asked: "Do we have a
> reference for SSL proxies that's not just a product data sheet? Be nice to add
> if it exists. (I doubt it'll be an RFC, but I'd bet there's a paper to be found on
> the topic.)"
> 

The below, by Jeff Jarmoc at Dell SecureWorks, is the best summary of the landscape I've seen:

http://www.secureworks.com/research/threats/transitive-trust/

-Brad Hill