Subject: [TLS] Revision draft-friedl-tls-applayerprotoneg-02 Posted

From: "Stephan Friedl (sfriedl)" <[email-masked]>
Date: Fri, 22 Feb 2013 16:43:04 +0000

A revision of draft-friedl-tls-applayerprotoneg has been posted.  The following changes have been introduced into the draft in response to feedback from the working group:

1.       Section 3.1 "Application Layer Protocol Negotiation Extension" defines ProtocolNameList and ProtocolName as variable-length arrays, as typically done in TLS. This increases payload size by 2 bytes, but allows the use of the normal TLS parsers.

2.       Section 3.2 "Protocol Selection" defines a new fatal alert no_application_protocol, to be used with ALPN extension only, instead of using a generic handshake_failure alert. This is done to help distinguish application protocol negotiation issues from other handshake failures.

We would greatly appreciate any comments and feedback on the draft.

Best Wishes,

Stephan Friedl, Andrei Popov

---

From: "Brian Raymor (MS OPEN TECH)" <[email-masked]>
Date: Thu, 28 Feb 2013 05:30:14 +0000

Our HTML5 Labs HTTP/2.0 prototype has been updated to reflect the changes in the applayerprotoneg-02 internet draft. This prototype now leverages OpenSSL and Apache on the backend. 

http://html5labs.interopbridges.com/prototypes/alpn/alpn/info

The associated server patch is available as open source - http://html5labs.interopbridges.com/media/167447/alpn_patches.zip

Feedback on the code and the internet draft would be appreciated.

Brian Raymor
Microsoft Open Technologies, Inc. 
A subsidiary of Microsoft Corporation

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephan Friedl (sfriedl)
> Sent: Friday, February 22, 2013 8:43 AM
> To: [email-masked]
> Subject: [TLS] Revision draft-friedl-tls-applayerprotoneg-02 Posted