Subject: [TLS] Some missing context (was: Confirming consensus for ALPN)

From: Peter Gutmann <[email-masked]>
Date: Sat, 16 Mar 2013 02:00:30 +0000

Yoav Nir <[email-masked]> writes:

>The difference between them, is that in ALPN the client proposes a list of
>applications, and the server chooses - all in the clear. With NPN, the server
>advertises a list of applications in the clear, while the client picks one
>after the CCS - in an encrypted handshake record.

Thus my earlier comment that I vote for none of the above.  Both expose the
details of the further negotiation that's going on, and neither can be
generalised to server other purposes than protocol-negotiation.

Peter.

---

From: Yoav Nir <[email-masked]>
Date: Sat, 16 Mar 2013 02:05:48 +0000

> generalised to server other purposes than protocol-negotiation.

Well, the NPN people think their mechanism can be generalized to other extensions in that post-CCS handshake message. But perhaps this should be left to TLS 1.3

The one thing we had consensus on in the room was that "none of the above" was not an option, and neither was anything that would require another round-trip.