Subject: [TLS] [email-masked]

From: Peter Gutmann <[email-masked]>
Date: Tue, 15 Oct 2013 11:18:11 +0000

Paul Bakker <[email-masked]> writes:

>For now I've just put up a test server at: 141.138.204.107:4433
>
>Running PolarSSL 1.3.1 with Brainpool curves supported..

Thanks!  What's the procedure for ensuring that we're getting Brainpool curves
rather than fallback to something else, list the Brainpool ones first in the
hello, disable all but Brainpool curves, ... ?

Peter.

---

From: "Paul Bakker" <[email-masked]>
Date: Tue, 15 Oct 2013 13:20:17 +0200

The server enforces server preferences. I did not tweak it for brainpool
specifically at the moment.

So if you want brainpool: disable all but..

Paul

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Peter
> Gutmann
> Sent: dinsdag 15 oktober 2013 13:18
> To: <[email-masked]>
> Subject: [TLS] [email-masked]
> 
> Thanks!  What's the procedure for ensuring that we're getting Brainpool
> curves rather than fallback to something else, list the Brainpool ones
first in
> the hello, disable all but Brainpool curves, ... ?
> 
> Peter.
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Dr Stephen Henson <[email-masked]>
Date: Tue, 15 Oct 2013 12:23:54 +0100

> So if you want brainpool: disable all but..

That's what I did for the test: just used the single curve of interest in the
supported curves extension. I also double checked the debug output to see that
is was used for the ECDH temporary key.

Steve.
-- 
Dr Stephen N. Henson.
Core developer of the   OpenSSL project: http://www.openssl.org/
Freelance consultant see: http://www.drh-consultancy.co.uk/
Email: [email-masked], PGP key: via homepage.