Subject: Re: [TLS] Using Brainpool curves in TLS

From: Peter Gutmann <[email-masked]>
Date: Tue, 15 Oct 2013 10:11:18 +0000

Patrick Pelletier <[email-masked]> writes:
>On 10/14/13 8:45 AM, Johannes Merkle wrote:
>> jaust in case that someone hasn't noticed it: our draft on using the Brainpool curves in TLS has been published as RFC 7027
>> http://www.rfc-editor.org/rfc/rfc7027.txt
>
>Is support available in any TLS libraries yet?  Do we know which libraries
>are planning on adding support for Brainpool?

Present in my code but commented out due to lack of anything to test against.

Peter.

---

From: "Paul Bakker" <[email-masked]>
Date: Tue, 15 Oct 2013 12:50:25 +0200

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Peter
> Gutmann
> Sent: dinsdag 15 oktober 2013 12:11
> To: <[email-masked]>
> Subject: Re: [TLS] Using Brainpool curves in TLS
> 
> >> jaust in case that someone hasn't noticed it: our draft on using the
> >> Brainpool curves in TLS has been published as RFC 7027
> >Is support available in any TLS libraries yet?  Do we know which
> >libraries are planning on adding support for Brainpool?
> 

Chicken and egg problem :)

Our private repo has brainpool support included for PolarSSL. We are
wrapping up our release right now.
99% certainty: release of Brainpool support within 2 hours.
High certainty on correctness due to the way our library is structured and
our testing framework.

Paul