Subject: [TLS] Which browsers support signature_algorithms?

From: "Salz, Rich" <[email-masked]>
Date: Thu, 11 Sep 2014 10:38:32 -0400

My employer will have to support dual-chains for some of our customers who want to support both current browsers and older embedded devices. We're trying to figure out how to know when to present SHA-256 vs SHA-1 cert chain, and signature_algorithms seems like the cleanest way to do that.  Google hopes to have it shortly, but what about FF, IE, Opera, etc?

Replies to me will be summarized for the list.

Thanks.

--
Principal Security Engineer, Akamai Technologies
IM: [email-masked]<mailto:[email-masked]> Twitter: RichSalz

---

From: Brian Smith <[email-masked]>
Date: Thu, 11 Sep 2014 10:27:41 -0700

On Thu, Sep 11, 2014 at 7:38 AM, Salz, Rich <[email-masked]> wrote:
> My employer will have to support dual-chains for some of our customers who
> want to support both current browsers and older embedded devices. We’re
> trying to figure out how to know when to present SHA-256 vs SHA-1 cert
> chain, and signature_algorithms seems like the cleanest way to do that.
> Google hopes to have it shortly, but what about FF, IE, Opera, etc?

I think it is safe to assume that no major browser will drop support
for SHA-1-based signatures without advertising support for the
signature_algorithms extension in its TLS 1.2 ClientHello.

The thing that you are trying to implement has been discussed pretty
extensively. See [1][2][3][4][5] in particular, but you should
probably read that whole thread.

Cheers,
Brian

[1] https://groups.google.com/a/chromium.org/d/msg/security-dev/2-R4XziFc7A/mlf3RVmioCAJ
[2] https://groups.google.com/a/chromium.org/d/msg/security-dev/2-R4XziFc7A/TZyFYctjSy4J
[3] https://groups.google.com/a/chromium.org/d/msg/security-dev/2-R4XziFc7A/CvjBXJcCWa0J
[4] https://groups.google.com/a/chromium.org/d/msg/security-dev/2-R4XziFc7A/GHOe5sSteEcJ
[5] https://code.google.com/p/chromium/issues/detail?id=409901

---

From: Peter Bowen <[email-masked]>
Date: Thu, 11 Sep 2014 11:37:14 -0700

I would also suggest looking at
http://rt.openssl.org/Ticket/Display.html?id=3068&user=guest&pass=guest
for another client bug related to certificate selection.

Thanks,
Peter

On Thu, Sep 11, 2014 at 10:27 AM, Brian Smith <[email-masked]> wrote:
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls