Subject: Re: [TLS] Early code-point assignment for draft-ietf-tls-session-hash

From: "Ryan Sleevi" <[email-masked]>
Date: Thu, 4 Sep 2014 18:50:41 -0700

On Wed, August 20, 2014 10:06 pm, Joseph Salowey (jsalowey) wrote:
>  We have a request for early code point assignment for the
>  extended_master_secret extension in draft-ietf-tls-session-hash.  I've
>  asked the authors to update the draft with an IANA section including the
>  details.  If anyone has a concern with early code point assignment for
>  this draft, please respond to the list by September 3, 2014.
>
>  Thanks,
>
>  J&S
>  _______________________________________________
>  TLS mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/tls
>

Hi Joe, Eric,

Any chance that an early code point has been assigned now that the period
for discussion/concerns has closed? It would be great to be able to begin
implementing and avoiding interoperability issues.

---

From: "Joseph Salowey (jsalowey)" <[email-masked]>
Date: Fri, 5 Sep 2014 18:05:57 +0000

I've sent off a request to start the process of the assignment.  

Cheers,

Joe

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 09 Sep 2014 20:25:50 +0100

Hi all,

I've now gotten to that and plan to approve this early
allocation. Be great if the wg can finish up the draft
soon too - there's a 1 year timer that starts when IANA
do the allocation.

Cheers,
S.

---

From: Adam Langley <[email-masked]>
Date: Thu, 25 Sep 2014 17:37:58 -0700

> soon too - there's a 1 year timer that starts when IANA

Any signs of this early allocation? I don't see anything on the IANA pages.

Cheers

AGL

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 26 Sep 2014 07:59:59 +0200

>Any signs of this early allocation? I don't see anything on the IANA

That's my fault - I sent the request to the wrong alias but I fixed it yesterday when someone else pinged me so iana have it in hand now. Should be done real soon.

S.

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 27 Sep 2014 02:32:10 +0100

> Any signs of this early allocation? I don't see anything on the IANA pages.

Sorted. 23 it is. [1]

S.

[1] http://www.iana.org/assignments/tls-extensiontype-values

---

From: Adam Langley <[email-masked]>
Date: Fri, 26 Sep 2014 18:56:37 -0700

> Sorted. 23 it is. [1]

Thank you!

-- 
Adam Langley [email-masked] https://www.imperialviolet.org