Subject: Re: [TLS] The TLS_FALLBACK_SCSV time bomb (was: Re: Working Group Last Call for draft-ietf-tls-downgrade-scsv-00)

From: Peter Gutmann <[email-masked]>
Date: Sun, 19 Oct 2014 04:13:44 +0000

Andrei Popov <[email-masked]> writes:

>I think about 60-90 days or so, for those clients and servers that get
>regular updates.

... and 5,000 days for clients and servers where you have to wait for the
hardware to die in order to see an update.

(10,000 days is probably on the long side, but I still have to maintain
backwards-compatible bugfixes for SSH versions from the late 1990s in major
backbone routing gear, so we're talking a 15-year lifespan at least, which is
where the 5K days came from).

Oh, and given your affiliation, I was tempted to add: "So Microsoft are
planning to roll out an update to Windows XP then?" :-).

Peter.

---

From: Andrei Popov <[email-masked]>
Date: Mon, 20 Oct 2014 22:23:13 +0000

> ... and 5,000 days for clients and servers where you have to wait for the hardware to die in order to see an update.
You may be right; after all SSl2 is still deployed. My argument is about the clients and servers that actually get regular updates. These up-to-date clients are losing fallback to SSL3, so there's nothing to protect using SCSV (extension works fine for TLS1.0-1.3). These up-to-date servers negotiate TLS1.2 with up-to-date clients, so there seems to be little need for them to protect TLS1.0 -> SSL3 downgrade.

> Oh, and given your affiliation, I was tempted to add: "So Microsoft are planning to roll out an update to Windows XP then?" :-).
Hopefully, POODLE will help bring about the end of XP :)

Cheers,

Andrei

-----Original Message-----
From: TLS [mailto:[email-masked]] On Behalf Of Peter Gutmann
Sent: Saturday, October 18, 2014 9:14 PM
To: <[email-masked]>
Subject: Re: [TLS] The TLS_FALLBACK_SCSV time bomb (was: Re: Working Group Last Call for draft-ietf-tls-downgrade-scsv-00)

>I think about 60-90 days or so, for those clients and servers that get 

... and 5,000 days for clients and servers where you have to wait for the hardware to die in order to see an update.

(10,000 days is probably on the long side, but I still have to maintain backwards-compatible bugfixes for SSH versions from the late 1990s in major backbone routing gear, so we're talking a 15-year lifespan at least, which is where the 5K days came from).

Oh, and given your affiliation, I was tempted to add: "So Microsoft are planning to roll out an update to Windows XP then?" :-).

Peter.
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: [email-masked] (Martin Rex)
Date: Tue, 21 Oct 2014 16:36:43 +0200 (CEST)

Andrei Popov wrote:
>
>> Oh, and given your affiliation, I was tempted to add:
>> "So Microsoft are planning to roll out an update to Windows XP then?" :-).
>

Windows XP, with MSIE 7 or MSIE 8 installed is *UNAFFECTED* by Poodle,
because it will offer TLSv1.0 and not fallback to SSLv3 only.

Win7 & Win8.x Users are affected by Poodle.

-Martin

---

From: Yoav Nir <[email-masked]>
Date: Tue, 21 Oct 2014 18:28:12 +0300

> On Oct 21, 2014, at 5:36 PM, Martin Rex <[email-masked]> wrote:
> 
> Andrei Popov wrote:
>> 

As are Firefox and Chrome users of Windows XP and people whose IE has TLSv1 disabled (as was the default through SP2).

Yoav