Subject: [TLS] Products supporting TLS 1.0 & some other high-level questions

From: Watson Ladd <[email-masked]>
Date: Sun, 5 Oct 2014 19:22:21 -0700

Is the prefered path
-Adoption of TLS 1.3
-Adoption of TLS 1.2+session_hash fix
-Indefinite support for TLS 1.0 plus multiple, not widely deployed fixes.

The answer to this question affects how complex we force minimal
implementations of TLS 1.3 to be.

The other high level question is tying to X509. The current draft
requires the server and client to be identified by X509 certificates.
While this repeats what previous versions have done, X509 is not a
perfect match for all uses.

Sincerely,
Watson Ladd

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 5 Oct 2014 19:33:17 -0700

> -Indefinite support for TLS 1.0 plus multiple, not widely deployed fixes.

As a practical matter, we're likely to get at least the first two and
probably all three.

> perfect match for all uses.

As you probably know, there are TLS documents which allow for both
PGP (RFC 6091) and for raw keys (RFC 7250). I haven't studied the
matter, but I expect that they are compatible or can be made compatible
with TLS 1.3. For obvious reasons, we'll likely need to retain X.509,
but we can certainly reference/update these documents or merge them
in if people really want to.

-Ekr

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 5 Oct 2014 21:36:30 -0500

I think http/2, which many people want because of perceived efficiencies, will be a major factor for pulling TLS 1.3 especially if the latter adopts ChaCha/Poly and/or X25519.

If I were a conspiracy fan, I'd be worried about the close professional relationship between the authors of the TLS  1.3 and HTTP/2 RFC's :)

	/r$