Subject: [TLS] I-D Action: draft-ietf-tls-tls13-03.txt

From: [email-masked]
Date: Mon, 27 Oct 2014 15:14:08 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Transport Layer Security Working Group of the IETF.

        Title           : The Transport Layer Security (TLS) Protocol Version 1.3
        Authors         : Tim Dierks
                          Eric Rescorla
	Filename        : draft-ietf-tls-tls13-03.txt
	Pages           : 93
	Date            : 2014-10-27

Abstract:
   This document specifies Version 1.3 of the Transport Layer Security
   (TLS) protocol.  The TLS protocol provides communications security
   over the Internet.  The protocol allows client/server applications to
   communicate in a way that is designed to prevent eavesdropping,
   tampering, or message forgery.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tls-tls13/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-tls-tls13-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-tls-tls13-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Hubert Kario <[email-masked]>
Date: Wed, 29 Oct 2014 11:24:29 +0100

On Monday 27 October 2014 15:14:08 [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Transport Layer Security
> Working Group of the IETF.
> 
>         Title           : The Transport Layer Security (TLS) Protocol
> Version 1.3 Authors         : Tim Dierks
>                           Eric Rescorla

It's missing brainpool Elliptic Curve Groups from RFC 7027,
points 26, 27 and 28 in NamedGroup.

Is this an intentional omission?

-- 
Regards,
Hubert Kario
Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 99/71, 612 45, Brno, Czech Republic

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 29 Oct 2014 05:49:15 -0700

> Is this an intentional omission?

Semi-intentional.

In Toronto we discussed triaging the list of curves and I didn't know if the
WG wanted Brainpool on the list. I'll be sending out mail on that in a bit.

-Ekr

---

From: Thulasi <[email-masked]>
Date: Wed, 29 Oct 2014 04:39:40 -0700 (MST)

In Figure 3 (Message flow for an abbreviated handshake),
what does ClientKeyExhange message along with ClientHello signify?

Thanks,

Thulasi.

On 28 October 2014 03:40, Internet-Drafts Administrator [via IETF] <
[email-masked]> wrote:

> directories.
> _______________________________________________
> TLS mailing list
> [hidden email] <http://user/SendEmail.jtp?type=node&node=436405&i=0>
> https://www.ietf.org/mailman/listinfo/tls
>
>
> ------------------------------
>  If you reply to this email, your message will be added to the discussion
> below:
>
> http://ietf.10.n7.nabble.com/I-D-Action-draft-ietf-tls-tls13-03-txt-tp436405.html
>  To start a new topic under IETF - TLS, email
> [email-masked]
> To unsubscribe from IETF - TLS, click here
> <http://ietf.10.n7.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=240755&code=dGh1bGFzaS5nb3JpcGFydGhpQGdtYWlsLmNvbXwyNDA3NTV8ODQxODk1ODMw>
> .
> NAML
> <http://ietf.10.n7.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>

--
View this message in context: http://ietf.10.n7.nabble.com/I-D-Action-draft-ietf-tls-tls13-03-txt-tp436405p436714.html
Sent from the IETF - TLS mailing list archive at Nabble.com.

---

From: Benjamin Beurdouche <[email-masked]>
Date: Wed, 29 Oct 2014 18:50:25 +0100

Hi,

It is a typo… Anyway, it still to be decided how to handle resumption in 1.3.
We still don’t know how resumption will be modified because of the PFS problem. Maybe we will simply discard it in favour of another mechanism if the WG considers it is good enough, for instance a potential 0RTT, but from last week interim meeting I think we are far from consensus...
I don’t expect this part of the draft to end up on Eric’s todo list until the WG agree upon a concrete solution.

Cheers,
B.

> On 29 Oct 2014, at 12:39, Thulasi <[email-masked]> wrote:
> 
> On 28 October 2014 03:40, Internet-Drafts Administrator [via IETF] <[hidden email] <x-msg://6/user/SendEmail.jtp?type=node&node=436714&i=0>> wrote:
> 
> https://datatracker.ietf.org/doc/draft-ietf-tls-tls13/ <https://datatracker.ietf.org/doc/draft-ietf-tls-tls13/>
> 
> http://tools.ietf.org/html/draft-ietf-tls-tls13-03 <http://tools.ietf.org/html/draft-ietf-tls-tls13-03>
> 
> http://www.ietf.org/rfcdiff?url2=draft-ietf-tls-tls13-03 <http://www.ietf.org/rfcdiff?url2=draft-ietf-tls-tls13-03>
> 
> 
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>. 
> 
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/> 
> 
> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>
> 
> 
> If you reply to this email, your message will be added to the discussion below:
> http://ietf.10.n7.nabble.com/I-D-Action-draft-ietf-tls-tls13-03-txt-tp436405.html <http://ietf.10.n7.nabble.com/I-D-Action-draft-ietf-tls-tls13-03-txt-tp436405.html>
> To start a new topic under IETF - TLS, email [hidden email] <x-msg://6/user/SendEmail.jtp?type=node&node=436714&i=1> 
> To unsubscribe from IETF - TLS, click here <applewebdata://7E943509-4477-4511-9614-4815F8464AEB>.
> NAML <http://ietf.10.n7.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
> 
> View this message in context: Re: I-D Action: draft-ietf-tls-tls13-03.txt <http://ietf.10.n7.nabble.com/I-D-Action-draft-ietf-tls-tls13-03-txt-tp436405p436714.html>
> Sent from the IETF - TLS mailing list archive <http://ietf.10.n7.nabble.com/IETF-TLS-f240755.html> at Nabble.com.
> [email-masked]