Subject: [TLS] AD review of draft-ietf-tls-prohibiting-rc4-01

From: Stephen Farrell <[email-masked]>
Date: Tue, 25 Nov 2014 17:20:01 +0000

Hiya,

I have a question to ask before starting IETF LC. I don't
care much what answer you provide but we will be asked
later and I don't recall it being discussed here, so let's
get it out of the way:

This says there are no IANA actions, which is consistent
with how e.g. export ciphersuites were handled I think.
But would the WG like to add a column saying "deprecated"
or similar to [2]?

My assumption is the answer is "no" or at least "not in
this document" so unless the chairs tell me to hold off
again I'll start IETF LC tomorrow. (OTOH, a part of me
would be happy to see a draft that deprecated a whole
nice big pile of ciphersuites;-)

Cheers,
S.

[1] https://datatracker.ietf.org/doc/draft-ietf-tls-prohibiting-rc4/
[2]
https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-parameters-4

---

From: Yoav Nir <[email-masked]>
Date: Tue, 25 Nov 2014 19:57:56 +0200

I’d say no. Definitely not without also deprecating TLS_RSA_EXPORT_WITH_DES40_CBC_SHA, and that is out of scope for *this* document.

Perhaps, though we could add a reference to this RFC to all the ciphersuites listed in appendix A?  I see that many ciphersuites already have more than one reference listed.

Yoav

> On Nov 25, 2014, at 7:20 PM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls