Subject: [TLS] Pull request for removing renegotiation

From: Eric Rescorla <[email-masked]>
Date: Fri, 7 Nov 2014 13:38:22 -0800

Per WG discussion in YYZ, here is a pull request to remove renegotiation.

https://github.com/tlswg/tls13-spec/pull/88

-Ekr

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Sat, 8 Nov 2014 14:29:31 -0500

The current changes remove hello_request from the HandshakeType enum,
but then it is still referenced in the description of no_renegotiation
alert.

This changeset avoids reintroducing the value for the enum, but still
clarifies when the client should send a no_renegotiation alert.
---
 draft-ietf-tls-tls13.md | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/draft-ietf-tls-tls13.md b/draft-ietf-tls-tls13.md
index 14ec39a..5a66e40 100644
--- a/draft-ietf-tls-tls13.md
+++ b/draft-ietf-tls-tls13.md
@@ -1432,7 +1432,8 @@ user_canceled
   by a close_notify.  This message is generally a warning.
 
 no_renegotiation
-: Sent by the client in response to a hello request or by the server
+: Sent by the client in response to a hello request (a Handshake
+  message where msg_type is 0) or by the server
   in response to a client hello after initial handshaking. Versions
   of TLS prior to TLS 1.3 supported renegotiation of a previously
   established connection; TLS 1.3 removes this feature. When the
-- 
2.1.1

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Sat, 8 Nov 2014 14:29:30 -0500

In 1.2 and earlier, the no_renegotiation alert is "always a warning".

Under the current proposal, in TLS 1.3 it is "always fatal".

I (think i) understand the scope of these statements, but i worry that
"always" can be interpreted more broadly than intended.
---
 draft-ietf-tls-tls13.md | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/draft-ietf-tls-tls13.md b/draft-ietf-tls-tls13.md
index 729fa3a..14ec39a 100644
--- a/draft-ietf-tls-tls13.md
+++ b/draft-ietf-tls-tls13.md
@@ -1435,8 +1435,8 @@ no_renegotiation
 : Sent by the client in response to a hello request or by the server
   in response to a client hello after initial handshaking. Versions
   of TLS prior to TLS 1.3 supported renegotiation of a previously
-  established connection; TLS 1.3 removes this feature. This
-  message is always fatal.
+  established connection; TLS 1.3 removes this feature. When the
+  protocol version is TLS 1.3, this message is a fatal alert.
 
 unsupported_extension
 : sent by clients that receive an extended server hello containing
-- 
2.1.1