Subject: [TLS] MS14-066 and the TLS premaster secret version check

From: Yuhong Bao <[email-masked]>
Date: Tue, 25 Nov 2014 03:07:22 -0800

Has the incorrect premaster secret version check described in this been fixed in MS14-066:
http://www.ietf.org/mail-archive/web/tls/current/msg08139.html

Yuhong Bao

---

From: Yuhong Bao <[email-masked]>
Date: Tue, 25 Nov 2014 11:15:50 -0800

Adding Andrei Popov to To: list

----------------------------------------
> From: [email-masked]
> To: [email-masked]; [email-masked]
> Date: Tue, 25 Nov 2014 03:07:22 -0800
> Subject: [TLS] MS14-066 and the TLS premaster secret version check
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Andrei Popov <[email-masked]>
Date: Tue, 25 Nov 2014 23:43:03 +0000

Hi Yuhong,

The interop problem related to premaster secret version check is resolved in Win8 and above.

MS14-066 is not related: it fixes a few security issues we found internally.

Cheers,

Andrei

-----Original Message-----
From: TLS [mailto:[email-masked]] On Behalf Of Yuhong Bao
Sent: Tuesday, November 25, 2014 3:07 AM
To: [email-masked]; [email-masked]
Subject: [TLS] MS14-066 and the TLS premaster secret version check

Yuhong Bao

---

From: Yuhong Bao <[email-masked]>
Date: Tue, 25 Nov 2014 16:37:43 -0800

I asked because it backported a lot of Win8.1 SChannel in addition to the security fixes.
To be honest, they screwed up the backport of the new GCM cipher suites anyway, 
and to fix this will require a new SChannel, right?

> From: [email-masked]
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [TLS] MS14-066 and the TLS premaster secret version check
> Date: Tue, 25 Nov 2014 23:43:03 +0000
>
> Hi Yuhong,
>

---

From: Andrei Popov <[email-masked]>
Date: Wed, 26 Nov 2014 01:13:58 +0000

> I asked because it backported a lot of Win8.1 SChannel in addition to the security fixes.

In addition to security fixes, MS14-066 includes a back-port of cipher suites added by KB 2919355 (http://support.microsoft.com/kb/2919355).

Unfortunately, MS14-066 includes the wrong version of a kernel binary, so it only adds the new ciphers for user-mode SSPI callers. When a kermel-mode SSPI caller (e.g. HTTP.SYS) negotiates one of the newly added cipher suites, the connection fails at the end of the handshake. Update 3018238 disables these new cipher suites, for now.

> To be honest, they screwed up the backport of the new GCM cipher suites anyway, and to fix this will require a new SChannel, right?

I expect that there will be a new update that will include the correct binaries, so the new cipher suites will work for the kernel-mode SSPI callers.

Cheers,

Andrei

-----Original Message-----
From: Yuhong Bao [mailto:[email-masked]] 
Sent: Tuesday, November 25, 2014 4:38 PM
To: Andrei Popov; [email-masked]; [email-masked]
Subject: RE: [TLS] MS14-066 and the TLS premaster secret version check

I asked because it backported a lot of Win8.1 SChannel in addition to the security fixes.
To be honest, they screwed up the backport of the new GCM cipher suites anyway, and to fix this will require a new SChannel, right?

---

From: Yuhong Bao <[email-masked]>
Date: Tue, 25 Nov 2014 17:17:31 -0800

The point was that since a new version of SChannel will be shipped with the new update anyway,
it should be easy to backport the fix for the TLS premaster secret version check to this new version.

> Date: Wed, 26 Nov 2014 01:13:58 +0000
>

---

From: Andrei Popov <[email-masked]>
Date: Wed, 26 Nov 2014 17:47:09 +0000

> The point was that since a new version of SChannel will be shipped with the new update anyway, ...

Per my previous message, this is not necessarily the case. A new update may just include the kernel binary that was missed the first time around. No need to touch schannel.dll to fix the problem with the ciphers.

Cheers,

Andrei

-----Original Message-----
From: Yuhong Bao [mailto:[email-masked]] 
Sent: Tuesday, November 25, 2014 5:18 PM
To: Andrei Popov; [email-masked]; [email-masked]
Subject: RE: [TLS] MS14-066 and the TLS premaster secret version check

The point was that since a new version of SChannel will be shipped with the new update anyway, it should be easy to backport the fix for the TLS premaster secret version check to this new version.

---

From: Yuhong Bao <[email-masked]>
Date: Wed, 26 Nov 2014 10:49:18 -0800

Yea, I realized it now. But I forgot to mention that they also made the mistake of using DHE_RSA key exchange for AES GCM when the other cipher suites uses ECDHE_RSA. I expect at some point that AES GCM with ECDHE_RSA key exchange will be backported, like what Win10 tech preview has already.

> Date: Wed, 26 Nov 2014 17:47:09 +0000
>