Subject: [TLS] Issue 472: Remove non-closure warning alerts

From: Eric Rescorla <[email-masked]>
Date: Sat, 9 Jul 2016 05:49:13 -0700

In general, TLS stacks handle warning alerts badly aside from the defined
alerts
that are explicitly non-fatal ("close_notify", etc.). Many just close the
connection
so it's not safe to send one.

I would suggest that we instead adopt the following semantic:

- All alerts mean connection close.
- Fatal means that you should report an error to the application
  (e.g., return -1 in a sockets-style API) and abort immediately.
- Warning means that you should report a "normal" end of data
  (e.g., return 0 in a sockets-style API) except in the case of
end_of_early_data
  and in the case of close_notify, send your own close_notify
- Any alerts except the ones specifically listed as "warning" MUST be
treated
  as fatal regardless.

This is more or less what people do anyway.

If people are in favor of this, I will prepare a PR.

-Ekr

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 9 Jul 2016 14:37:20 +0000

> If people are in favor of this, I will prepare a PR.

+1

---

From: David Benjamin <[email-masked]>
Date: Sat, 09 Jul 2016 18:49:41 +0000

+1

David

---

From: Subodh Iyengar <[email-masked]>
Date: Sat, 9 Jul 2016 20:03:05 +0000

+1

Subodh
________________________________
From: TLS [[email-masked]] on behalf of David Benjamin [[email-masked]]
Sent: Saturday, July 09, 2016 11:49 AM
To: Salz, Rich; Eric Rescorla; [email-masked]
Subject: Re: [TLS] Issue 472: Remove non-closure warning alerts

+1

+1

David

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 10 Jul 2016 09:38:13 -0700

Can be found in:
https://github.com/tlswg/tls13-spec/pull/530

On Sat, Jul 9, 2016 at 1:03 PM, Subodh Iyengar <[email-masked]> wrote:

> +1
>
> Subodh
> ------------------------------
> *From:* TLS [[email-masked]] on behalf of David Benjamin [
> [email-masked]]
> *Sent:* Saturday, July 09, 2016 11:49 AM
> *To:* Salz, Rich; Eric Rescorla; [email-masked]
> *Subject:* Re: [TLS] Issue 472: Remove non-closure warning alerts
>