Subject: [TLS] Terminology clarification around SSL & TLS

From: Julien ÉLIE <[email-masked]>
Date: Wed, 31 Aug 2016 09:35:38 +0200

Hi all,

Following a recent discussion about how to name the successor of TLS 
1.2, I wish to share an idea about a possible terminology clarification.
I believe it could help to conciliate people understanding of SSL & TLS.

We would have 3 notions:
1/ the technology,
2/ the protocols,
3/ the protocol versions.

The technology is SSL, and is sometimes also refered to as SSL/TLS.  
(Note that bare TLS is not a technology.)

The protocols are:
- deprecated eponym SSL,
- TLS,
- DTLS.

The protocol versions are:
- 1.0, 2.0 and 3.0 for SSL,
- 1.0, 1.1, 1.2 and 2.0 for TLS,
- 1.0, 1.2 and 2.0 for DTLS.

Any comments about that proposal?

-- 
Julien ÉLIE

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Wed, 31 Aug 2016 12:44:02 -0400

> (Note that bare TLS is not a technology.)

please no.  the technology is TLS.  The time for us to have made the
other decision was 17 years ago before TLS 1.0 was formalized.

i would like to continue to be able to say unambiguously that all known
versions of SSL are badly broken and should be avoided.  Let's not muddy
those waters further.

         --dkg

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 31 Aug 2016 17:39:37 +0000

> versions of SSL are badly broken and should be avoided.  Let's not muddy

+1

--  
Senior Architect, Akamai Technologies
IM: [email-masked] Twitter: RichSalz

---

From: Andrei Popov <[email-masked]>
Date: Wed, 31 Aug 2016 17:50:20 +0000

+1. Let's not use a proprietary protocol name for a standard protocol. Conveniently, all SSL is broken now, long live TLS!

-----Original Message-----
From: TLS [mailto:[email-masked]] On Behalf Of Salz, Rich
Sent: Wednesday, August 31, 2016 10:40 AM
To: Daniel Kahn Gillmor <[email-masked]>; Julien ÉLIE <[email-masked]>; [email-masked]
Subject: Re: [TLS] Terminology clarification around SSL & TLS

> i would like to continue to be able to say unambiguously that all 
> known versions of SSL are badly broken and should be avoided.  Let's 
> not muddy those waters further.

+1

_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: Dave Garrett <[email-masked]>
Date: Wed, 31 Aug 2016 15:27:52 -0400

+1