Subject: Re: [TLS] [Editorial Errata Reported] RFC5246 (4750)

From: Sean Turner <[email-masked]>
Date: Wed, 24 Aug 2016 15:45:23 -0400

I created an issue for this in the tls13 repo so that we can settle on whether or not we need to change.

spt

> On Jul 28, 2016, at 10:59, Benjamin Kaduk <[email-masked]> wrote:
> 
> Jeff Hodges came up with a slightly different proposed rewording at
> https://www.ietf.org/mail-archive/web/tls/current/msg19092.html the last time this came up, which apparently was just a mail on the list and not an erratum submission.
> 
> -Ben
> 
> On 07/26/2016 08:40 PM, RFC Errata System wrote:
>> The following errata report has been submitted for RFC5246,
>> "The Transport Layer Security (TLS) Protocol Version 1.2".
>> 
>> --------------------------------------
>> You may review the report below and at:
>> 
>> http://www.rfc-editor.org/errata_search.php?rfc=5246&eid=4750
>> 
>> 
>> --------------------------------------
>> Type: Editorial
>> Reported by: Adrien de Croy 
>> <[email-masked]>
>> 
>> 
>> Section: 4.3 Vectors
>> 
>> Original Text
>> -------------
>> The length of
>>    an encoded vector must be an even multiple of the length of a single
>>    element (for example, a 17-byte vector of uint16 would be illegal).
>> 
>> Corrected Text
>> --------------
>> The length of
>>    an encoded vector must be a whole multiple of the length of a single
>>    element (for example, a 17-byte vector of uint16 would be illegal).
>> 
>> Notes
>> -----
>> Original text implies vectors can only contain even (0,2,4,6,8...) numbers of elements.  The example does not resolve this but indicates the intent is that parts of elements are not allowed. It is clear from other examples that odd numbers of elements are permitted.
>> 
>> Instructions:
>> -------------
>> This erratum is currently posted as "Reported". If necessary, please
>> use "Reply All" to discuss whether it should be verified or
>> rejected. When a decision is reached, the verifying party (IESG)
>> can log in to change the status and edit the report, if necessary. 
>> 
>> --------------------------------------
>> RFC5246 (draft-ietf-tls-rfc4346-bis-10)
>> --------------------------------------
>> Title               : The Transport Layer Security (TLS) Protocol Version 1.2
>> Publication Date    : August 2008
>> Author(s)           : T. Dierks, E. Rescorla
>> Category            : PROPOSED STANDARD
>> Source              : Transport Layer Security
>> Area                : Security
>> Stream              : IETF
>> Verifying Party     : IESG
>> 
>> _______________________________________________
>> TLS mailing list
>> 
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Sean Turner <[email-masked]>
Date: Wed, 24 Aug 2016 15:46:59 -0400

And there’s the link to that issue:

https://github.com/tlswg/tls13-spec/issues/587

spt

> On Aug 24, 2016, at 15:45, Sean Turner <[email-masked]> wrote:
>