Subject: [TLS] [Technical Errata Reported] RFC4492 (4783)

From: RFC Errata System <[email-masked]>
Date: Fri, 19 Aug 2016 10:13:46 -0700 (PDT)

The following errata report has been submitted for RFC4492,
"Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4492&eid=4783

--------------------------------------
Type: Technical
Reported by: Florent Tatard <[email-masked]>

Section: 5.7

Original Text
-------------
Actions of the sender:

   The client selects an ephemeral ECDH public key corresponding to the
   parameters it received from the server according to the ECKAS-DH1
   scheme from IEEE 1363 [6].  It conveys this information to the client
   in the ClientKeyExchange message using the format defined above.

Corrected Text
--------------
Actions of the sender:

   The client selects an ephemeral ECDH public key corresponding to the
   parameters it received from the server according to the ECKAS-DH1
   scheme from IEEE 1363 [6].  It conveys this information to the server
   in the ClientKeyExchange message using the format defined above.

Notes
-----
The client conveys data to the server, not itself.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4492 (draft-ietf-tls-ecc-12)
--------------------------------------
Title               : Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS)
Publication Date    : May 2006
Author(s)           : S. Blake-Wilson, N. Bolyard, V. Gupta, C. Hawk, B. Moeller
Category            : INFORMATIONAL
Source              : Transport Layer Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Sean Turner <[email-masked]>
Date: Tue, 23 Aug 2016 21:19:48 -0400

This looks correct, but I’d change the “type” to editorial.  Unless anybody disagrees with by next Monday, I’ll ask Stephen to accept this.

I’ve also submitted an issue in the 4492bis github repo to get this fixed in the new draft.  I’d submit a PR, but I’m still digging out from being absent last week.

spt

> On Aug 19, 2016, at 13:13, RFC Errata System <[email-masked]> wrote:
>

---

From: Xiaoyin Liu <[email-masked]>
Date: Wed, 24 Aug 2016 04:08:40 +0000

Why is the type editorial? According to [1], an editorial errata is "a spelling, grammar, punctuation, or syntax error that does not affect the technical meaning". Although the mistake in RFC4492 is clearly a typo, I think it does affect the technical meaning. So I would prefer to leave the type as technical.

[1] https://www.rfc-editor.org/errata-definitions/

Best,

Xiaoyin

________________________________
From: TLS <[email-masked]> on behalf of Sean Turner <[email-masked]>
Sent: Tuesday, August 23, 2016 9:19 PM
To: <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Kathleen Moriarty; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [TLS] [Technical Errata Reported] RFC4492 (4783)

This looks correct, but I'd change the "type" to editorial.  Unless anybody disagrees with by next Monday, I'll ask Stephen to accept this.

I've also submitted an issue in the 4492bis github repo to get this fixed in the new draft.  I'd submit a PR, but I'm still digging out from being absent last week.

spt

> "Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS)".

_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: Sean Turner <[email-masked]>
Date: Wed, 24 Aug 2016 10:38:05 -0400

I think it ought to editorial because I don't think an implementer would have gotten it wrong; it's  been like that for a decade and it's in a paragraph talking about what the client returns in an CKE.  The important part here is that we get it fixed.  Yaron already has it fixed in the 4492bis draft.

spt

> On Aug 24, 2016, at 00:08, Xiaoyin Liu <[email-masked]> wrote:
>

---

From: Bodo Moeller <[email-masked]>
Date: Wed, 24 Aug 2016 16:51:27 +0200

Sean Turner <[email-masked]>:

> I think it ought to editorial because I don't think an implementer would
> have gotten it wrong;
>

It's also not strictly technically wrong. The client TLS implementation
hands the ClientKeyExchange message to the component of the client that
actually sends something to the server, and in that step, the client indeed
"conveys [...] information to the client in the ClientKeyExchange message":
that's certainly not something that implementors need to be told about, and
it's not what the authors of the specification meant to tell implementors,
but it's still correct. (It's also not strictly necessary to tell the
reader here that the ClientKeyExchange message will be sent to the server
-- it's not as if this element of the protocol would be underspecified if
we didn't have this information here.)

So, I certainly think that this really is a purely editorial error.

Bodo

---

From: Watson Ladd <[email-masked]>
Date: Wed, 24 Aug 2016 08:47:03 -0700

On Wed, Aug 24, 2016 at 7:51 AM, Bodo Moeller <[email-masked]> wrote:
> but it's still correct. (It's also not strictly necessary to tell the reader
> here that the ClientKeyExchange message will be sent to the server -- it's
> not as if this element of the protocol would be underspecified if we didn't
> have this information here.)

No, this is wrong. There is a client and there is a server, and
whatever internal arrangements are made are epiphenominal from the
perspective of this standard. I doubt anyone was confused by what it
said, but either way it needs to get fixed, and our trichotomizing is
not helping with this.

-- 
"Man is born free, but everywhere he is in chains".
--Rousseau.

---

From: Bodo Moeller <[email-masked]>
Date: Wed, 24 Aug 2016 18:32:50 +0200

> perspective of this standard.

They certainly are, but that just means that, in that (unintended) reading
of the spec, it's using very contrived language to discuss something that's
not subject to being specified here per se (where more commonly you'd find
informal language describing the "inner thoughts" of the implantation).

> I doubt anyone was confused by what it
> said, but either way it needs to get fixed,

Exactly. My point is just that, either way, it can be seen as an editorial
error rather than a technical one, so there's no need to block the erratum
on that decision

Bodo

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 24 Aug 2016 14:50:05 +0000

Strongly agree this is an editorial fix, not a technical one.

---

From: Russ Housley <[email-masked]>
Date: Wed, 24 Aug 2016 13:09:18 -0400

I agree this is an editorial errata, not a technical one.

---

From: Xiaoyin Liu <[email-masked]>
Date: Wed, 24 Aug 2016 17:31:10 +0000

Thank you everyone for your explanation! Now I see why it is editorial.

Xiaoyin

________________________________
From: TLS <[email-masked]> on behalf of Bodo Moeller <[email-masked]>
Sent: Wednesday, August 24, 2016 12:32:50 PM
To: Watson Ladd
Cc: [email-masked]; [email-masked]; Kathleen Moriarty; Chris Hawk; Nelson B Bolyard; <[email-masked]>; [email-masked]
Subject: Re: [TLS] [Technical Errata Reported] RFC4492 (4783)

> perspective of this standard.

They certainly are, but that just means that, in that (unintended) reading of the spec, it's using very contrived language to discuss something that's not subject to being specified here per se (where more commonly you'd find informal language describing the "inner thoughts" of the implantation).

> said, but either way it needs to get fixed,

Exactly. My point is just that, either way, it can be seen as an editorial error rather than a technical one, so there's no need to block the erratum on that decision

Bodo

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 24 Aug 2016 15:57:55 -0400

Thank you for verifying the errata.  I changed the status to verified
after marking it as editorial.

There is another errata on this RFC, 4633.  Is that errata correct?

Best regards,
Kathleen

On Wed, Aug 24, 2016 at 1:31 PM, Xiaoyin Liu <[email-masked]> wrote:
> Cc: [email-masked]; [email-masked]; Kathleen Moriarty; Chris
> Hawk; Nelson B Bolyard; <[email-masked]>; [email-masked]

-- 

Best regards,
Kathleen

---

From: Sean Turner <[email-masked]>
Date: Wed, 24 Aug 2016 16:16:32 -0400

> On Aug 24, 2016, at 15:57, Kathleen Moriarty <[email-masked]> wrote:
> 

How about you mark it as “held for document update”.  I believe the 4492bis draft will address 4633.

spt