Subject: [TLS] early IANA code point assignment request for draft-ietf-tls-ecdhe-psk-aead

From: Sean Turner <[email-masked]>
Date: Tue, 9 Aug 2016 14:45:05 -0400

All,

We've received a request for early IANA assignments for the 6 cipher suites listed in https://datatracker.ietf.org/doc/draft-ietf-tls-ecdhe-psk-aead/.  Please respond before August 23rd if you have concerns about early code point assignment for these cipher suites. 

J&S

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Aug 2016 13:42:30 +1000

> We've received a request for early IANA assignments for the 6 cipher suites listed in https://datatracker.ietf.org/doc/draft-ietf-tls-ecdhe-psk-aead/.  Please respond before August 23rd if you have…

Did that request provide justification?  I know that we've done this a
fair bit recently, but is there a reason why these can't wait for the
docs to at least pass WGLC?

---

From: Nikos Mavrogiannopoulos <[email-masked]>
Date: Wed, 10 Aug 2016 11:33:33 +0200

On Tue, 2016-08-09 at 14:45 -0400, Sean Turner wrote:
> All,
> 
> We've received a request for early IANA assignments for the 6 cipher
> suites listed in https://datatracker.ietf.org/doc/draft-ietf-tls-ecdh
> e-psk-aead/.  Please respond before August 23rd if you have concerns
> about early code point assignment for these cipher suites. 

I have previously raised an issue [0] on these ciphersuites. The same
requirement was noted also by Peter Dettman as something special in
[1]. However, there has been no reaction from the authors (now in CC).

regards,
Nikos

[0]. https://mailarchive.ietf.org/arch/msg/tls/4PZsc_Dy-aT299BYrlBKvZs0BOQ
[1]. https://mailarchive.ietf.org/arch/msg/tls/onEkdgH30eZgWs8v5Rp-CUqCHds

---

From: Martin Thomson <[email-masked]>
Date: Fri, 12 Aug 2016 16:29:00 +1000

Looking at those emails, I am prompted to wonder if anyone can justify
the existence of a ciphersuite with a double-sized key and half-sized
authentication tag.  RFC 6655 doesn't really explain how that is a
useful thing.

On 10 August 2016 at 19:33, Nikos Mavrogiannopoulos <[email-masked]> wrote:
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls