Subject: [TLS] IANA Alert registry does not include ALPN alert

From: Hubert Kario <[email-masked]>
Date: Fri, 26 Aug 2016 15:52:22 +0200

The IANA TLS Alert Registry[1] does not include the 
no_application_protocol(120) alert from RFC7301[2] (a.k.a. Application-Layer 
Protocol Negotiation Extension)

What's the procedure to fix it?

 1 - https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-parameters-6
 2 - https://tools.ietf.org/html/rfc7301#section-3.2
-- 
Regards,
Hubert Kario
Senior Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 99/71, 612 45, Brno, Czech Republic

---

From: Xiaoyin Liu <[email-masked]>
Date: Fri, 26 Aug 2016 14:27:32 +0000

I guess the reason is that this new alert is not mentioned in the IANA Considerations section in RFC7301. I don’t know how to fix it though.

Best,

Xiaoyin

From: Hubert Kario<mailto:[email-masked]>
Sent: Friday, August 26, 2016 10:03
To: [email-masked]<mailto:[email-masked]>
Subject: [TLS] IANA Alert registry does not include ALPN alert

Web: www.cz.redhat.com<http://www.cz.redhat.com>

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 26 Aug 2016 07:41:28 -0700

I believe the chairs are preparing an IANA update RFC. We can cram it in
there.

-Ekr

On Fri, Aug 26, 2016 at 7:27 AM, Xiaoyin Liu <[email-masked]> wrote:

> I guess the reason is that this new alert is not mentioned in the IANA
> Considerations section in RFC7301. I don’t know how to fix it though.
>
>
>
> Best,
>
> Xiaoyin
>
>
>
>
>
>
>
> *From: *Hubert Kario <[email-masked]>
> *Sent: *Friday, August 26, 2016 10:03
> *To: [email-masked]
> *Subject: *[TLS] IANA Alert registry does not include ALPN alert
>
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>
>