Subject: [TLS] [Technical Errata Reported] RFC7301 (5176)

From: RFC Errata System <[email-masked]>
Date: Wed, 1 Nov 2017 22:24:24 -0700 (PDT)

The following errata report has been submitted for RFC7301,
"Transport Layer Security (TLS) Application-Layer Protocol Negotiation Extension".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5176

--------------------------------------
Type: Technical
Reported by: Ilya Grigorik <[email-masked]>

Section: 6

Original Text
-------------
IANA Considerations

Corrected Text
--------------
+Protocol:  HTTP/1.0
+Protocol:  HTTP/0.9

Notes
-----
RFC does not register ALPN identifiers for http/0.9 or http/1.0.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7301 (draft-ietf-tls-applayerprotoneg-05)
--------------------------------------
Title               : Transport Layer Security (TLS) Application-Layer Protocol Negotiation Extension
Publication Date    : July 2014
Author(s)           : S. Friedl, A. Popov, A. Langley, E. Stephan
Category            : PROPOSED STANDARD
Source              : Transport Layer Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Thomson <[email-masked]>
Date: Thu, 2 Nov 2017 16:30:20 +1100

I don't think that this is an appropriate way to request the addition
of ALPN labels.  If it is important to register ALPN labels for these
protocols, then the HTTP working group can produce a short document
defining them.

On Thu, Nov 2, 2017 at 4:24 PM, RFC Errata System
<[email-masked]> wrote:
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Ilya Grigorik <[email-masked]>
Date: Wed, 1 Nov 2017 22:33:48 -0700

Wasn't sure what the appropriate route is.. apologies for the noise. :-)

Should I file a bug against http-wg
<https://github.com/httpwg/http-extensions/issues>?

---

From: Martin Thomson <[email-masked]>
Date: Thu, 2 Nov 2017 16:54:06 +1100

Maybe you should start by sending an email to the working group,
explaining why you think that this is necessary.  Because the way to
change these things ultimately is to publish an RFC.

On Thu, Nov 2, 2017 at 4:33 PM, Ilya Grigorik <[email-masked]> wrote:
> Should I file a bug against http-wg?
>
>
>

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 2 Nov 2017 06:57:02 -0700

See:
https://tools.ietf.org/html/rfc7301#section-6

" This registry operates under the "Expert Review" policy as defined in
   [RFC5226 <https://tools.ietf.org/html/rfc5226>]. The designated expert
is advised to encourage the
   inclusion of a reference to a permanent and readily available
   specification that enables the creation of interoperable
   implementations of the identified protocol."

And then see:
https://tools.ietf.org/html/rfc8126#section-1.2

And finally:
https://www.iana.org/help/protocol-registration

-Ekr

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 2 Nov 2017 14:40:58 +0000

➢     Maybe you should start by sending an email to the working group,
    explaining why you think that this is necessary.  Because the way to
    change these things ultimately is to publish an RFC.

Well, someone might have to write an RFC.  I forget details of how this registry was set up.  It might be as simple as someone saying “yup”

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 2 Nov 2017 07:45:32 -0700

It's Expert Review with the requirement being a stable reference.

-Ekr

On Thu, Nov 2, 2017 at 7:40 AM, Salz, Rich <[email-masked]> wrote:

> Well, someone might have to write an RFC.  I forget details of how this
> registry was set up.  It might be as simple as someone saying “yup”
>

---

From: Sean Turner <[email-masked]>
Date: Thu, 2 Nov 2017 10:52:08 -0400

yep

> On Nov 2, 2017, at 10:45, Eric Rescorla <[email-masked]> wrote:
>