Subject: [TLS] Interim meeting information

From: Christopher Wood <[email-masked]>
Date: Wed, 12 Sep 2018 07:58:43 -0700

Below is an agenda for Friday's virtual interim meeting, followed by
the meeting information. This information is also available online
[1]. We are looking for volunteers to lead each agenda item. Please
respond on list or to the chairs directly if you're willing to do so.

Best,
Chris, Joe, and Sean

[1] https://datatracker.ietf.org/doc/agenda-interim-2018-tls-01-tls-01/

~~~

Agenda: Discuss draft-ietf-tls-dnssec-chain-extension
- Problem statement recap.
- Discuss client-side caching semantics and use cases.
- Discuss need (or not) for extension pinning.
- Review some open gaps:
  - Lack of a port number in the client side of the extension.
  - Lack of downgrade protection for existing applications.
  - Lack of discussion of virtual hosting.
  - Needless complexity from RRset ordering requirements.
- Wrap up.

~~~

Topic: TLS Virtual Interim
Date and Time:
Friday, September 14, 2018 10:00 am, Pacific Daylight Time (San
Francisco, GMT-07:00)
Friday, September 14, 2018 1:00 pm, Eastern Daylight Time (New York, GMT-04:00)
Event number: 642 489 356
Event password: 1234
Event address for attendees:
https://ietf.webex.com/ietf/onstage/g.php?MTID=e02cf108b5a24e348e10132497d5def9

-------------------------------------------------------
Audio conference information
-------------------------------------------------------
Call-in toll number (US/Canada): 1-650-479-3208
Access code: 642 489 35

https://www.webex.com

IMPORTANT NOTICE: This Webex service includes a feature that allows
audio and any documents and other materials exchanged or viewed during
the session to be recorded. You should inform all meeting attendees
prior to recording if you intend to record the meeting. Please note
that any such recordings may be subject to discovery in the event of
litigation.

---

From: Viktor Dukhovni <[email-masked]>
Date: Wed, 12 Sep 2018 11:22:23 -0400

> On Sep 12, 2018, at 10:58 AM, Christopher Wood <[email-masked]> wrote:
> 

Thanks.  There are a couple of other gaps that'll come to the surface
once we get down to work updating the text.  One issue is that draft-07
did not require SNI from the client, and seemed to suggest that the
server can in any case use the extension with some default name, even
when it does not recognize the client's SNI.  This does not work at
all well.

I've prepared text that makes SNI a co-requisite with dnssec_chain,
and ensures that the server's extension matches the requested SNI
or else the server decline the dnssec_chain extension.

Denial of existence text needed a bit more polish, ...  Also
added some commentary on the need for NSEC records any time
something in the chain is synthesized via wildcard records.
(Some the background discussion is the git commit message).

When we actually get to discuss virtual hosting use-cases it'll
be useful point out a deviation from RFC7671, which suggests
CNAME chasing that simply can't be made to work with dnssec_chain,
(and that's OK).

I've also realized that even with direct DNS lookups the CNAME chasing
in RFC7671 is not a good fit for some applications (like web browsers)
where the server's post-handshake behaviour depends on the SNI
value.  It seems that 7671 had a bit too much SMTP tunnel-vision, ...
sorry about that.  So we could even consider a couple of updates
to 7671 here, or in a separate draft.  Perhaps the UKS draft from
Richard Barnes could get adopted and also fix-up the CNAME
issues from 7671.

-- 
	Viktor.

---

From: Richard Barnes <[email-masked]>
Date: Fri, 14 Sep 2018 12:03:51 -0500

I am getting "This link to the event is no longer valid" from the below
link, and I hear folks are having PSTN trouble as well.  Are there some
different coordinates we should be using?

On Wed, Sep 12, 2018 at 9:59 AM Christopher Wood <
[email-masked]> wrote:

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Fri, 14 Sep 2018 13:05:24 -0400

> https://ietf.webex.com/ietf/onstage/g.php?MTID=e02cf108b5a24e348e10132497d5def9

when i visit this, i get a page that says::

    This link to the event is no longer valid.

    This may be because the event has been cancelled, the event has
    ended, or you have been removed from the invitation list. For more
    information, contact the host.

I think the interim should havejust started now.  any pointers for how
to connect?

   --dkg

---

From: Joseph Salowey <[email-masked]>
Date: Fri, 14 Sep 2018 10:05:22 -0700

We are having some technical issues getting the meeting started.

---

From: "Kaduk, Benjamin" <[email-masked]>
Date: Fri, 14 Sep 2018 17:06:25 +0000

I know Webex has been having some issues today; we're working on finding working coordinates.

-Ben

On 9/14/18, 12:04, "Richard Barnes" <[email-masked]> wrote:

    I am getting "This link to the event is no longer valid" from the below link, and I hear folks are having PSTN trouble as well.  Are there some different coordinates we should be using?

    On Wed, Sep 12, 2018 at 9:59 AM Christopher Wood <[email-masked]> wrote:

    Best,
    Chris, Joe, and Sean
    
    [1] 
    https://datatracker.ietf.org/doc/agenda-interim-2018-tls-01-tls-01/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_agenda-2Dinterim-2D2018-2Dtls-2D01-2Dtls-2D01_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=sssDLkeEEBWNIXmTsdpw8TZ3tAJx-Job4p1unc7rOhM&m=NbypeR4MDN_rZA08gNN0BJhYKZ8HB76a90ykv-Hv2Bk&s=-97FFwHAjwPmmg7j4jnRX1b8JIj7MxgRWoK5qX6Vbd0&e=>
    
    ~~~

    ~~~
    
    https://ietf.webex.com/ietf/onstage/g.php?MTID=e02cf108b5a24e348e10132497d5def9 <https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.webex.com_ietf_onstage_g.php-3FMTID-3De02cf108b5a24e348e10132497d5def9&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=sssDLkeEEBWNIXmTsdpw8TZ3tAJx-Job4p1unc7rOhM&m=NbypeR4MDN_rZA08gNN0BJhYKZ8HB76a90ykv-Hv2Bk&s=EPFWIXz_ogT2vEgV6f7R2k6_dz6W6lUG1OiQ_1oJJ34&e=>

    https://www.webex.com <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.webex.com&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=sssDLkeEEBWNIXmTsdpw8TZ3tAJx-Job4p1unc7rOhM&m=NbypeR4MDN_rZA08gNN0BJhYKZ8HB76a90ykv-Hv2Bk&s=aPz2Q1tknX1f185yZDX5IKI2hOwkOXvd1JuQYr0O_M0&e=>

    _______________________________________________
    TLS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tls <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=sssDLkeEEBWNIXmTsdpw8TZ3tAJx-Job4p1unc7rOhM&m=NbypeR4MDN_rZA08gNN0BJhYKZ8HB76a90ykv-Hv2Bk&s=a42hzG7ur4papj08mMQmlp_ACAwjjHgYAq4btHYvWrk&e=>

---

From: Viktor Dukhovni <[email-masked]>
Date: Fri, 14 Sep 2018 13:12:47 -0400

Just like everyone else, waiting for further instructions for a working
conference bridge...

-- 
	Viktor.

---

From: Joseph Salowey <[email-masked]>
Date: Fri, 14 Sep 2018 10:13:23 -0700

It should be working now.

On Fri, Sep 14, 2018 at 10:05 AM, Daniel Kahn Gillmor <[email-masked]
> wrote:

---

From: Richard Barnes <[email-masked]>
Date: Fri, 14 Sep 2018 12:15:42 -0500

I just tried again, same error.

On Fri, Sep 14, 2018 at 12:15 PM Joseph Salowey <[email-masked]> wrote:

> On Fri, Sep 14, 2018 at 10:05 AM, Daniel Kahn Gillmor <
> [email-masked]> wrote:
>

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 14 Sep 2018 10:16:24 -0700

Still doesn't work for mel

---

From: Joseph Salowey <[email-masked]>
Date: Fri, 14 Sep 2018 10:19:41 -0700

You need to use the webex meeting number:

642 489 356

---

From: "Kaduk, Benjamin" <[email-masked]>
Date: Fri, 14 Sep 2018 17:20:34 +0000

You can go to https://ietf.webex.com and follow links to the ongoing TLS virtual interim.
You'll have to go through the register workflow and use the password of 1234, but it worked for me.

On 9/14/18, 12:17, "Eric Rescorla" <[email-masked]> wrote:

    On Fri, Sep 14, 2018 at 10:13 AM, Joseph Salowey 
    <[email-masked]> wrote:

    On Fri, Sep 14, 2018 at 10:05 AM, Daniel Kahn Gillmor 
    <[email-masked]> wrote:
    
    On Wed 2018-09-12 07:58:43 -0700, Christopher Wood wrote:
    https://ietf.webex.com/ietf/onstage/g.php?MTID=e02cf108b5a24e348e10132497d5def9 <https://urldefense.proofpoint.com/v2/url?u=https-3A__ietf.webex.com_ietf_onstage_g.php-3FMTID-3De02cf108b5a24e348e10132497d5def9&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=sssDLkeEEBWNIXmTsdpw8TZ3tAJx-Job4p1unc7rOhM&m=ptv628H2hQQzV-CQS0xFRam7DVHU0hcxWtIcy5dq5EU&s=MAUv0CXei2sbkce_WbpYbvWtXfVrBzLQ2MJIoJbCU5k&e=>

    

       --dkg
    
    _______________________________________________
    TLS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tls <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=sssDLkeEEBWNIXmTsdpw8TZ3tAJx-Job4p1unc7rOhM&m=ptv628H2hQQzV-CQS0xFRam7DVHU0hcxWtIcy5dq5EU&s=50iSJZmnEuz7dgTJicaMRXCyLaR1ueYnxxqaMh-jMUg&e=>

    

    
    _______________________________________________
    TLS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tls <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=sssDLkeEEBWNIXmTsdpw8TZ3tAJx-Job4p1unc7rOhM&m=ptv628H2hQQzV-CQS0xFRam7DVHU0hcxWtIcy5dq5EU&s=50iSJZmnEuz7dgTJicaMRXCyLaR1ueYnxxqaMh-jMUg&e=>

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Fri, 14 Sep 2018 13:19:30 -0400

> It should be working now.

sorry, i'm still getting the same error message i got before.

any pointers?  same URL as in the untrimmed text below, same failure response :/

if that doesn't work for anyone else, i propose an alternative:

I've just made up the URL https://meet.jit.si/tls13-interim, which can
also be accessed via:

           To join your meeting, dial one of these numbers and then enter this PIN:
           3586666305#

             Country	Dial-in Numbers
           Australia   +61.8.7150.1136
           Brazil	    +55.21.3500.0112
           Canada	    +1.647.243.6108
           France	    +33.1.84.88.6478
           Germany	    +49.89.380.38719
           Japan	    +81.3.4510.2372
           Spain	    +34.932.205.409
           Switzerland +41.61.588.0496
           UK	    +44.121.468.3154
           US	    +1.512.402.2718

    --dkg

> On Fri, Sep 14, 2018 at 10:05 AM, Daniel Kahn Gillmor <[email-masked]> wrote:
>

---

From: Nico Williams <[email-masked]>
Date: Fri, 14 Sep 2018 12:20:48 -0500

Shortening the link works.  Basically you can join with the app or web
page, using the 9-digit meeting code.  You end up having to register.

---

From: "Kaduk, Benjamin" <[email-masked]>
Date: Fri, 14 Sep 2018 17:33:25 +0000

Anyone who is still trying to join and cannot, please reply to me and/or the chairs.

-Ben

On 9/14/18, 12:23, "Nico Williams" <[email-masked]> wrote: