Subject: [TLS] IANA changes for draft-ietf-tls-exported-authenticator

From: "Christopher Wood" <[email-masked]>
Date: Wed, 02 Oct 2019 13:58:19 -0700

Hi folks,

draft-ietf-tls-exported-authenticator requires some IANA changes that were not discussed during WGLC. The proposed changes are below. Please let the list know by next week (10/9) if you object to them, and if so, please explain why.

> Value: EXPORTER-server authenticator handshake context
> DTLS-OK: Y
> Recommended: Y
> Reference: [ RFC-to-be ]
> Note: 
> 
> Value: EXPORTER-client authenticator finished key
> DTLS-OK: Y
> Recommended: Y
> Reference: [ RFC-to-be ]
> Note: 
> 
> Value: EXPORTER-server authenticator finished key
> DTLS-OK: Y
> Recommended: Y
> Reference: [ RFC-to-be ]
> Note: 

Thanks!
Chris

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 10 Oct 2019 12:28:14 +1100

These are pretty long strings.  That means more hash iterations to get these values.  Are we comfortable with that?

Even excluding the prefix, the first is 39 octets.

On Thu, Oct 3, 2019, at 06:58, Christopher Wood wrote:
> Hi folks,
> 
> draft-ietf-tls-exported-authenticator requires some IANA changes that 
> were not discussed during WGLC. The proposed changes are below. Please 
> let the list know by next week (10/9) if you object to them, and if so, 
> please explain why.
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Christopher Wood" <[email-masked]>
Date: Fri, 11 Oct 2019 09:52:42 -0700

On Wed, Oct 9, 2019, at 6:28 PM, Martin Thomson wrote:
> These are pretty long strings.  That means more hash iterations to get 
> these values.  Are we comfortable with that?

For what it's worth, I think it's fine. I'm not overly concerned with more hash iterations here. 

Best,
Chris

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 23 Oct 2019 07:57:19 +0200

Hearing no major objections, we're moving forward with this proposal.

Best,
Chris