Subject: [TLS] Adoption call for draft-rescorla-tls-ctls

From: Sean Turner <[email-masked]>
Date: Thu, 21 Nov 2019 13:36:25 +0800

At IETF 105, ekr presented cTLS (Compact TLS) [0][1][2] to both the TLS WG and the LAKE BOF, which is now a chartered WG [3].  After some discussions, the ADs suggested [4] that the TLS WG consider whether this draft be adopted as a TLS WG item. LAKE could then later specify/refer/adopt/profile it, as appropriate. The authors revised cTLS and presented the revised draft at IETF 106 [5].  At IETF 106 there was support for adoption of cTLS as a WG item.  To confirm this on the list: if you believe that the TLS WG should not adopt this as a WG item, then please let the chairs know by posting a message to the TLS list by 2359 UTC 13 December 2019 (and say why).

NOTE:
: If the consensus is that this draft should be adopted as a WG item, then this will necessarily result in a WG rechartering discussions.  We would have gotten to this rechartering discussion anyway now that DTLS 1.3 is progressing out of the WG.

Thanks,
Chris, Joe, and Sean

[0] https://datatracker.ietf.org/doc/slides-105-tls-sessa-ctls/
[1] https://datatracker.ietf.org/doc/draft-rescorla-tls-ctls/
[2] https://github.com/ekr/draft-rescorla-tls-ctls
[3] https://datatracker.ietf.org/doc/draft-rescorla-tls-ctls/
[4] https://mailarchive.ietf.org/arch/msg/lake/kACwW7PXrmTRa4PvXQ0TA34xCvk
[5] https://datatracker.ietf.org/meeting/106/materials/slides-106-tls-compact-tls-13-00.pdf

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 20 Nov 2019 21:37:54 -0800

I support adoption.

On Wed, Nov 20, 2019 at 9:36 PM Sean Turner <[email-masked]> wrote:

> At IETF 105, ekr presented cTLS (Compact TLS) [0][1][2] to both the TLS WG
> and the LAKE BOF, which is now a chartered WG [3].  After some discussions,
> the ADs suggested [4] that the TLS WG consider whether this draft be
> adopted as a TLS WG item. LAKE could then later specify/refer/adopt/profile
> it, as appropriate. The authors revised cTLS and presented the revised
> draft at IETF 106 [5].  At IETF 106 there was support for adoption of cTLS
> as a WG item.  To confirm this on the list: if you believe that the TLS WG
> should not adopt this as a WG item, then please let the chairs know by
> posting a message to the TLS list by 2359 UTC 13 December 2019 (and say
> why).
>
> NOTE:
> : If the consensus is that this draft should be adopted as a WG item, then
> this will necessarily result in a WG rechartering discussions.  We would
> have gotten to this rechartering discussion anyway now that DTLS 1.3 is
> progressing out of the WG.
>
> Thanks,
> Chris, Joe, and Sean
>
> [5]
> https://datatracker.ietf.org/meeting/106/materials/slides-106-tls-compact-tls-13-00.pdf
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Valery Smyslov" <[email-masked]>
Date: Thu, 21 Nov 2019 08:44:21 +0300

Hi,

I think it's a good starting point. I support adoption.

Regards,
Valery.

> the ADs suggested [4] that the TLS WG consider whether this draft be
adopted
> as a TLS WG item. LAKE could then later specify/refer/adopt/profile it, as
> appropriate. The authors revised cTLS and presented the revised draft at
IETF
> 106 [5].  At IETF 106 there was support for adoption of cTLS as a WG item.
To
> confirm this on the list: if you believe that the TLS WG should not adopt
this as
> a WG item, then please let the chairs know by posting a message to the TLS
list
> by 2359 UTC 13 December 2019 (and say why).
> 
> NOTE:
this
> will necessarily result in a WG rechartering discussions.  We would have
gotten
> to this rechartering discussion anyway now that DTLS 1.3 is progressing
out of
> the WG.
> [4]
> https://mailarchive.ietf.org/arch/msg/lake/kACwW7PXrmTRa4PvXQ0TA34xCv
> k
> [5]
https://datatracker.ietf.org/meeting/106/materials/slides-106-tls-compact-
> tls-13-00.pdf

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 21 Nov 2019 13:46:47 +0800

On Thu, Nov 21, 2019, at 13:36, Sean Turner wrote:
> [...] if you believe that the TLS WG should not adopt this as a 
> WG item, then please let the chairs know by posting a message to the 
> TLS list by 2359 UTC 13 December 2019 (and say why).

I know you want dissent, but I thought I would instead express support.

---

From: Ben Schwartz <[email-masked]>
Date: Thu, 21 Nov 2019 13:48:13 +0800

I support adoption.

In the spirit of Ted Hardie's comment on dividing the work into pieces, I'd
like to suggest putting the handshake compression into a separate draft
from the certificate compression.  Certificate compression could be made
into an extension that is usable in standard TLS. cTLS can then use it for
free with extension monomorphization.

On Thu, Nov 21, 2019 at 1:38 PM Eric Rescorla <[email-masked]> wrote:

>> At IETF 105, ekr presented cTLS (Compact TLS) [0][1][2] to both the TLS
>> WG and the LAKE BOF, which is now a chartered WG [3].  After some
>> discussions, the ADs suggested [4] that the TLS WG consider whether this
>> draft be adopted as a TLS WG item. LAKE could then later
>> specify/refer/adopt/profile it, as appropriate. The authors revised cTLS
>> and presented the revised draft at IETF 106 [5].  At IETF 106 there was
>> support for adoption of cTLS as a WG item..  To confirm this on the list:
>> if you believe that the TLS WG should not adopt this as a WG item, then
>> please let the chairs know by posting a message to the TLS list by 2359 UTC
>> 13 December 2019 (and say why).
>>
>> NOTE:
>> : If the consensus is that this draft should be adopted as a WG item,
>> then this will necessarily result in a WG rechartering discussions.  We
>> would have gotten to this rechartering discussion anyway now that DTLS 1.3
>> is progressing out of the WG.
>>
>> Thanks,
>> Chris, Joe, and Sean
>>
>> https://mailarchive.ietf.org/arch/msg/lake/kACwW7PXrmTRa4PvXQ0TA34xCvk
>> [5]

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 21 Nov 2019 05:53:33 +0000

>    I think it's a good starting point. I support adoption.
 
Strongly agree.

---

From: Karthik Bhargavan <[email-masked]>
Date: Thu, 21 Nov 2019 06:57:28 +0100

I support adoption.

> On 21 Nov 2019, at 06:53, Salz, Rich <[email-masked]> wrote:
>

---

From: "Christopher Wood" <[email-masked]>
Date: Thu, 21 Nov 2019 14:14:12 +0800

I support adoption.

Best,
Chris (no hat)

---

From: Benjamin Beurdouche <[email-masked]>
Date: Thu, 21 Nov 2019 07:17:37 +0100

I support adoption.
B.

> On Nov 21, 2019, at 6:53 AM, Salz, Rich <[email-masked]> wrote:
> 
> 
>>

---

From: Paul Yang <[email-masked]>
Date: Thu, 21 Nov 2019 14:26:19 +0800

I’d like to see it’s adopted as well. It’s important for low-bandwidth scenarios.

Regards,

Paul Yang

> On Nov 21, 2019, at 2:17 PM, Benjamin Beurdouche <[email-masked]> wrote:
> 
> I support adoption.
> B.
>

---

From: Thomas Fossati <[email-masked]>
Date: Thu, 21 Nov 2019 06:45:22 +0000

Yes, please.

On 21/11/2019, 05:36, "TLS on behalf of Sean Turner" <[email-masked] on behalf of [email-masked]> wrote:

    NOTE:

    Thanks,
    Chris, Joe, and Sean

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: CJ Tjhai <[email-masked]>
Date: Thu, 21 Nov 2019 02:59:07 -0500

+1 support this adoption.

CJ

> On 21 Nov 2019, at 05:36, Sean Turner <[email-masked]> wrote:
>

-- 

PQ Solutions Limited (trading as ‘Post-Quantum’) is a private limited 
company incorporated in England and Wales with registered number 06808505.

This email is meant only for the intended recipient. If you have received 
this email in error, any review, use, dissemination, distribution, or 
copying of this email is strictly prohibited. Please notify us immediately 
of the error by return email and please delete this message from your 
system. Thank you in advance for your cooperation.

For more information 
about Post-Quantum, please visit www.post-quantum.com 
<http://www.post-quantum.com>.

In the course of our business relationship, 
we may collect, store and transfer information about you. Please see our 
privacy notice at www.post-quantum.com/privacy-notice 
<http://www.post-quantum.com/privacy-notice> to learn about how we use this 
information.

---

From: Tommy Pauly <[email-masked]>
Date: Thu, 21 Nov 2019 16:02:37 +0800

I support adoption of this work.

Best,
Tommy

> On Nov 21, 2019, at 1:36 PM, Sean Turner <[email-masked]> wrote:
>

---

From: Richard Barnes <[email-masked]>
Date: Thu, 21 Nov 2019 17:33:54 +0800

I also support adoption.

On the question of how the work should be factored: It is true that this
work comprises 3-4 fairly separable technologies.  However, they have in
common that they need to be pre-agreed between the client and server
(except possibly the "known certificates" mechanism, which could possibly
be negotiated with ClientHello/ServerHello extensions).  So my inclination
would be to push forward with this work as a unified package, and consider
later whether certain mechanisms are separable.

--Richard

On Thu, Nov 21, 2019 at 1:48 PM Ben Schwartz <bemasc=
[email-masked]> wrote:

> I support adoption.
>
> In the spirit of Ted Hardie's comment on dividing the work into pieces,
> I'd like to suggest putting the handshake compression into a separate draft
>>> specify/refer/adopt/profile it, as appropriate.. The authors revised cTLS

---

From: Dmitry Belyavsky <[email-masked]>
Date: Thu, 21 Nov 2019 12:45:55 +0300

I support the adoption.

-- 
SY, Dmitry Belyavsky

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Thu, 21 Nov 2019 16:38:40 +0000

+1, support adoption.

From: TLS <[email-masked]> On Behalf Of Dmitry Belyavsky
Sent: Thursday, November 21, 2019 4:46 AM
To: Sean Turner <[email-masked]>
Cc: TLS List <[email-masked]>
Subject: Re: [TLS] Adoption call for draft-rescorla-tls-ctls

I support the adoption.

On Thu, Nov 21, 2019 at 8:36 AM Sean Turner <[email-masked]<mailto:[email-masked]>> wrote:

   At IETF 105, ekr presented cTLS (Compact TLS) [0][1][2] to both the TLS WG and the LAKE BOF, which is now a chartered WG [3].  After some discussions, the ADs suggested [4] that the TLS WG consider whether this draft be adopted as a TLS WG item. LAKE could then later specify/refer/adopt/profile it, as appropriate. The authors revised cTLS and presented the revised draft at IETF 106 [5].  At IETF 106 there was support for adoption of cTLS as a WG item..  To confirm this on the list: if you believe that the TLS WG should not adopt this as a WG item, then please let the chairs know by posting a message to the TLS list by 2359 UTC 13 December 2019 (and say why).

   NOTE:

   Thanks,
   Chris, Joe, and Sean

   [email-masked]<mailto:[email-masked]>

   --

   SY, Dmitry Belyavsky

---

From: Daniel Migault <[email-masked]>
Date: Fri, 22 Nov 2019 10:19:51 +0800

I clearly support the adoption of the work, but it seems important to
ensure cTLS integrates or remains in line with the work on compression that
has been accomplished at the IETF - SCHC defined in lpwan might be a
starting point. It also seems important to me that cTLS defines mechanisms
that could be reused as TLS 1.3 evolves.

Yours,
Daniel

On Fri, Nov 22, 2019 at 12:39 AM Panos Kampanakis (pkampana) <
[email-masked]> wrote:

> +1, support adoption.
>
>
>
> *From:* TLS <[email-masked]> *On Behalf Of * Dmitry Belyavsky
> *Sent:* Thursday, November 21, 2019 4:46 AM
> *To:* Sean Turner <[email-masked]>
> *Cc:* TLS List <[email-masked]>
> *Subject:* Re: [TLS] Adoption call for draft-rescorla-tls-ctls
>
>
>
> I support the adoption.
>
>
>
> as a WG item..  To confirm this on the list: if you believe that the TLS WG

---

From: <[email-masked]>
Date: Fri, 22 Nov 2019 11:33:39 +0800

Hi Daniel

Although inappropriate to discuss at the time of the adoption call I wanted to point out that I looked at SCHC and was surprised to learn that it is more than a compression scheme but also includes a protocol for adding reliability. In my reading is essentially a replacement for 6lowpan. Unfortunately, this design decision does not make it a well suited mechanism for a generic compression mechanism. I am happy to get convinced otherwise. 

Ciao

Hannes

From: TLS <[email-masked]> On Behalf Of Daniel Migault
Sent: Friday, November 22, 2019 10:20 AM
To: Panos Kampanakis (pkampana) <[email-masked]>
Cc: TLS List <[email-masked]>
Subject: Re: [TLS] Adoption call for draft-rescorla-tls-ctls

I clearly support the adoption of the work, but it seems important to ensure cTLS integrates or remains in line with the work on compression that has been accomplished at the IETF - SCHC defined in lpwan might be a starting point. It also seems important to me that cTLS defines mechanisms that could be reused as TLS 1.3 evolves.

Yours, 

Daniel

On Fri, Nov 22, 2019 at 12:39 AM Panos Kampanakis (pkampana) <[email-masked] <mailto:[email-masked]> > wrote:

+1, support adoption.

From: TLS <[email-masked] <mailto:[email-masked]> > On Behalf Of Dmitry Belyavsky
Sent: Thursday, November 21, 2019 4:46 AM
To: Sean Turner <[email-masked] <mailto:[email-masked]> >
Cc: TLS List <[email-masked] <mailto:[email-masked]> >
Subject: Re: [TLS] Adoption call for draft-rescorla-tls-ctls

I support the adoption.

On Thu, Nov 21, 2019 at 8:36 AM Sean Turner <[email-masked] <mailto:[email-masked]> > wrote:

NOTE:

Thanks,
Chris, Joe, and Sean

[email-masked] <mailto:[email-masked]> 

-- 

SY, Dmitry Belyavsky

_______________________________________________
TLS mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/tls

---

From: <[email-masked]>
Date: Fri, 22 Nov 2019 11:36:34 +0800

As a co-author of the document I am in favor of adopting it. I have started
on implementation work on top of Mbed TLS already and plan to continue doing
that work as it progresses through the IETF.

-----Original Message-----
From: TLS <[email-masked]> On Behalf Of Sean Turner
Sent: Thursday, November 21, 2019 1:36 PM
To: TLS List <[email-masked]>
Subject: [TLS] Adoption call for draft-rescorla-tls-ctls

At IETF 105, ekr presented cTLS (Compact TLS) [0][1][2] to both the TLS WG
and the LAKE BOF, which is now a chartered WG [3].  After some discussions,
the ADs suggested [4] that the TLS WG consider whether this draft be adopted
as a TLS WG item. LAKE could then later specify/refer/adopt/profile it, as
appropriate. The authors revised cTLS and presented the revised draft at
IETF 106 [5].  At IETF 106 there was support for adoption of cTLS as a WG
item.  To confirm this on the list: if you believe that the TLS WG should
not adopt this as a WG item, then please let the chairs know by posting a
message to the TLS list by 2359 UTC 13 December 2019 (and say why).

NOTE:

Thanks,
Chris, Joe, and Sean

https://datatracker.ietf.org/meeting/106/materials/slides-106-tls-compact-tl
s-13-00.pdf

---

From: Jim Schaad <[email-masked]>
Date: Sun, 24 Nov 2019 20:49:30 -0800

I believe that this is a worth while effort.  I will be willing to review
and might contribute text

-----Original Message-----
From: TLS <[email-masked]> On Behalf Of Sean Turner
Sent: Wednesday, November 20, 2019 9:36 PM
To: TLS List <[email-masked]>
Subject: [TLS] Adoption call for draft-rescorla-tls-ctls

NOTE:

Thanks,
Chris, Joe, and Sean

---

From: Antoine Delignat-Lavaud <[email-masked]>
Date: Mon, 25 Nov 2019 13:49:45 +0000

I support this effort, and would like to point out that we have recently 
published a paper [1] and a collection of tools [2] to automatically 
verify the security (non malleability) of binary message formats, which 
we successfully applied to all of TLS [3] (which revealed many small 
specification errors in published RFCs, and some malleability problems 
such as the lack of tag in the CertificateEntry type).

Using this collection of tool, if the new compact format is expressible 
in the same syntax as TLS, it may be relatively easy to formally prove 
that the compact and full message formats are equivalent (and most of 
the proof is automated), by writing the lifting from the compact to the 
full specification types. I also recommend to formalize the message 
format specification language such that automatic tools like ours can 
directly operate over the formats described in the RFC.

[1] 
https://www.microsoft.com/en-us/research/uploads/prod/2019/05/20190601everparse.pdf
[2] https://github.com/project-everest/everparse
[3] 
https://github.com/project-everest/mitls-fstar/blob/dev/src/parsers/Parsers.rfc

Best,

Antoine

On 2019-11-21 05:36, Sean Turner wrote:
> At IETF 105, ekr presented cTLS (Compact TLS) [0][1][2] to both the
> TLS WG and the LAKE BOF, which is now a chartered WG [3].  After some
> discussions, the ADs suggested [4] that the TLS WG consider whether
> this draft be adopted as a TLS WG item. LAKE could then later
> specify/refer/adopt/profile it, as appropriate. The authors revised
> cTLS and presented the revised draft at IETF 106 [5].  At IETF 106
> there was support for adoption of cTLS as a WG item.  To confirm this
> on the list: if you believe that the TLS WG should not adopt this as a
> then this will necessarily result in a WG rechartering discussions.
> We would have gotten to this rechartering discussion anyway now that
> DTLS 1.3 is progressing out of the WG.
> 
> Thanks,
> Chris, Joe, and Sean
>

---

From: Daniel Migault <[email-masked]>
Date: Mon, 25 Nov 2019 14:11:14 -0500

Hi Hannes,

My reading is that only compression/decompression applies to our case.
Fragmentation is optional and only concerns ipv6. I did not intent to make
the comment at an inappropriate time, but if so, please consider it when it
is appropriate.

Yours,
Daniel

On Thu, Nov 21, 2019 at 10:34 PM <[email-masked]> wrote:

> Hi Daniel
>
>
>
> Although inappropriate to discuss at the time of the adoption call I
> wanted to point out that I looked at SCHC and was surprised to learn that
> it is more than a compression scheme but also includes a protocol for
> adding reliability. In my reading is essentially a replacement for 6lowpan.
> Unfortunately, this design decision does not make it a well suited
> mechanism for a generic compression mechanism. I am happy to get convinced
> otherwise.
>
>
>
> Ciao
>
> Hannes
>
>
>
> *From:* TLS <[email-masked]> *On Behalf Of *Daniel Migault
> *Sent:* Friday, November 22, 2019 10:20 AM
> *To:* Panos Kampanakis (pkampana) <[email-masked]>
> *From:* TLS <[email-masked]> *On Behalf Of *Dmitry Belyavsky