Subject: [TLS] Omitting length in DTLS

From: "Martin Thomson" <[email-masked]>
Date: Thu, 07 Nov 2019 11:18:28 +1100

> Omitting the length field MUST only be used for data which is protected with one of the application_traffic_secret values, and not for messages protected with either [sender]_handshake_traffic_sercret or [sender]_early_traffic_secret values.  When using an [sender]_application_traffic_secret for message protection, Implementations MAY include the length field at their discretion.

This seems like an unnecessarily strong requirement that I couldn't find any discussion about.  I do seem to remember some discussion, but I couldn't find it.

QUIC says something different: any packet without a length has to go at the end of the datagram.  Why does DTLS not say the same?

(QUIC also says something about mixing packets from different connections in the same datagram: don't.  That probably an addition worth including.)

---

From: Ilari Liusvaara <[email-masked]>
Date: Thu, 7 Nov 2019 08:28:12 +0200

On Thu, Nov 07, 2019 at 11:18:28AM +1100, Martin Thomson wrote:
> > Omitting the length field MUST only be used for data which is
> > protected with one of the application_traffic_secret values, and
> > not for messages protected with either [sender]_handshake_traffic_sercret
> > or [sender]_early_traffic_secret values.  When using an
> > [sender]_application_traffic_secret for message protection,
> > Implementations MAY include the length field at their discretion.
> 
> This seems like an unnecessarily strong requirement that I couldn't
> find any discussion about.  I do seem to remember some discussion,
> but I couldn't find it.

I actually tried finding rationale for that, and concluded that it was
likely a mistake.

Originally the requirement was not to use short headers with initial
handshake packets. That was sensible back then.

However, when unified headers were introduced, that requirement was
changed to prohibition of omitting length, which does not make much
sense to me. And I could not find any arguments for it.

-Ilari

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 9 Nov 2019 13:55:17 -0800

I have filed a PR to fix this.

On Wed, Nov 6, 2019 at 10:28 PM Ilari Liusvaara <[email-masked]>
wrote:

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>