Subject: Re: [TLS] [Editorial Errata Reported] RFC8446 (6120)

From: Peter Wu <[email-masked]>
Date: Fri, 1 May 2020 11:34:55 +0200

Hi,

In what way is the old writing ambiguous? The semantics of that text is
correct. If someone wants to run the TLS protocol on paper as
"transport", it would still maintain the same guarantees. And "paper" is
arguably not a transport protocol or "stream delivery service".

I suggest to reject this change.

Kind regards,
Peter

On Fri, Apr 24, 2020 at 02:05:04AM -0700, RFC Errata System wrote:
> The following errata report has been submitted for RFC8446,
> "The Transport Layer Security (TLS) Protocol Version 1.3".
> 
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid6120
> 
> --------------------------------------
> Type: Editorial
> Reported by: Ben Smyth <[email-masked]>
> 
> Section: 1
> 
> Original Text
> -------------
> the underlying transport is a reliable, in-order data stream
> 
> 
> 
> Corrected Text
> --------------
> the underlying transport layer is a reliable, in-order stream delivery service
> 
> or
> 
> the underlying transport protocol is a reliable, in-order stream delivery service
> 
> or similar
> 
> Notes
> -----
> Similar elsewhere
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party  
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC8446 (draft-ietf-tls-tls13-28)
> --------------------------------------
> Title               : The Transport Layer Security (TLS) Protocol Version 1.3
> Publication Date    : August 2018
> Author(s)           : E. Rescorla
> Category            : PROPOSED STANDARD
> Source              : Transport Layer Security
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: William Whyte <[email-masked]>
Date: Fri, 1 May 2020 12:32:44 +0000

I think the point here is that the "transport" isn't a "data stream", the transport is what the data stream is delivered over. I agree that the intended meaning is clear, but the text as written isn't correct, and if the draft's being corrected anyway this should be corrected too.

William

-----Original Message-----
From: TLS <[email-masked]> On Behalf Of Peter Wu
Sent: Friday, May 1, 2020 5:35 AM
To: RFC Errata System <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [EXT] Re: [TLS] [Editorial Errata Reported] RFC8446 (6120)

Hi,

Kind regards,
Peter