Subject: [TLS] Bikeshedding ECHO

From: "Christopher Wood" <[email-masked]>
Date: Thu, 07 May 2020 15:52:43 -0700

Erik raises some compelling reasons to change the name from ECHO to... something else less confusing or misleading [1]. Candidates from the PR include ETCH (Encrypted TLS Client Hello), ECH, and EHELLO. Since the HTTPSSVC draft aims for WGLC before IETF 108, it would be good if we got this bikeshedding out of the way now. To that end, if you have an opinion on the name and whether or not we should change it, please share it! 

Thanks,
Chris (no hat)

[1] https://github.com/tlswg/draft-ietf-tls-esni/issues/232

---

From: Tommy Pauly <[email-masked]>
Date: Thu, 07 May 2020 16:03:12 -0700

ECHO is more fun to say, but I do see how it can be confusing (sounding like some sort of ping) when out of the context of TLS.

To that end, I’d have a minor preference for “ETCH”.

Thanks,
Tommy

> On May 7, 2020, at 3:52 PM, Christopher Wood <[email-masked]> wrote:
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 8 May 2020 00:05:45 +0100

On 07/05/2020 23:52, Christopher Wood wrote:
> Erik raises some compelling reasons to change the name from ECHO
> to... something else less confusing or misleading [1]. Candidates
> from the PR include ETCH (Encrypted TLS Client Hello), ECH, and
> EHELLO. Since the HTTPSSVC draft aims for WGLC before IETF 108, it
> would be good if we got this bikeshedding out of the way now. To that
> end, if you have an opinion on the name and whether or not we should
> change it, please share it!

I don't care as long as it's decided asap.

S

> Thanks, Chris (no hat)
> _______________________________________________ TLS mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/tls
>

---

From: Watson Ladd <[email-masked]>
Date: Thu, 7 May 2020 19:06:52 -0400

'ELLO

-- 
"Man is born free, but everywhere he is in chains".
--Rousseau.

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 7 May 2020 23:07:51 +0000

Agree with Tommy, but don't care all that much if another gets consensus.

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 7 May 2020 20:14:22 -0400

+1 on sooner rather than later

tim
terrible at picking colors

---

From: Viktor Dukhovni <[email-masked]>
Date: Fri, 8 May 2020 00:43:10 -0400

On Thu, May 07, 2020 at 03:52:43PM -0700, Christopher Wood wrote:

> Erik raises some compelling reasons to change the name from ECHO to...
> something else less confusing or misleading [1]. Candidates from the
> PR include ETCH (Encrypted TLS Client Hello), ECH, and EHELLO. Since
> the HTTPSSVC draft aims for WGLC before IETF 108, it would be good if
> we got this bikeshedding out of the way now. To that end, if you have
> an opinion on the name and whether or not we should change it, please
> share it! 

Well, there's the Russian for "Hello": привет.  Which in a Latin
alphabet would be written "privyet" (pronounced more like pree-vyet).
The cuteness factor is that it starts with "priv" for privacy.  E.
Snowden can probably pronounce it correctly by now. :-)

-- 
    Viktor.

Looking forward to all those TLS PRIVYET messages.

---

From: Sean Turner <[email-masked]>
Date: Fri, 8 May 2020 01:59:59 -0400

> On May 7, 2020, at 19:03, Tommy Pauly <tpauly=[email-masked]> wrote:
> 

If we could just work an “a" and “sketch” into the name … I am all in.

More seriously, let’s knock this decision out by end of next week, i.e., the 15th.

spt

---

From: Rob Sayre <[email-masked]>
Date: Fri, 8 May 2020 00:12:46 -0700

> More seriously, let’s knock this decision out by end of next week, i.e.,

It doesn't matter, and I don't care what it is called.

Very few people on the planet know what this is, so leaving "ECHO" is fine
too.

thanks,
Rob

---

From: Erik Nygren <[email-masked]>
Date: Fri, 8 May 2020 12:30:37 -0400

+1 to "ETCH"

Any objections to that or concerns with that?
(Agreed it would be good to finalize this ASAP.)

On Thu, May 7, 2020 at 7:03 PM Tommy Pauly <tpauly=
[email-masked]> wrote:

> ECHO is more fun to say, but I do see how it can be confusing (sounding
> like some sort of ping) when out of the context of TLS.
>
> something else less confusing or misleading [1]. Candidates from the PR
> include ETCH (Encrypted TLS Client Hello), ECH, and EHELLO. Since the
> HTTPSSVC draft aims for WGLC before IETF 108, it would be good if we got
> this bikeshedding out of the way now. To that end, if you have an opinion
> on the name and whether or not we should change it, please share it!
> >
> > Thanks,
> > Chris (no hat)
> >

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 8 May 2020 15:38:33 -0700

I rather prefer ECHO.

-Ekr

On Fri, May 8, 2020 at 9:31 AM Erik Nygren <[email-masked]> wrote:

>> To that end, I’d have a minor preference for “ETCH”..
>>
>> Thanks,
>> Tommy
>>

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 8 May 2020 15:42:40 -0700

> I rather prefer ECHO.

Do you have some arguments to dispel the concerns about confusion, other than
your personal preference?

-Ben

---

From: Rob Sayre <[email-masked]>
Date: Fri, 8 May 2020 22:51:00 -0700

> your personal preference?

There's no confusion. I couldn't believe the issue was raised (the name
does not matter).

thanks,
Rob

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 10 May 2020 10:10:32 -0700

Hi Rob,

> There's no confusion. I couldn't believe the issue was raised (the name

I regret to say that I completely fail to understand how you can have
the confidence to make such a blanket statement ("there's no confusion") that
in principle applies to all human beings, without any apparent supporting
evidence.  If someone appears and says that they are confused, what are you
going to tell them?

-Ben

---

From: Rob Sayre <[email-masked]>
Date: Sun, 10 May 2020 12:37:55 -0700

On Sun, May 10, 2020 at 10:10 AM Benjamin Kaduk <[email-masked]> wrote:

> > > Do you have some arguments to dispel the concerns about confusion,
> other
> > > than
> evidence.

I don't believe it makes sense to demand "evidence" on a completely
subjective issue.

As I wrote in my other email in this thread, not very many people on the
planet are going to need to know what this is. I haven't run into
anyone confused as I've worked on it, and the name was presented 6 months
ago at IETF 106.

> If someone appears and says that they are confused, what are you
> going to tell them?
>

That all of the proposals collide with other meanings too (ETH, ETCH, etc).
This is one reason we expand acronyms on first use in IETF documents.

I don't think there's confusion here, but just preferences and annoyances.
The choice also doesn't matter to me.

thanks,
Rob

---

From: Nick Harper <[email-masked]>
Date: Mon, 11 May 2020 15:52:40 -0700

I see how the name ECHO can be confusing and support renaming it. All of
the proposed replacement names are fine with me.

On Sun, May 10, 2020 at 12:38 PM Rob Sayre <[email-masked]> wrote:

> That all of the proposals collide with other meanings too (ETH, ETCH,
> etc). This is one reason we expand acronyms on first use in IETF documents.
>

---

From: Carrick Bartle <[email-masked]>
Date: Mon, 11 May 2020 22:46:11 -0700

I agree that it’s misleading and potentially confusing to newcomers. 

ETCH sounds like a good alternative.

> On May 11, 2020, at 3:52 PM, Nick Harper <nharper=[email-masked]> wrote:
> 
> I see how the name ECHO can be confusing and support renaming it. All of the proposed replacement names are fine with me.
> 
> On Sun, May 10, 2020 at 12:38 PM Rob Sayre <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> On Sun, May 10, 2020 at 10:10 AM Benjamin Kaduk <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Rob,
> 
> > [email-masked] <mailto:[email-masked]>> wrote:
> > 
> I don't believe it makes sense to demand "evidence" on a completely subjective issue.
> 
> As I wrote in my other email in this thread, not very many people on the planet are going to need to know what this is. I haven't run into anyone confused as I've worked on it, and the name was presented 6 months ago at IETF 106.
>  
> That all of the proposals collide with other meanings too (ETH, ETCH, etc). This is one reason we expand acronyms on first use in IETF documents.
> 
> I don't think there's confusion here, but just preferences and annoyances. The choice also doesn't matter to me.
> 
> thanks,
> Rob
> 
> 
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>

---

From: Sean Turner <[email-masked]>
Date: Tue, 19 May 2020 08:32:05 -0400

I am glad this bikeshed was shorter than I expected. Because most people didn’t have a strong preference and there might be some (possibly small) chance of confusion, it seems like we should change the name to ETCH (Encrypted TLS Client Hello).

spt

> On May 7, 2020, at 18:52, Christopher Wood <[email-masked]> wrote:
>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 19 May 2020 05:57:21 -0700

If we must change it, let's do ECH, as the T seems entirely superfluous.
After all, it's not TSNI.

-Ekr

On Tue, May 19, 2020 at 5:32 AM Sean Turner <[email-masked]> wrote:

> I am glad this bikeshed was shorter than I expected. Because most people
> didn’t have a strong preference and there might be some (possibly small)
> chance of confusion, it seems like we should change the name to ETCH
> (Encrypted TLS Client Hello).
>
> spt
>

---

From: "Filippo Valsorda" <[email-masked]>
Date: Tue, 19 May 2020 23:18:38 -0400

As a data point, I was fairly confused when ECHO came up in conversation, and had to stop to ask what it was. I think I would have had a better chance of figuring it out from context or search if it were called ECH, but don't have a strong preference for any specific name.

ECH does have a remarkable short Wikipedia disambiguation list, FWIW. https://en.wikipedia.org/wiki/ECH

Filippo

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 20 May 2020 11:19:09 -0700

On Tue, May 19, 2020, at 8:18 PM, Filippo Valsorda wrote:
> As a data point, I was fairly confused when ECHO came up in 
> conversation, and had to stop to ask what it was. I think I would have 
> had a better chance of figuring it out from context or search if it 
> were called ECH, but don't have a strong preference for any specific 
> name.
> 

ECH also works for me.

Best,
Chris (no hat)

---

From: Erik Nygren <[email-masked]>
Date: Wed, 20 May 2020 14:34:09 -0400

ECH works for me.  (I really don't care between ECH and ETCH and thing both
are fine.)

    Erik

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 20 May 2020 20:36:53 -0700

ECH is good. Go for it!

Tommy

> On May 20, 2020, at 11:34 AM, Erik Nygren <[email-masked]> wrote:
> 
> 
> 
> ECH works for me.  (I really don't care between ECH and ETCH and thing both are fine.)
> 
>     Erik
> 
> 
>> On Wed, May 20, 2020 at 2:20 PM Christopher Wood <[email-masked]> wrote:

---

From: Erik Nygren <[email-masked]>
Date: Thu, 21 May 2020 11:52:41 -0400

Are there any objections to "ECH" or should we just go with that?
(I'd like to update the parameter name in SRVB/HTTPSSVC accordingly based
on what gets decided.)

---

From: Gary Gapinski <[email-masked]>
Date: Thu, 21 May 2020 14:48:25 -0400

> Are there any objections to "ECH" or should we just go with that?

I have no objection, but would benefit from consensus on whether it 
(ECH) is an initialism or acronym. My opinion is that it is best as an 
initialism (as is, e.g., TLS).