Subject: Re: [TLS] [Editorial Errata Reported] RFC8446 (6125)

From: Peter Wu <[email-masked]>
Date: Fri, 1 May 2020 12:30:58 +0200

Hi Ben,

Do you have a specific sentence that caused confusion for you? Both
"out-of-band" and "external" can be used interchangeably. What is
unclear about https://tools.ietf.org/html/rfc8446#section-2.2 for
example?

If you are interested in use of external PSKs, I suggest following this
work: https://tools.ietf.org/html/draft-ietf-tls-external-psk-importer

This errat report lacks context, and even if accepted, it should
probably have been a new document. I suggest rejecting it.

Kind regards,
Peter

On Fri, Apr 24, 2020 at 02:22:12AM -0700, RFC Errata System wrote:
> The following errata report has been submitted for RFC8446,
> "The Transport Layer Security (TLS) Protocol Version 1.3".
> 
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid6125
> 
> --------------------------------------
> Type: Editorial
> Reported by: Ben Smyth <[email-masked]>
> 
> Section: GLOBAL
> 
> Original Text
> -------------
> PSKs are referred to as out-of-band and external
> 
> Corrected Text
> --------------
> Referring to PSKs as either out-of-band xor external would help at least one reader
> 
> Notes
> -----
> 
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party  
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC8446 (draft-ietf-tls-tls13-28)
> --------------------------------------
> Title               : The Transport Layer Security (TLS) Protocol Version 1.3
> Publication Date    : August 2018
> Author(s)           : E. Rescorla
> Category            : PROPOSED STANDARD
> Source              : Transport Layer Security
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Ben Smyth <[email-masked]>
Date: Fri, 1 May 2020 12:57:45 +0200

Dear Peter,

On Fri, 1 May 2020 at 12:30, Peter Wu <[email-masked]> wrote:

> "out-of-band" and "external" can be used interchangeably.
>

Getting to grips with TLS 1.3 has been challenging for me! The use of
synonyms made it more difficult. I hope that the reports I have submitted
will aid others in understanding the specification. Longer-term they may
even aid the development for future documents. Many of the reports are
minor, others are preventing me from fully understanding the specification,
and several may highlight minor technical issues. They all came about
whilst writing a manual for TLS (
https://bensmyth.com/publications/2019-TLS-tutorial/), which I'm currently
extending. Since the reports are based on my private notes, I thought
sharing them (via reports) would be useful.

Best regards,

Ben