Subject: Re: [TLS] Bikeshedding ECHO

From: Sean Turner <[email-masked]>
Date: Thu, 21 May 2020 11:58:34 -0400

Okay let’s call this done! ECH it is.

spt

Sent from my iPhone

>> On May 21, 2020, at 11:53, Erik Nygren <[email-masked]> wrote:
> 
> Are there any objections to "ECH" or should we just go with that?
> (I'd like to update the parameter name in SRVB/HTTPSSVC accordingly based on what gets decided.)
> 
> 
>> On Wed, May 20, 2020 at 11:37 PM Tommy Pauly <[email-masked]> wrote:
>> ECH is good. Go for it!
>> 
>> Tommy
>> 
>>>> On May 20, 2020, at 11:34 AM, Erik Nygren <[email-masked]> wrote:
>>> 
>>> 
>>> ECH works for me.  (I really don't care between ECH and ETCH and thing both are fine.)
>>> 
>>>     Erik
>>> 
>>> 
>>>> On Wed, May 20, 2020 at 2:20 PM Christopher Wood <[email-masked]> wrote:
>>>> On Tue, May 19, 2020, at 8:18 PM, Filippo Valsorda wrote:
>>>> > As a data point, I was fairly confused when ECHO came up in 
>>>> > conversation, and had to stop to ask what it was. I think I would have 
>>>> > had a better chance of figuring it out from context or search if it 
>>>> > were called ECH, but don't have a strong preference for any specific 
>>>> > name.
>>>> > 
>>>> > ECH does have a remarkable short Wikipedia disambiguation list, FWIW. 
>>>> > https://en.wikipedia.org/wiki/ECH
>>>> 
>>>> ECH also works for me.
>>>> 
>>>> Best,
>>>> Chris (no hat)
>>>> 
>>>> _______________________________________________
>>>> TLS mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/tls
>>> _______________________________________________
>>> TLS mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/tls
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: "Christopher Wood" <[email-masked]>
Date: Thu, 21 May 2020 12:46:23 -0700

To make it official, here's a PR making that change:

   https://github.com/tlswg/draft-ietf-tls-esni/pull/236

Please have a look. I'll merge in the next day or so.

Thanks!
Chris (no hat)

On Thu, May 21, 2020, at 8:58 AM, Sean Turner wrote:
> >>> On May 20, 2020, at 11:34 AM, Erik Nygren <[email-masked] <mailto:[email-masked]>> wrote:
> >>> 
> >>>

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 21 May 2020 12:56:08 -0700

I actually already merged it :)