Subject: [TLS] What's it called

From: "Salz, Rich" <[email-masked]>
Date: Thu, 24 Jun 2021 17:31:58 +0000

I’m blanking on a term and web searches turn up too much useless info.

What is it called when we have to start using a new symmetric key because we’ve encrypted too much data with the old one?  Key exhaustion fits, but probably isn’t it.

---

From: Christopher Patton <[email-masked]>
Date: Thu, 24 Jun 2021 10:37:29 -0700

I've heard this called "rekeying". The amount of data that's safe to
authenticate and encrypt is usually called the "safety margin".

Chris P.

On Thu, Jun 24, 2021 at 10:32 AM Salz, Rich <rsalz=
[email-masked]> wrote:

> What is it called when we have to start using a new symmetric key because
> we’ve encrypted too much data with the old one?  Key exhaustion fits, but
> probably isn’t it.
>
>
>
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Dmitry Belyavsky <[email-masked]>
Date: Thu, 24 Jun 2021 19:43:12 +0200

Dear Rich,

Rekeying (https://datatracker.ietf.org/doc/html/rfc8645). For GOST, the
"key meshing" term at least was in use.

-- 
SY, Dmitry Belyavsky

---

From: Tanja Lange <[email-masked]>
Date: Thu, 24 Jun 2021 19:49:13 +0200

Do youmean key rotation or rekeying? I'd check Lukx Paterson
	https://www.isg.rhul.ac.uk/~kp/TLS-AEbounds.pdf
Limits on Authenticated Encryption Use in TLS

All the best
	Tanja

On Thu, Jun 24, 2021 at 05:31:58PM +0000, Salz, Rich wrote:
> What is it called when we have to start using a new symmetric key because we’ve
> encrypted too much data with the old one?  Key exhaustion fits, but probably
> isn’t it.
> 
>  
> 
>  
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 24 Jun 2021 17:50:43 +0000

We rekey when certain limits are hit.  Is there a common name for those limits?

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 24 Jun 2021 18:52:14 +0000

Rekey and safety margin work for my purposes.  Thanks everyone!

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 24 Jun 2021 14:03:18 -0700

I've heard the phenomenon called "exhaustion" and "rekey" the fix for it.