Subject: Re: [TLS] What's it called

From: "Paterson Kenneth" <[email-masked]>
Date: Thu, 24 Jun 2021 19:02:05 +0000

Hi Rich,

We speak of reaching data limits, and the process of changing the key has many names, e.g. key rotation, key renewal, key refreshing, key updating.

Any of those ring a bell?

Cheers

Kenny

From: TLS <[email-masked]> on behalf of "Salz, Rich" <rsalz=[email-masked]>
Date: Thursday, 24 June 2021 at 19:32
To: "[email-masked]" <[email-masked]>
Subject: [TLS] What's it called

I’m blanking on a term and web searches turn up too much useless info.

What is it called when we have to start using a new symmetric key because we’ve encrypted too much data with the old one?  Key exhaustion fits, but probably isn’t it.

---

From: Tim Bray <[email-masked]>
Date: Thu, 24 Jun 2021 12:13:16 -0700

How much data is too much?

On Thu, Jun 24, 2021 at 12:02 PM Paterson Kenneth <
[email-masked]> wrote:

> Hi Rich,
>
>
>
> We speak of reaching data limits, and the process of changing the key has
> many names, e.g. key rotation, key renewal, key refreshing, key updating.
>
>
>
> *From: *TLS <[email-masked]> on behalf of "Salz, Rich" <rsalz=
> [email-masked]>
> *Date: *Thursday, 24 June 2021 at 19:32
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[TLS] What's it called
>
>
>
> What is it called when we have to start using a new symmetric key because
> we’ve encrypted too much data with the old one?  Key exhaustion fits, but
> probably isn’t it.
>
>
>
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 25 Jun 2021 09:45:27 +1000

> How much data is too much?

https://cfrg.github.io/draft-irtf-cfrg-aead-limits/draft-irtf-cfrg-aead-limits.html

...shameless self-promotion.

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 25 Jun 2021 06:10:14 +0000

Depends on the algorithm and its parameters. Here is a recent document talking about AES algorithms limits.
https://datatracker.ietf.org/doc/html/draft-irtf-cfrg-aead-limits-02

From: TLS <[email-masked]> On Behalf Of Tim Bray
Sent: Thursday, June 24, 2021 9:13 PM
To: Paterson Kenneth <[email-masked]>
Cc: [email-masked]; Salz, Rich <rsalz=[email-masked]>
Subject: Re: [TLS] What's it called

On Thu, Jun 24, 2021 at 12:02 PM Paterson Kenneth <[email-masked]<mailto:[email-masked]>> wrote:
Hi Rich,

Cheers

Kenny

From: TLS <[email-masked]<mailto:[email-masked]>> on behalf of "Salz, Rich" <rsalz=[email-masked]<mailto:[email-masked]>>
Date: Thursday, 24 June 2021 at 19:32
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [TLS] What's it called

_______________________________________________
TLS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tls
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.