Subject: [TLS] Editorial: chronological order in ECH draft

From: Carrick Bartle <[email-masked]>
Date: Wed, 23 Jun 2021 16:04:54 -0700

Hi all,

I'm bringing https://github.com/tlswg/draft-ietf-tls-esni/issues/412 to the list since it looks like we're (hopefully) getting close to the end game with ECH.

The ECH draft is currently organized such that it describes all client behavior and then all server behavior. Personally, I find this very confusing to follow, and I'm constantly having to flip back and forth between sections (which themselves constantly refer to each other). Does anyone object to my rearranging the content to be in more of the order in which things occur rather than being divided into client and server sections? Of course, depending on how I do it, it could end up being more confusing, but I just wanted to see if people were opposed to it in principle.

Carrick

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 24 Jun 2021 09:37:31 +1000

Whatever you can do to improve the readability of this document would be greatly appreciated.  It's a complicated design and I always spend far too much time trying to find answers to my questions.  A better structure would be appreciated.

I do find that questions aren't always about behaviour.  They are also about protocol elements, and those a scattered piecemeal throughout.  So I would be disappointed if any restructuring were limited to just getting the time sequence straightened out.

On Thu, Jun 24, 2021, at 09:04, Carrick Bartle wrote:
> Hi all,
> 
> I'm bringing https://github.com/tlswg/draft-ietf-tls-esni/issues/412 to 
> the list since it looks like we're (hopefully) getting close to the end 
> game with ECH.
> 
> The ECH draft is currently organized such that it describes all client 
> behavior and then all server behavior. Personally, I find this very 
> confusing to follow, and I'm constantly having to flip back and forth 
> between sections (which themselves constantly refer to each other). 
> Does anyone object to my rearranging the content to be in more of the 
> order in which things occur rather than being divided into client and 
> server sections? Of course, depending on how I do it, it could end up 
> being *more* confusing, but I just wanted to see if people were opposed 
> to it in principle.
> 
> Carrick
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 24 Jun 2021 00:47:19 +0100

On 24/06/2021 00:37, Martin Thomson wrote:
> Whatever you can do to improve the readability of this document would
> be greatly appreciated. 

+1 though I have to admit I've really been mostly looking
at diffs at this stage - probably some new readers/coders
are needed,

S.

> It's a complicated design and I always spend
> far too much time trying to find answers to my questions.  A better
> structure would be appreciated.
> 
> I do find that questions aren't always about behaviour.  They are
> also about protocol elements, and those a scattered piecemeal
> throughout.  So I would be disappointed if any restructuring were
> limited to just getting the time sequence straightened out.
> 
>> I'm bringing
>> https://github.com/tlswg/draft-ietf-tls-esni/issues/412 to the list
>> since it looks like we're (hopefully) getting close to the end game
>> with ECH.
>> 
>> The ECH draft is currently organized such that it describes all
>> client behavior and then all server behavior. Personally, I find
>> this very confusing to follow, and I'm constantly having to flip
>> back and forth between sections (which themselves constantly refer
>> to each other). Does anyone object to my rearranging the content to
>> be in more of the order in which things occur rather than being
>> divided into client and server sections? Of course, depending on
>> how I do it, it could end up being *more* confusing, but I just
>> wanted to see if people were opposed to it in principle.
>> 
>> Carrick _______________________________________________ TLS mailing
>> list [email-masked] https://www.ietf.org/mailman/listinfo/tls
>> 
> 
> _______________________________________________ TLS mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/tls
>

---

From: Christopher Patton <[email-masked]>
Date: Wed, 23 Jun 2021 16:50:52 -0700

+1 to new readers! I think a chronological description would be a good
starting point, though like MT, I suspect there would be rearranging to do
afterwards that would break with a strictly chronological description.

Chris P.

---

From: Carrick Bartle <[email-masked]>
Date: Wed, 23 Jun 2021 19:01:23 -0700

Cool. I might leave that for a different PR, but if something along those lines seems obvious or necessary, I'll go ahead and do it.

> On Jun 23, 2021, at 4:37 PM, Martin Thomson <[email-masked]> wrote:
>

---

From: Carrick Bartle <[email-masked]>
Date: Thu, 24 Jun 2021 14:21:09 -0700

Thanks for the feedback, all!

> On Jun 23, 2021, at 4:50 PM, Christopher Patton <cpatton=[email-masked]> wrote:
> 
> +1 to new readers! I think a chronological description would be a good starting point, though like MT, I suspect there would be rearranging to do afterwards that would break with a strictly chronological description.
> 
> Chris P.
> 
> On Wed, Jun 23, 2021 at 4:48 PM Stephen Farrell <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> >> https://github.com/tlswg/draft-ietf-tls-esni/issues/412 <https://github.com/tlswg/draft-ietf-tls-esni/issues/412> to the list
> >> list [email-masked] <mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>
> >> 
> > 
> > [email-masked] <mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>
> > 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>