Subject: [TLS] esni-draft-13 suggestion

From: Stephen Farrell <[email-masked]>
Date: Tue, 3 Aug 2021 21:40:59 +0100

Hiya,

I see a bunch of activity in github that may be the precursor
to pushing out draft-13, which would be great.

One (ignorable) suggestion - as we're aiming for this draft
to be the basis for ongoing experiments, just before pushing
the publish button, it might be no harm to give people a day
or so to review the github version, on the understanding that
the editors will only accept  non-controversial editorial PRs
submitted over that short period. (And other comments/PRs
will not be accepted for -13.)

If given a day to do that, I'd prioritise it.

That said, this'd put more work on the editors, and maybe
they don't have time right now, and things can be fixed
later anyway, so it's very much ok to not do this.

(I'm suggesting this as it's been ages since I read the
whole thing through so if a few people in my situation
did a read-through we might catch stuff that'd save work
as we experiment.)

Cheers,
S.

---

From: "Christopher Wood" <[email-masked]>
Date: Tue, 03 Aug 2021 13:44:28 -0700

> will not be accepted for -13.)

Of course! We're happy to park the next version until the end of the week (or longer), if that would yield more reviews. Please send any editorial comments you have here on the list or as PRs against the draft, and we'll work to try and incorporate them.

Thanks for flagging this and offering to review, Stephen. :-)

Best,
Chris

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 3 Aug 2021 21:51:27 +0100

On 03/08/2021 21:44, Christopher Wood wrote:
> Of course! We're happy to park the next version until the end of the
> week (or longer), if that would yield more reviews. Please send any
> editorial comments you have here on the list or as PRs against the
> draft, and we'll work to try and incorporate them.

Great. I shouldn't need that long. I'll plan to do this
tomorrow (Wed). If it'd be better to wait 'till some
more PRs are merged that's fine just tell me when to
start.

Cheers,
S.

---

From: "Christopher Wood" <[email-masked]>
Date: Tue, 03 Aug 2021 13:58:41 -0700

> more PRs are merged that's fine just tell me when to

Sounds good! Feel free to start at your earliest convenience. As of now, we weren't planning any more editorial changes for -13.

Best,
Chris

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 5 Aug 2021 17:51:21 +0100

Hiya,

So I gave that a read through and created a pile of
PRs. [1] I didn't go over the appendices.

As I said, I'm fine if those are ignored - better to
get -13 out than spend ages discussing. (I'm fine with
chatting about 'em too for a bit of course.)

Cheers,
S.

[1] https://github.com/tlswg/draft-ietf-tls-esni/pulls

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 5 Aug 2021 17:30:11 +0000

As you are an experienced reviewer, I really appreciate all your commentary, and I think an experienced, not-author, view is very useful!

---

From: "Christopher Wood" <[email-masked]>
Date: Mon, 09 Aug 2021 11:07:39 -0700

On Thu, Aug 5, 2021, at 10:30 AM, Salz, Rich wrote:
> As you are an experienced reviewer, I really appreciate all your 
> commentary, and I think an experienced, not-author, view is very useful!

+1 -- thanks, Stephen! Most of the PRs have been reviewed and merged. There's a couple lingering PRs that we may want to close or punt. I'd prefer we resolve them in the next day or two, update the change log, and get the next version out. Of course, if folks are still reviewing and want or need more time, please let me know!

Best,
Chris

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 9 Aug 2021 20:13:03 +0100

Hiya,

On 09/08/2021 19:07, Christopher Wood wrote:
> +1 -- thanks, Stephen! Most of the PRs have been reviewed and merged.
> There's a couple lingering PRs that we may want to close or punt. 

I just closed one and punted one, leaving none:-)

Thanks,
S.

> I'd
> prefer we resolve them in the next day or two, update the change log,
> and get the next version out. Of course, if folks are still reviewing
> and want or need more time, please let me know!
> 
> Best, Chris
>