Subject: Re: [TLS] tls-flags: abort on malformed extension

From: Sean Turner <[email-masked]>
Date: Thu, 2 Sep 2021 22:37:52 -0400

Seems pretty reasonable to me.

spt

> On Aug 28, 2021, at 16:36, Yoav Nir <[email-masked]> wrote:
> 
> Hi.
> 
> To address Michael StJohns comment from 19-July, I submitted PR #12:
> 
> https://github.com/tlswg/tls-flags/pull/12
> 
> What is says is that any implementation receiving a malformed tls_flags extensions should abort the handshake. The text provides a list (which I hope is comprehensive) of all the ways this specific extension can be malformed. 
> 
> Please comment here or on the PR is this makes sense to everybody.
> 
> Yoav
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Rob Sayre <[email-masked]>
Date: Thu, 2 Sep 2021 20:44:42 -0700

On Sat, Aug 28, 2021 at 1:37 PM Yoav Nir <[email-masked]> wrote:

>  The text provides a list (which I hope is comprehensive) of all the ways
> this specific extension can be malformed.
>

The text says "Such invalid tls_flags extensions include: ..."

While I don't oppose the edit, I don't understand why this WG continues to
specify this kind of thing in prose.

thanks,
Rob