Subject: Re: [TLS] progressing draft-ietf-tls-md5-sha1-deprecate

From: Sean Turner <[email-masked]>
Date: Thu, 2 Sep 2021 22:36:22 -0400

Just a reminder that sometime tomorrow I will ask for these PRs to be merged and a new version of the I-D be produced so that we can make progress.

spt

> On Aug 27, 2021, at 10:58, Sean Turner <[email-masked]> wrote:
> 
> Hi! While address the IoT Directorate comments from IETF LC, some addition comments have been received. I would like to address these new comments and get the I-D in the hands of the iESG. There were three set of comments:
> 
> 1) Based on Daniels and David Benjamin’s reviews, the I-D is not as clear as it could be. The end result of deprecating MD5 and SHA1 is that signature_algorithms is always included; we should just say that. Chris has submitted the following PR to address this:
> https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate/pull/19
> You will notice that the PR removes section 6 of the I-D; it is unclear how much utility there is in updating the NOTE.
> 
> We are looking to merge this PR at the end of next week so please submit any comments before then.
> 
> 2) Hannes suggested that we remove the 7525 updates text now that 7525bis is underway. I submitted this issue to capture the issue:
> https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate/issues/17
> Peter Saint-Andre (one of the 7525bis authors) has filled the following issue to incorporate the text from our I-D: 
> https://github.com/yaronf/I-D/issues/245
> Yaron has already merged the PR:
> https://github.com/yaronf/I-D/pull/248
> Chris has also kindly submitted this PR to remove the 7525bis-related text from “our" I-D:
> https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate/pull/18
> 
> Again, we are looking to merge this PR at the end of next week so please submit any comments before then.
> 
> 3) Hannes also had some editorial suggestions, that I created issues for:
> https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate/issues/16
> https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate/issues/15
> https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate/issues/14
> These are addressed in this PR:
> https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate/pull/20
> 
> These ought to all be non-controversial, so we will merge them sometime next week.
> 
> Cheers,
> spt (as Shepherd)

---

From: Daniel Migault <[email-masked]>
Date: Fri, 3 Sep 2021 08:00:02 -0400

Looks good to me however this still represents in my opinion an update to
5246 -- which I think is also what we want.

Yours,
Daniel

On Thu, Sep 2, 2021 at 10:37 PM Sean Turner <[email-masked]> wrote:

> Just a reminder that sometime tomorrow I will ask for these PRs to be
> merged and a new version of the I-D be produced so that we can make
> progress.
>
> spt
>
> > Hi! While address the IoT Directorate comments from IETF LC, some
> addition comments have been received. I would like to address these new
> comments and get the I-D in the hands of the iESG. There were three set of
> comments:
> >
> > 1) Based on Daniels and David Benjamin’s reviews, the I-D is not as
> clear as it could be. The end result of deprecating MD5 and SHA1 is that
> signature_algorithms is always included; we should just say that. Chris has
> submitted the following PR to address this:
> > You will notice that the PR removes section 6 of the I-D; it is unclear
> how much utility there is in updating the NOTE.
> >
> > 2) Hannes suggested that we remove the 7525 updates text now that
> 7525bis is underway. I submitted this issue to capture the issue:
> > Peter Saint-Andre (one of the 7525bis authors) has filled the following
> issue to incorporate the text from our I-D:
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

-- 
Daniel Migault
Ericsson

---

From: Sean Turner <[email-masked]>
Date: Fri, 3 Sep 2021 09:05:32 -0400

Daniel,

This I-D is an update to RFC 5246 (see header).  Only the 7525 updates were moved to 7525bis. While checking this out I did note a couple of there places in the I-D that 7525 needs to be scrubbed. I asked for changes in the following PR to account for those:
https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate/pull/18

Thanks again for your reviews,
spt

> On Sep 3, 2021, at 08:00, Daniel Migault <[email-masked]> wrote:
> 
> Looks good to me however this still represents in my opinion an update to 5246 -- which I think is also what we want.
> 
> Yours, 
> Daniel
>