Subject: Re: [TLS] tls@ietf112

From: "Martin Thomson" <[email-masked]>
Date: Thu, 04 Nov 2021 17:32:20 +1100

Hey Sean, what is "Zero-Knowledge Proofs meet TLS"?  I can't find a draft and the link in the agenda is busted.

On Wed, Oct 20, 2021, at 06:46, Sean Turner wrote:
> Hi! We have a meeting time scheduled for Tuesday, 9 November 2021 from 
> 1600-1800 (UTC). Please send in your agenda topics along with how much 
> time you think you will need to [email-masked] by 26 October 2021 
> (early is better).
>
> Cheers
> Chris, Joe, and Sean
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Sean Turner <[email-masked]>
Date: Thu, 4 Nov 2021 09:21:51 -0400

Martin,

Paul Grubbs approached us about presenting some work he has done to show "how zero-knowledge proofs can be used to prove properties of TLS plaintexts, and describes how this can solve problems related to TLS ‘visibility' in a privacy-preserving way, with no changes needed to TLS.  His paper can be found here:
https://eprint.iacr.org/2021/1022

Because this is not an I-D, I confirmed with that there are no IPR issues.

Apologies about the agenda, I think Chris has updated it to refer to the paper.

Cheers,
spt

> On Nov 4, 2021, at 02:32, Martin Thomson <[email-masked]> wrote:
>