Subject: [TLS] Up to date overview of TLS implementations?

From: John Mattsson <[email-masked]>
Date: Fri, 12 Nov 2021 08:55:50 +0000

Hi,

Is there any up to date overwiew of which TLS libraries support or are working on support for new and upcoming stuff like:

RFC 8879 TLS Certificate Compression
draft-ietf-tls-dtls-connection-id
draft-ietf-tls-ticketrequests
draft-ietf-tls-subcerts
draft-ietf-tls-dtls13
draft-ietf-tls-esni

Cheers,
John

---

From: Achim Kraus <[email-masked]>
Date: Fri, 12 Nov 2021 10:32:11 +0100

Hi John,

for draft-ietf-tls-dtls-connection-id, I have some views ("overview" may
be something else).

Eclipse/Californium, Release 3.0 (3. November 2021), Java, CoAP + DTLS
1.2, supports/configurable both deprecated variants (old MAC and
deprecated extension code-point 53) and RFC9146 variant (new MAC and
extension code-point 54).

Eclipse/Leshan, Java, LwM2M, using Californium and current development
of leshan is updated to use Californium 3.0.

Eclipse/tinydtls, C, DTLS 1.2, on my list (but for now I'm still too
busy with Californium).

Mbedtls 3.0, C, ongoing, https://github.com/ARMmbed/mbedtls/pull/5061

Tools:

Wireshark, implemented,
https://gitlab.com/wireshark/wireshark/-/issues/17695

Zephyr, waiting on mbedtls,
https://github.com/zephyrproject-rtos/zephyr/pull/36738

best regards
Achim Kraus

Am 12.11.21 um 09:55 schrieb John Mattsson:
> Hi,
>
> Is there any up to date overwiew of which TLS libraries support or are
> working on support for new and upcoming stuff like:
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: John Mattsson <[email-masked]>
Date: Fri, 12 Nov 2021 11:22:13 +0000

Thanks Achim,

My interest in DTLS Connection IDs is mainly for non-constrained use cases such as DTLS/SCTP (DTLS over SCTP) between nodes in the 5G core network.

https://datatracker.ietf.org/doc/draft-ietf-tsvwg-dtls-over-sctp-bis/

The current plan is to mandate use of connection IDs for both DTLS 1.2 and DTLS 1.3.

Cheers,
John

From: Achim Kraus <[email-masked]>
Date: Friday, 12 November 2021 at 10:32
To: John Mattsson <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [TLS] Up to date overview of TLS implementations?
Hi John,

Mbedtls 3.0, C, ongoing, https://protect2.fireeye.com/v1/url?k=b8474e79-e7dc7745-b8470ee2-86b1886cfa64-2c1d54f96c0a9e76&q=1&e=c259a055-7f88-4bac-a4f8-bc722e69c000&u=https%3A%2F%2Fgithub.com%2FARMmbed%2Fmbedtls%2Fpull%2F5061

Tools:

Wireshark, implemented,

Zephyr, waiting on mbedtls,
https://protect2.fireeye.com/v1/url?k=37e00812-687b312e-37e04889-86b1886cfa64-88e9e9f09c0d6a34&q=1&e=c259a055-7f88-4bac-a4f8-bc722e69c000&u=https%3A%2F%2Fgithub.com%2Fzephyrproject-rtos%2Fzephyr%2Fpull%2F36738

best regards
Achim Kraus

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 12 Nov 2021 13:34:19 +0100

> On 12. Nov 2021, at 12:22, John Mattsson <john.mattsson=[email-masked]> wrote:
> 
> Thanks Achim,
>  
Please note that Ericsson has filed
* https://datatracker.ietf.org/ipr/5195/
* https://datatracker.ietf.org/ipr/5218/
which might have an impact on what you can implement and/or use in the
above mentioned use-case.

Best regards
Michael