Subject: [Tm-rid] could WebFinger help us?

From: "Card, Stu" <[email-masked]>
Date: Mon, 22 Jun 2020 09:01:57 -0400

RFC7033 describes WebFinger.

Might this be a reasonable way to look up [public] info on UA, operators,
registries, et al?

I have found no "compare & contrast" writeups on WebFinger vs RDAP. They
both use HTTP & return JSON about named entities...

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 22 Jun 2020 09:25:24 -0400

It could be one more access method provided by a Net-DP or other USS/UTM 
entity.

I would expect that different ones would use different tools.  The best 
we can do is provide examples how different tools can produce worthwhile 
responses.

Though choosing a Mandatory to Implement protocol would be preferred.

Mike Jones would be a good person in general to get some feedback on 
this side of the UA environment.

On 6/22/20 9:01 AM, Card, Stu wrote:
> Might this be a reasonable way to look up [public] info on UA, 
> operators, registries, et al?
>
> I have found no "compare & contrast" writeups on WebFinger vs RDAP. 
> They both use HTTP & return JSON about named entities...
>
>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Michael Richardson <[email-masked]>
Date: Mon, 22 Jun 2020 10:51:32 -0400

Web-Finger has not, sadly, been a stunning success.
If only facebook or linkedin had been willing to play.

RDAP as a successor to whois is still young.

Both finger and whois have the old-hats who actually type the command.
Neither web-finger nor rdap seem to have that, but of course, perl/curl/etc.

I believe that web-finger would be more useful.
I managed to server web-finger with static pages, but it took some Apache
magic to transform.
  https://webfinger.net/lookup/?resource=mcr%40sandelman.ca

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-