Subject: Re: [Drip] Authentication Formats Follow-Up

From: Michael Richardson <[email-masked]>
Date: Thu, 13 Aug 2020 18:12:55 -0400

Robert Moskowitz <[email-masked]> wrote:
    > First a UA moving at 60MPH = ~42FPS.  So you have 7s warning with BT4 and
    > ~42s with BT5.

I couldn't figure your weird provincial units out. :-)
FPS => (BT) Frames per second ???       [naturally, at first, I'm thinking video]

Ah, FPS = feet per second.
So, with BT4 you can't get anything until it's 300 feet away, but BT5, means it
can be 1764 feet away. Did I get that right?

    > Now this is bad in his worst timing of 45s and even 2s eats up critical time
    > to respond, but things are really not so bleak. Adam's code is in Python and
    > quite removed from the actual radio driver.  Let's look over at:

    > See: https://www.bluetooth.com/blog/exploring-bluetooth-5-how-fast-can-it-be/

    > One BT 4 packet takes 80 + 150 + 328 + 150 µs = 708µs

    > I do not think BT has an cts/rts like wifi.  So the UA COULD stream the 10
    > auth frames and:

    > So 10 take 7.08ms.  Closer to radio coding will greatly reduce timing..

How often will it (re)transmit?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 13 Aug 2020 18:41:31 -0400

> can be 1764 feet away. Did I get that right?

See Adam's slides as to the distances he was picking up BT4 and BT5 in 
an open airport.

I just used a web calculator of Miles per Hour to Feet per Second and 60 
MPH = 88FPS.  Ugh.

So that is like only a 4sec time until that UA hits you with BT4 range.  
But ~20sec with BT5.  Not good at all...

> How often will it (re)transmit?

It is still unclear what FAA will require.  I think the proposed rules 
is at least once per sec.

Of course, the vendors will want to do this as seldom as possible as it 
interferes with their UA control.  If the UA only has one radio that it 
needs for both C2 and Broadcast RID, C2 wins in priority.