Subject: Re: [Drip] HITs and HHITs as valid IPv6 addresses in 'draft-ietf-drip-rid'

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 28 Jan 2021 18:13:15 +0000

Stu, turning back to this message from a couple of weeks ago I took it upon
myself to learn a bit more about HIP and based on what I learned I took the
concept one step further and said: “Why not form a complementary union
between HIP and AERO/OMNI and thereby get the best of both worlds?”.
I wrote this into the latest OMNI draft, which you can see here:

https://datatracker.ietf.org/doc/draft-templin-6man-omni-interface/

This would have AERO/OMNI inheriting not just the (H)HIT, but also all of
the protocol mechanisms of HIP as well. It would have the HIP Initiator
and Responder messages driven by IPv6 ND messages, which appears
to be consistent with what the HIP authors originally intended when
they designed the message formats.

Am I wrong?

Thanks - Fred

From: Card, Stu [mailto:[email-masked]]
Sent: Tuesday, January 12, 2021 9:47 AM
To: Templin (US), Fred L <[email-masked]>
Cc: [email-masked]
Subject: [EXTERNAL] Re: [Drip] HITs and HHITs as valid IPv6 addresses in 'draft-ietf-drip-rid'

EXT email: be mindful of links/attachments.

On 1st quick consideration of your idea, I _think_ you are right!

[H]HITs are artifacts emerging from HIP work, but neither require nor exclusively support running HIP.

Thanks for this novel idea!

On Tue, Jan 12, 2021, 12:29 PM Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:
Stu, I admittedly don’t know much about HIP (even though my officemate
was one of the authors), but it occurs to me that the HIT/HHIT could also be
used with AERO/OMNI instead of HIP.

With AERO/OMNI, there is always a virtual interface (the OMNI interface)
that the HIT/HHIT would be assigned to, i.e., even if there are multiple
underlying interfaces associated with the OMNI interface. The HIT/HHIT
could then be called a valid IPv6 address.

Another point is that the document at some points references HIP. If it
intends to continue to do so, please make sure that it is just an example
and not the exclusive potential user of HITs/HHITS, as others such as
AERO/OMNI are also candidate users.

Thanks - Fred

From: Card, Stu [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, January 12, 2021 9:14 AM
To: Templin (US), Fred L <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Dickson (US), Sean M <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Drip] HITs and HHITs as valid IPv6 addresses in 'draft-ietf-drip-rid'

Interesting point Fred.

One (sophist?) definition would be that a [H]HIT is associated with the set of virtual interfaces used by the host for HIP (e.g. hip0, hip1), with the caveat that these are not always up.

This is not really different from a DHCP reservation associated with a wireless interface on a mobile host, inc. one that connects to different routers so only gets that address when it connects to the router configured with that DHCP reservation.

Do you consider that sufficient?
On Tue, Jan 12, 2021, 11:57 AM Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:
Hi, in the draft it says in a couple of places that HITs and HHITs are "valid IPv6 addresses".
But, in RFC8200, "address" is defined as follows:

   address      an IPv6-layer identifier for an interface or a set of interfaces.

So, the HIT/HHIT cannot be called a "valid IPv6 address" unless it is also associated
with an interface or a set of interfaces.

The simple and effective fix for this is to, in the document, state that the HIT/HHIT
will always be assigned to a virtual interface of the device (e.g., loopback, etc.).
With that simple fix, I believe the statement that the HIT/HHIT is a valid IPv6
address is supported; without it, I do not believe the claim can be made.

Thanks - Fred

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

---

From: "Card, Stu" <[email-masked]>
Date: Thu, 28 Jan 2021 13:34:16 -0500

Fred, again, thank you!

I can't comment on what the HIP authors originally intended, but Bob could.

Nor have I yet fully grokked your latest contribution here, but I am happy
to see you make the effort, which at first quick read looks promising.

If we of IETF can present a consistent picture to ASTM, ICAO TFSG & WG-I,
RTCA/EUROCAE, et al, that will help greatly.

On Thu, Jan 28, 2021, 1:13 PM Templin (US), Fred L <
[email-masked]> wrote:

> *From:* Card, Stu [mailto:[email-masked]]
> *Sent:* Tuesday, January 12, 2021 9:47 AM
> *To:* Templin (US), Fred L <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* [EXTERNAL] Re: [Drip] HITs and HHITs as valid IPv6 addresses
> in 'draft-ietf-drip-rid'
>
>
>
> On Tue, Jan 12, 2021, 12:29 PM Templin (US), Fred L <
> [email-masked]> wrote:
>
> *From:* Card, Stu [mailto:[email-masked]]
> *Sent:* Tuesday, January 12, 2021 9:14 AM
> *To:* Templin (US), Fred L <[email-masked]>
> *Cc:* [email-masked]; Dickson (US), Sean M <[email-masked]>
> *Subject:* Re: [Drip] HITs and HHITs as valid IPv6 addresses in
> 'draft-ietf-drip-rid'
>
>
>
> Interesting point Fred.
>
>
>
> One (sophist?) definition would be that a [H]HIT is associated with the
> set of virtual interfaces used by the host for HIP (e.g. hip0, hip1), with
> the caveat that these are not always up.
>
>
>
> This is not really different from a DHCP reservation associated with a
> wireless interface on a mobile host, inc. one that connects to different
> routers so only gets that address when it connects to the router configured
> with that DHCP reservation.
>
>
>
> On Tue, Jan 12, 2021, 11:57 AM Templin (US), Fred L <
> [email-masked]> wrote:
>
> [email-masked]