Subject: [Drip] I-D Action: draft-ietf-drip-arch-08.txt

From: [email-masked]
Date: Thu, 21 Jan 2021 15:36:32 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Drone Remote ID Protocol WG of the IETF.

        Title           : Drone Remote Identification Protocol (DRIP) Architecture
        Authors         : Stuart W. Card
                          Adam Wiethuechter
                          Robert Moskowitz
                          Shuai Zhao
                          Andrei Gurtov
	Filename        : draft-ietf-drip-arch-08.txt
	Pages           : 23
	Date            : 2021-01-21

Abstract:
   This document defines an architecture for protocols and services to
   support Unmanned Aircraft System Remote Identification and tracking
   (UAS RID), plus RID-related communications, including required
   architectural building blocks and their interfaces.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-drip-arch/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-drip-arch-08
https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-arch-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Thu, 21 Jan 2021 23:39:18 +0000

update in -08 based on Daniel’s comment, please look at the diff
·         Move section of broadcast rid ahead of network RID. I feel Broadcast RID has more weight than the network RID.
·         Terminology update

Best,
Shuai

From: Tm-rid <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Thursday, January 21, 2021 at 15:36
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Drip] I-D Action: draft-ietf-drip-arch-08.txt(Internet mail)

Abstract:

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

---

From: Daniel Migault <[email-masked]>
Date: Fri, 22 Jan 2021 08:34:53 -0500

Thanks for submitting the draft.

This document is currently the priority for the WG so that we can get
focused on the solution drafts. It would be good, WG member could take the
time to review it in the coming days.

I am wondering if the document is on github somewhere. maybe that would be
easier for the co-author to follow the issues.

I agree that broadcast rid is moved higher into the list of use case. In my
opinion - and being non familiar to FAA  I am happy to be wrong - it seems
to me that the network rid remains important use case for future
deployments and hardly believe it is definitively out. I am happy to get
your thoughts on it.

Yours,
Daniel

On Thu, Jan 21, 2021 at 6:39 PM shuaiizhao(Shuai Zhao) <
[email-masked]> wrote:

> ·         Move section of broadcast rid ahead of network RID. I feel
> Broadcast RID has more weight than the network RID.
>
> ·         Terminology update
>
>
>
> Best,
>
> Shuai
>
>
>
> *From: *Tm-rid <[email-masked]> on behalf of "
> [email-masked]" <[email-masked]>
> *Reply-To: *"[email-masked]" <[email-masked]>
> *Date: *Thursday, January 21, 2021 at 15:36
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *[Drip] I-D Action: draft-ietf-drip-arch-08.txt(Internet mail)
>
>
>
>
>
> [email-masked]
> [email-masked]

-- 
Daniel Migault
Ericsson

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 22 Jan 2021 09:14:34 -0500

On 1/22/21 8:34 AM, Daniel Migault wrote:
> focused on the solution drafts. It would be good, WG member could take 
> the time to review it in the coming days.
>
> I am wondering if the document is on github somewhere. maybe that 
> would be easier for the co-author to follow the issues.
>
> I agree that broadcast rid is moved higher into the list of use case. 
> In my opinion - and being non familiar to FAA  I am happy to be wrong 
> - it seems to me that the network rid remains important use case for 
> future deployments and hardly believe it is definitively out. I am 
> happy to get your thoughts on it.

In my highly biased opinion, the FAA "kicked the can down the road".  
Network RID needs USS and UTM.  It should not be the tail that wags the 
dog.  More work is needed to prove out UTM/USS and finalize its rules 
that will most likely include Network RID.

Requiring Network RID now would force the hand on USS and maybe result 
in suboptimal designs.

>
> Yours,
> Daniel
>
>
> On Thu, Jan 21, 2021 at 6:39 PM shuaiizhao(Shuai Zhao) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     ·Move section of broadcast rid ahead of network RID. I feel
>     ·Terminology update
>     *From: *Tm-rid <[email-masked]
>     <mailto:[email-masked]>> on behalf of
>     "[email-masked] <mailto:[email-masked]>"
>     <[email-masked] <mailto:[email-masked]>>
>     *Reply-To: *"[email-masked] <mailto:[email-masked]>"
>     <[email-masked] <mailto:[email-masked]>>
>     *To: *"[email-masked] <mailto:[email-masked]>"
>     <[email-masked] <mailto:[email-masked]>>
>     *Cc: *"[email-masked] <mailto:[email-masked]>" <[email-masked]
>     <mailto:[email-masked]>>
>     <https://datatracker.ietf.org/doc/draft-ietf-drip-arch/>
>
>     <https://tools.ietf.org/html/draft-ietf-drip-arch-08>
>
>     <https://datatracker.ietf.org/doc/html/draft-ietf-drip-arch-08>
>
>     <https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-arch-08>
>
>     until the htmlized version and diff are available at
>     tools.ietf.org <http://tools.ietf.org>.
>
>     <ftp://ftp.ietf.org/internet-drafts/>
>
>     -- 
>
>     Tm-rid mailing list
>
>     [email-masked] <mailto:[email-masked]>
>
>     <https://www.ietf.org/mailman/listinfo/tm-rid>
>
>     -- 
>     Tm-rid mailing list
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tm-rid>
>
>
>
> -- 
> Daniel Migault
> Ericsson
>

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 28 Jan 2021 11:21:05 -0500

First fixes to update to FAA RID Final Rules:

In Sec 1:

    This document describes an architecture for protocols and services to
    support Unmanned Aircraft System Remote Identification and tracking
    (UAS RID), plus RID-related communications, conforming to proposed 
and final
    regulations plus external technical standards, satisfying the
    requirements listed in the companion requirements document
    [I-D.ietf-drip-reqs].

In Sec 1.1:

The FAA has published "Remote Identification of Unmanned Aircraft"
    [FAA_RID].  CAAs currently promulgate performance-based regulations that
    do not specify techniques, but rather cite industry consensus
    technical standards as acceptable means of compliance.

The [F3411-19] is cited by FAA in
    its RID [FAA_RID] as "revised or updated" ... "a potential means of 
compliance
    for remote identification of unmanned aircraft".

Sec 6:

   The FAA Final Rules only specifies Broadcast RID for UAS.

References:

[FAA_RID]  United States Federal Aviation Administration (FAA),
     "Remote Identification of Unmanned Aircraft", 2020,
     <https://www.govinfo.gov/content/pkg/FR-2021-01-15/
     pdf/2020-28948.pdf>.

Note xml for this is:

<reference anchor="FAA_RID" 
target="https://www.govinfo.gov/content/pkg/FR-2021-01-15/pdf/2020-28948.pdf">
   <front>
     <title>Remote Identification of Unmanned Aircraft</title>
     <author >
       <organization>United States Federal Aviation Administration 
(FAA)</organization>
     </author>
     <date year="2020"/>
   </front>
</reference>

I think there is something else I need to comment on, but not finding it 
right now.  So pushing these needed edits out.