Subject: [Drip] Opsdir last call review of draft-ietf-drip-reqs-12

From: Nagendra Nainar via Datatracker <[email-masked]>
Date: Mon, 07 Jun 2021 14:54:55 -0700

Reviewer: Nagendra Nainar
Review result: Has Nits

Hi,

I have reviewed this document as part of the Operational directorate's ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written with the intent of improving the operational aspects of
the IETF drafts per guidelines in RFC5706.

Comments that are not addressed in last call may be included
in AD reviews during the IESG review.  Document editors and WG chairs should
treat these comments just like any other last call comments.

Version: draft-ietf-drip-reqs-12

Overall Summary:

This draft is an informational track defining the terminologies and listing the
requirements for DRIP.

Overall this is a well-written document explaining the requirements and the
rationale behind the same. This document does not propose any new standards or
extensions to the existing standards and so does not introduce any operational
challenges or gaps as such. I am choosing "Has Nits" only to check if the
authors can address any of the below observations. Otherwise, it is ready.

Few observations below:

==> Is there any reference that you can add to the below-mentioned community
documents?.

"On this and other terminological issues, to encourage comprehension
   necessary for adoption of DRIP by the intended user community, that
   community's norms are respected herein, and definitions are quoted in
   cases where they have been found in that community's documents."

==> Based on the below DRI suffice, I assume that the below one is defined by
this document.

"AAA
      Attestation, Authentication, Authorization, Access Control,
      Accounting, Attribution, Audit, or any subset thereof (uses differ
      by application, author, and context).  (DRIP)"

AAA is common terminology used for "Authentication, Authorization, and
Accounting". While they both seem to be similar, is there any need to use a
different term to differentiate DRIP-AAA from the traditional AAA?.

==> The text below Figure 3 appears to mention UA-GCS, UA-Internet, and
GCS-Internet, but this is not clear in the figure.

"Figure 3 illustrates Network RID information flows.  Only two of the
   three typically wireless links shown involving the UAS (UA-GCS, UA-
   Internet, and GCS-Internet) need exist"

Thanks,
Nagendra

---

From: <[email-masked]>
Date: Tue, 8 Jun 2021 06:39:07 +0000

Hi Nagendra, 

Thank you for the comments.

For your comment about the AAA entry:

   AAA
      Attestation, Authentication, Authorization, Access Control,
      Accounting, Attribution, Audit, or any subset thereof (uses differ
                                      ^^^^^^^^^^^^^^^^^^^^^^    
      by application, author, and context).  (DRIP)
                                              ^^^^
I confirm that the WG had that discussion. The outcome of that discussion is to tag this entry as DRIP specific + indicate that the term is also used to refer to a subset of these functions. 

It wasn't clear at that time the need to use a different term such as the one you suggested (DRIP-AAA) as this will overload the other drip documents that will refer anyway to the terms defined in this I-D.

I trust the authors will fix the other points.

Cheers,
Med

> -----Message d'origine-----
> De : Nagendra Nainar via Datatracker [mailto:[email-masked]]
> Envoyé : lundi 7 juin 2021 23:55
> À : [email-masked]
> Cc : [email-masked]; [email-masked]; tm-
> [email-masked]
> Objet : Opsdir last call review of draft-ietf-drip-reqs-12
> 
> I have reviewed this document as part of the Operational
> directorate's ongoing effort to review all IETF documents being
> processed by the IESG.  These comments were written with the intent
> of improving the operational aspects of the IETF drafts per
> guidelines in RFC5706.
> 
> Comments that are not addressed in last call may be included in AD
> reviews during the IESG review.  Document editors and WG chairs
> should treat these comments just like any other last call comments.
> 
> This draft is an informational track defining the terminologies and
> listing the requirements for DRIP.
> 
> Overall this is a well-written document explaining the requirements
> and the rationale behind the same. This document does not propose
> any new standards or extensions to the existing standards and so
> does not introduce any operational challenges or gaps as such. I am
> choosing "Has Nits" only to check if the authors can address any of
> the below observations. Otherwise, it is ready.
> 
> Few observations below:
> 
> ==> Is there any reference that you can add to the below-mentioned
> community documents?.
> 
> ==> Based on the below DRI suffice, I assume that the below one is
> defined by this document.
> 
> "AAA
> AAA is common terminology used for "Authentication, Authorization,
> and Accounting". While they both seem to be similar, is there any
> need to use a different term to differentiate DRIP-AAA from the
> traditional AAA?.
> 
> ==> The text below Figure 3 appears to mention UA-GCS, UA-Internet,
> and GCS-Internet, but this is not clear in the figure.
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Tue, 8 Jun 2021 06:39:07 +0000

Hi Nagendra, 

   AAA

Cheers,
Med

---

From: "Card, Stu" <[email-masked]>
Date: Tue, 8 Jun 2021 17:13:08 -0400

Nagendra --

Thanks for the review, both your kind words and your identification of
points potentially requiring clarification!
Med addressed your first point concisely.
Adam is at this moment furiously banging on the keyboard, attempting to
simplify and clarify our ASCII art, to address your second.

-- Stu

On Mon, Jun 7, 2021 at 5:54 PM Nagendra Nainar via Datatracker <
[email-masked]> wrote:

> community

---

From: "Card, Stu" <[email-masked]>
Date: Tue, 8 Jun 2021 17:13:08 -0400

Nagendra --

-- Stu

---

From: Adam Wiethuechter <[email-masked]>
Date: Tue, 8 Jun 2021 21:37:18 +0000

Nagendra,

Does the illustration attached resolve the ambiguity you found?

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: Card, Stu <[email-masked]>
Sent: Tuesday, June 8, 2021 5:13 PM
To: Nagendra Nainar <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: Opsdir last call review of draft-ietf-drip-reqs-12

Nagendra --

Thanks for the review, both your kind words and your identification of points potentially requiring clarification!
Med addressed your first point concisely.
Adam is at this moment furiously banging on the keyboard, attempting to simplify and clarify our ASCII art, to address your second.

-- Stu

On Mon, Jun 7, 2021 at 5:54 PM Nagendra Nainar via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:
Reviewer: Nagendra Nainar
Review result: Has Nits

Hi,

Overall Summary:

Few observations below:

"AAA

Thanks,
Nagendra

---

From: <[email-masked]>
Date: Wed, 9 Jun 2021 07:39:13 +0000

Hi Adam, all,

Thank you for working this proposal. Please find below an updated version, fwiw:

+-------------+     ******************
|     UA      |     *    INTERNET    *
+--o-------o--+     *                *
   |       |        *                *
   |       |        *                *     +------------+
   |       '--------*-(+)------------*-----o            |
   |                *  |             *     |            |
   |       .--------*-(+)------------*-----o NET-Rid SP |
   |       |        *                *     |            |
   |       |        *         .------*-----o            |
   |       |        *         |      *     +------------+
   |       |        *         |      *
   |       |        *         |      *     +------------+
   |       |        *         '------*-----o            |
   |       |        *                *     | NET-Rid DP |
   |       |        *         .------*-----o            |
   |       |        *         |      *     +------------+
   |       |        *         |      *
   |       |        *         |      *     +------------+
+--o-------o--+     *         '------*-----o Observer's |
|     GCS     |     *                *     | Device     |
+-------------+     ******************     +------------+

(+) signs in the figure may not be intuitively interpreted by readers who don't carefully read the text right after the figure. If that can be avoided, this would be great.

Cheers,
Med

De : Adam Wiethuechter [mailto:[email-masked]]
Envoyé : mardi 8 juin 2021 23:37
À : Card, Stu <[email-masked]>; Nagendra Nainar <[email-masked]>
Cc : [email-masked]
Objet : Re: Opsdir last call review of draft-ietf-drip-reqs-12

Nagendra,

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: Card, Stu <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 8, 2021 5:13 PM
To: Nagendra Nainar <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: Opsdir last call review of draft-ietf-drip-reqs-12

Nagendra --

-- Stu

Hi,

Overall Summary:

Few observations below:

"AAA

Thanks,
Nagendra

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Wed, 9 Jun 2021 11:46:47 +0000

Hi Adam,

Thank you for the quick response.

Yes, it looks much better 😊

Thanks,
Nagendra

From: Adam Wiethuechter <[email-masked]>
Date: Tuesday, June 8, 2021 at 5:37 PM
To: Card, Stu <[email-masked]>, Nagendra Kumar Nainar (naikumar) <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: Opsdir last call review of draft-ietf-drip-reqs-12
Nagendra,

--------
73,
Adam T. Wiethuechter

Nagendra --

-- Stu

Hi,

Overall Summary:

Few observations below:

"AAA

Thanks,
Nagendra

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Wed, 9 Jun 2021 11:52:08 +0000

Hi Med,

Thank you for clarifying.

Thanks,
Nagendra

From: [email-masked] <[email-masked]>
Date: Tuesday, June 8, 2021 at 2:39 AM
To: Nagendra Kumar Nainar (naikumar) <[email-masked]>, [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: RE: Opsdir last call review of draft-ietf-drip-reqs-12
Hi Nagendra,

   AAA

Cheers,
Med

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Wed, 9 Jun 2021 11:52:08 +0000

Hi Med,

Thanks,
Nagendra

   AAA

Cheers,
Med

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Wed, 9 Jun 2021 11:52:43 +0000

Hi Stu,

Thank you. I just replied to Adam’s mail about the figure.

Thanks,
Nagendra

From: Card, Stu <[email-masked]>
Date: Tuesday, June 8, 2021 at 5:13 PM
To: Nagendra Kumar Nainar (naikumar) <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: Opsdir last call review of draft-ietf-drip-reqs-12
Nagendra --

-- Stu

Hi,

Overall Summary:

Few observations below:

"AAA

Thanks,
Nagendra

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Wed, 9 Jun 2021 11:52:43 +0000

Hi Stu,

Thanks,
Nagendra

-- Stu

Hi,

Overall Summary:

Few observations below:

"AAA

Thanks,
Nagendra

---

From: "Card, Stu" <[email-masked]>
Date: Mon, 14 Jun 2021 10:49:07 -0400

DRIP Requirements rev 13 has been posted.
https://datatracker.ietf.org/doc/draft-ietf-drip-reqs/
Thanks for your review, which I hope this rev adequately reflects.

On Wed, Jun 9, 2021 at 7:52 AM Nagendra Kumar Nainar (naikumar) <
[email-masked]> wrote:

> *From: *Card, Stu <[email-masked]>
> *Date: *Tuesday, June 8, 2021 at 5:13 PM
> *To: *Nagendra Kumar Nainar (naikumar) <[email-masked]>
> *Cc: [email-masked] <[email-masked]>,
> [email-masked] <[email-masked]>,
> [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
> *Subject: *Re: Opsdir last call review of draft-ietf-drip-reqs-12
>
> Nagendra --
>
>
>

---

From: "Card, Stu" <[email-masked]>
Date: Mon, 14 Jun 2021 10:49:07 -0400

On Wed, Jun 9, 2021 at 7:52 AM Nagendra Kumar Nainar (naikumar) <
[email-masked]> wrote:

> authors can address any of the below observations. Otherwise, it is ready