Subject: [Drip] Fw: New Version Notification for draft-ietf-drip-auth-01.txt

From: Adam Wiethuechter <[email-masked]>
Date: Fri, 18 Jun 2021 15:55:26 +0000

All,

The newest Authentication Formats draft was posted to avoid expiration.
In case anyone was not aware the draft now lives here: https://github.com/ietf-wg-drip/draft-ietf-drip-auth

Readers may note that a lot has changed since v00. This is due to a restructuring of the entire document to bring it in line with the next ASTM revision of F3411.
I believe a lot of the appendices should spin into their own drafts (FEC) or be merged into others (attestations into registries). I have my ideas on them but wish to hear WG ideas as well.

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: [email-masked] <[email-masked]>
Sent: Friday, June 18, 2021 11:46 AM
To: Adam Wiethuechter <[email-masked]>; Robert Moskowitz <[email-masked]>; Stuart Card <[email-masked]>
Subject: New Version Notification for draft-ietf-drip-auth-01.txt

A new version of I-D, draft-ietf-drip-auth-01.txt
has been successfully submitted by Adam Wiethuechter and posted to the
IETF repository.

Name:           draft-ietf-drip-auth
Revision:       01
Title:          DRIP Authentication Formats
Document date:  2021-06-18
Group:          drip
Pages:          31
URL:            https://www.ietf.org/archive/id/draft-ietf-drip-auth-01.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-drip-auth/
Html:           https://www.ietf.org/archive/id/draft-ietf-drip-auth-01.html
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-drip-auth
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-drip-auth-01

Abstract:
   This document describes how to include trust into the ASTM Remote ID
   specification defined in ASTM F3411-19 under a Broadcast Remote ID
   (RID) scenario.  It defines a few different message schemes (based on
   the Authentication Message) that can be used to assure past messages
   sent by a UA and also act as an assurance for UA trustworthiness in
   the absence of Internet connectivity at the receiving node.

The IETF Secretariat

---

From: <[email-masked]>
Date: Fri, 25 Jun 2021 07:39:04 +0000

Hi Adam,

Please find below some quick comments:

·         Section 3.1 should refer to the problem statement in the req I-D.

·         Thank you for the new Section 3.2. Still, if we can have more text to motivate further why this is done here in the IETF not directly in ASTM, that would be helpful.

·         The document refers to "DRIP Authentication AuthType": who assigns this value? Is there any action required to get this value formally assigned?

·         Likewise, the documents asks ICAO to proceed with some allocations: is there any formal procedure to get these values assigned?. It would be better in the future to record the actual assignments, rather than the request itself as this is not within the scope of IETF/IANA.

·         The document should indicate where it fits in the DRIP arch.

·         I do still think that having flow example would be useful for the reader to understand the usage of the various messages/headers.

·         I failed to understand the meaning of "DRIP Link or Manifest" in statements such the following. These terms are not part of DRIP terminology. Please consider fixing this:

==
   GEN 1: Provable Ownership  This will be addressed using the DRIP
      Link.
==

Cheers,
Med

De : Tm-rid [mailto:[email-masked]] De la part de Adam Wiethuechter
Envoyé : vendredi 18 juin 2021 17:55
À : [email-masked]
Objet : [Drip] Fw: New Version Notification for draft-ietf-drip-auth-01.txt

All,

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Friday, June 18, 2021 11:46 AM
To: Adam Wiethuechter <[email-masked]<mailto:[email-masked]>>; Robert Moskowitz <[email-masked]<mailto:[email-masked]>>; Stuart Card <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-ietf-drip-auth-01.txt

Abstract:

The IETF Secretariat

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.