Subject: [Drip] Potential name change for draft-ietf-drip-rid

From: Robert Moskowitz <[email-masked]>
Date: Tue, 3 Aug 2021 15:30:31 -0400

During our IETF111 session we covered changing what is in 
draft-ietf-drip-rid.

Over the past few versions, drip-rid absorbed other drafts and perhaps 
it is time to shed a few things.

Sec 6 on DRIP Proofs is really for draft-ietf-drip-auth and will be 
replaced with pointers to that draft.

In a couple places there is the HHIT registry discuss.  Noteably sec 
4.5.  this should point to draft-wiethuechter-drip-registries, which 
should be adopted by the wg.

drip-rid should be focused on the Remote ID itself.  In fact in the 
revision to ASTM F3411, we got in that Session ID type 1 is:

Internet Engineering Task Force (IETF) Drone Remote Identification 
Protocol (DRIP) entity ID.

So I propose to change the title in the draft to:

Unmanned Aircraft System Remote Entity ID (UAS RID)

And not change the draft name.

Comments?  I don't see any changes need in the Abstract for this.

Thanks

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 3 Aug 2021 16:06:01 -0400

Also should I drop Appendix B, as that is part of drip-auth?

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: "Card, Stu" <[email-masked]>
Date: Tue, 3 Aug 2021 16:21:38 -0400

Please don't use the acronym "RID" to refer to the identity or the
identifier. The regulators & other SDOs use it to refer to "remote
identification" [and tracking] as a _process_. ASTM F3411 refers to the
identifier of interest as the "UAS ID" although that is also a misnomer as
it uniquely identifies not the whole UAS but only the UA itself. Can't we
just call our specific subtype the "DRIP Entity ID" as in the F3411
revision, or "DRIP [entity] identifier" as in our own IETF DRIP
requirements draft?

On Tue, Aug 3, 2021, 3:30 PM Robert Moskowitz <[email-masked]>
wrote:

> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 3 Aug 2021 16:56:43 -0400

Other than I don't think I was the one that came up with "RID"....

an acronym is valuable.  It does not need to be a TLA, an FLA will work.  ;)

Also important to be pronounceable.  I really struggled with some IBM 
used back in the big iron days!

Also we are proposing the DRIP Entity ID to be used in many places in 
the UAS/USS architecture.  One name to bind them all?

Unmanned Aviation Entity ID  UAEID   Too many vowels.  Plus "UAE" is a 
nation.  hmm more daydreaming needed.

Also "Aviation" for inclusiveness and "Aircraft" provide the same first 
letter to the acronym with potential acronym expansion errors.

I have not looked at all uses of "RID" in drip-req, but at least the 
first few follow your point.  drip-arch will have to be checked as well.

But your point is a good one and I will see what I can come up with.

On 8/3/21 4:21 PM, Card, Stu wrote:
> identification" [and tracking] as a _process_. ASTM F3411 refers to 
> the identifier of interest as the "UAS ID" although that is also a 
> misnomer as it uniquely identifies not the whole UAS but only the UA 
> itself. Can't we just call our specific subtype the "DRIP Entity ID" 
> as in the F3411 revision, or "DRIP [entity] identifier" as in our own 
> IETF DRIP requirements draft?
>
> On Tue, Aug 3, 2021, 3:30 PM Robert Moskowitz 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tm-rid>
>
>

---

From: "Card, Stu" <[email-masked]>
Date: Tue, 3 Aug 2021 17:05:03 -0400

DRIP Entity Tag (DIT)?

On Tue, Aug 3, 2021, 4:57 PM Robert Moskowitz <[email-masked]>
wrote:

> Also important to be pronounceable.  I really struggled with some IBM used
> back in the big iron days!
>
> Also we are proposing the DRIP Entity ID to be used in many places in the
> UAS/USS architecture.  One name to bind them all?
>
> I have not looked at all uses of "RID" in drip-req, but at least the first
> few follow your point.  drip-arch will have to be checked as well.
>
> Robert Moskowitz
> C:      248-219-2059
> F:      248-968-2824
> E:      [email-masked]
>
> There's no limit to what can be accomplished if it doesn't matter who gets
> the credit
>

---

From: "Card, Stu" <[email-masked]>
Date: Tue, 3 Aug 2021 17:10:59 -0400

Correction:
DRIP Identity Tag (DIT)
or
DRIP Entity Tag (DET)

Intriguing that "entity" is embedded in "identity"... checking etymology
now...

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 3 Aug 2021 17:50:03 -0400

I vote for DET.

DIT went out with Morse Code.

On 8/3/21 5:10 PM, Card, Stu wrote:
> Correction:
> DRIP Identity Tag (DIT)
> or
> DRIP Entity Tag (DET)
>
> Intriguing that "entity" is embedded in "identity"... checking 
> etymology now...
>
> On Tue, Aug 3, 2021, 17:05 Card, Stu <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     DRIP Entity Tag (DIT)?
>
>     On Tue, Aug 3, 2021, 4:57 PM Robert Moskowitz
>         Also important to be pronounceable.  I really struggled with
>         some IBM used back in the big iron days!
>
>         Also we are proposing the DRIP Entity ID to be used in many
>         places in the UAS/USS architecture.  One name to bind them all?
>
>         Unmanned Aviation Entity ID  UAEID   Too many vowels. Plus
>         "UAE" is a nation.  hmm more daydreaming needed.
>
>         Also "Aviation" for inclusiveness and "Aircraft" provide the
>         same first letter to the acronym with potential acronym
>         expansion errors.
>
>         I have not looked at all uses of "RID" in drip-req, but at
>         least the first few follow your point.  drip-arch will have to
>         be checked as well.
>
>>         Please don't use the acronym "RID" to refer to the identity
>>         or the identifier. The regulators & other SDOs use it to
>>         refer to "remote identification" [and tracking] as a
>>         _process_. ASTM F3411 refers to the identifier of interest as
>>         the "UAS ID" although that is also a misnomer as it uniquely
>>         identifies not the whole UAS but only the UA itself. Can't we
>>         just call our specific subtype the "DRIP Entity ID" as in the
>>         F3411 revision, or "DRIP [entity] identifier" as in our own
>>             4.5.  this should point to
>>             draft-wiethuechter-drip-registries, which

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Wed, 4 Aug 2021 18:42:47 +0000

In current architecture draft, RID means “UAS Remote Identification (RID)” and “DRIP entity identifier”. That was an early comment from Stu and I think we fix them already at least in arch-.

Best,
Shuai

From: Tm-rid <[email-masked]> on behalf of Robert Moskowitz <[email-masked]>
Date: Tuesday, August 3, 2021 at 1:57 PM
To: "Card, Stu" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Internet]Re: [Drip] Potential name change for draft-ietf-drip-rid

Also important to be pronounceable.  I really struggled with some IBM used back in the big iron days!

Also we are proposing the DRIP Entity ID to be used in many places in the UAS/USS architecture.  One name to bind them all?

Unmanned Aviation Entity ID  UAEID   Too many vowels.  Plus "UAE" is a nation.  hmm more daydreaming needed.

Also "Aviation" for inclusiveness and "Aircraft" provide the same first letter to the acronym with potential acronym expansion errors.

I have not looked at all uses of "RID" in drip-req, but at least the first few follow your point.  drip-arch will have to be checked as well.

But your point is a good one and I will see what I can come up with.
On 8/3/21 4:21 PM, Card, Stu wrote:
Please don't use the acronym "RID" to refer to the identity or the identifier. The regulators & other SDOs use it to refer to "remote identification" [and tracking] as a _process_. ASTM F3411 refers to the identifier of interest as the "UAS ID" although that is also a misnomer as it uniquely identifies not the whole UAS but only the UA itself. Can't we just call our specific subtype the "DRIP Entity ID" as in the F3411 revision, or "DRIP [entity] identifier" as in our own IETF DRIP requirements draft?
On Tue, Aug 3, 2021, 3:30 PM Robert Moskowitz <[email-masked]<mailto:[email-masked]>> wrote:
During our IETF111 session we covered changing what is in
draft-ietf-drip-rid.

Thanks

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

--
Robert Moskowitz
Owner
HTT Consulting
C:      248-219-2059
F:      248-968-2824
E:      [email-masked]<mailto:[email-masked]>

There's no limit to what can be accomplished if it doesn't matter who gets the credit

---

From: Adam Wiethuechter <[email-masked]>
Date: Thu, 5 Aug 2021 15:59:56 +0000

See inline comments below.

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC

________________________________
From: Tm-rid <[email-masked]> on behalf of Robert Moskowitz <[email-masked]>
Sent: Tuesday, August 3, 2021 3:30 PM
To: [email-masked] <[email-masked]>
Subject: [Drip] Potential name change for draft-ietf-drip-rid

...

<atw>
I believe all of this should be in the DRIP Registries draft (which I plan to rename to DNS based DRIP Registries).
</atw>

<atw>
I will comment more on this in a second email after everyone elses responses.
<atw>

Thanks

---

From: Adam Wiethuechter <[email-masked]>
Date: Thu, 5 Aug 2021 16:23:26 +0000

Comments inline.

--------
73,
Adam T. Wiethuechter

________________________________
From: Tm-rid <[email-masked]> on behalf of Robert Moskowitz <[email-masked]>
Sent: Tuesday, August 3, 2021 5:50 PM
To: Card, Stu <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [Drip] Potential name change for draft-ietf-drip-rid

I vote for DET.

<atw>
Rude! Morse code is still valuable! However, I agree with the collision. I also vote for DET - I propose it for something different.

Myself and Stu have worked out a way to condense the HHIT into something somewhat more human readable that does not clog up screen real estate as much as 128 bits does. It is the following format:

RAA Tag <delim> HDA Tag <delim> Subset HHIT Hash

The Tags are strings up to 6 characters long that can be set by the Registries to be used by device for display purposes. The third section ("Subset HHIT Hash") can be variable length with a minimum of 4 characters. We used the last 4 of the HHIT for testing purposes but it could be something else. I propose this basic concept be placed into your draft in a short appendix (which I can write up). I also propose this is what is called the DET.

NOTE: this is ONLY for display purposes on devices; NOT for sending the UAS ID - that is still the DRIP Entity ID.
</atw>

Intriguing that "entity" is embedded in "identity"... checking etymology now...

On Tue, Aug 3, 2021, 17:05 Card, Stu <[email-masked]<mailto:[email-masked]>> wrote:
DRIP Entity Tag (DIT)?

On Tue, Aug 3, 2021, 4:57 PM Robert Moskowitz <[email-masked]<mailto:[email-masked]>> wrote:
Other than I don't think I was the one that came up with "RID"....

On 8/3/21 4:21 PM, Card, Stu wrote:
Please don't use the acronym "RID" to refer to the identity or the identifier. The regulators & other SDOs use it to refer to "remote identification" [and tracking] as a _process_. ASTM F3411 refers to the identifier of interest as the "UAS ID" although that is also a misnomer as it uniquely identifies not the whole UAS but only the UA itself. Can't we just call our specific subtype the "DRIP Entity ID" as in the F3411 revision, or "DRIP [entity] identifier" as in our own IETF DRIP requirements draft?
<atw>
I will use here to discuss what I think this draft should be called. First +1 to what Stu said here; RID is a process to all the regulators the identifier ("UAS ID") is used in that process. I also +1 Stus comment to just use the name "DRIP Entity ID" in our drafts.

I felt that at the end of 111 we agreed that we call the draft: "The DRIP Entity ID as a UAS Session ID". This way the draft is only about the DRIP Entity ID, how to generate it, its properties and general usage within F3411 (as a Session ID). The draft would also point (I believe as MUSTs) to Authentication and Registry documents to explain the technical details behind supporting it and satisfying various other number requirements (not related to ID but REG).

With this the document can then act as the Session ID Means of Compliance (MOC) that we would need to forward to the FAA for review and acceptance. Remember the FAA has no method of Session IDs at this time and is soliciting input on it - however they want to be sure it will support their requirements. This will mostly likely apply to other CAAs as well and instead of creating an MOC for each one we can just create a baseline (using the existing uas-rid document) and if needed create Informational RFCs that amend the document for a given CAA.
</atw>
On Tue, Aug 3, 2021, 3:30 PM Robert Moskowitz <[email-masked]<mailto:[email-masked]>> wrote:
During our IETF111 session we covered changing what is in
draft-ietf-drip-rid.

Thanks

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 5 Aug 2021 14:45:57 -0400

On 8/5/21 12:23 PM, Adam Wiethuechter wrote:
> ------------------------------------------------------------------------
> *From:* Tm-rid <[email-masked]> on behalf of Robert Moskowitz 
> <[email-masked]>
> *Sent:* Tuesday, August 3, 2021 5:50 PM
> *To:* Card, Stu <[email-masked]>
> *Cc:* [email-masked] <[email-masked]>
> *Subject:* Re: [Drip] Potential name change for draft-ietf-drip-rid
> I vote for DET.
>
> Rude! Morse code is still valuable! However, I agree with the 
> collision. I also vote for DET - I propose it for something different.

I could never get my Morse speed up to 5WPM to pass my test; I blame my 
dsylexia.  Need something to blame.  So I know my dits and daws. Was 
also important in teaching data encoding along with Baudot; with it 
shift up and shift down characters!

>
> Myself and Stu have worked out a way to condense the HHIT into 
> something somewhat more human readable that does not clog up screen 
> real estate as much as 128 bits does. It is the following format:
>
> The Tags are strings up to 6 characters long that can be set by the 
> Registries to be used by device for display purposes. The third 
> section ("Subset HHIT Hash") can be variable length with a minimum of 
> 4 characters. We used the last 4 of the HHIT for testing purposes but 
> it could be something else. I propose this basic concept be placed 
> into your draft in a short appendix (which I can write up). I also 
> propose this is what is called the DET.
>
> NOTE: this is ONLY for display purposes on devices; NOT for sending 
> the UAS ID - that is still the DRIP Entity ID.

this is worth serious consideration for the DNS representation of DET.  
Something else that needs general agreement.

>>>         _process_. ASTM F3411 refers to the identifier of interest
>>>         as the "UAS ID" although that is also a misnomer as it
>>>         uniquely identifies not the whole UAS but only the UA
>>>         itself. Can't we just call our specific subtype the "DRIP
>>>         Entity ID" as in the F3411 revision, or "DRIP [entity]
>>>         identifier" as in our own IETF DRIP requirements draft?
>>
> <atw>
> I will use here to discuss what I think this draft should be called. 
> First +1 to what Stu said here; RID is a process to all the regulators 
> the identifier ("UAS ID") is used in that process. I also +1 Stus 
> comment to just use the name "DRIP Entity ID" in our drafts.
>
> I felt that at the end of 111 we agreed that we call the draft: "The 
> DRIP Entity ID as a UAS Session ID". This way the draft is only about 
> the DRIP Entity ID, how to generate it, its properties and general 
> usage within F3411 (as a Session ID). The draft would also point (I 
> believe as MUSTs) to Authentication and Registry documents to explain 
> the technical details behind supporting it and satisfying various 
> other number requirements (not related to ID but REG).
>
> With this the document can then act as the Session ID Means of 
> Compliance (MOC) that we would need to forward to the FAA for review 
> and acceptance. Remember the FAA has no method of Session IDs at this 
> time and is soliciting input on it - however they want to be sure it 
> will support their requirements. This will mostly likely apply to 
> other CAAs as well and instead of creating an MOC for each one we can 
> just create a baseline (using the existing uas-rid document) and if 
> needed create Informational RFCs that amend the document for a given CAA.
> </atw>
>>

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 6 Aug 2021 14:23:26 -0400

Thus look for the new draft title as:

DRIP Entity Tag (DET) for Unmanned Aircraft System Remote Identification 
(UAS RID)

with the title abbreviation of:

DRIP Entity Tag (DET)

But at this point I am not changing the draft name.

On 8/3/21 5:10 PM, Card, Stu wrote:
>         E: [email-masked] <mailto:[email-masked]>
>

---

From: "Card, Stu" <[email-masked]>
Date: Fri, 6 Aug 2021 22:48:58 -0400

I concur. Thanks Bob!