Subject: TN5250E - Encrypted Password

From: [email-masked]
Date: Thu, 25 Jun 1998 10:39:59 -0700

Hi Jeffrey,

Would like additional info into encrypted password negotiation.

We have an AS/400 running V4R2 with the following PTFs applied:

        Product         PTFs
        5769TC1 SF47715 and SF46013
        5769999 MF19494
        5769SS1 SF48141, SF47792, and SF47400

Additionally, we have used the encrypted password example found in your
correspondence entitled "Working Example of Encrypted Password" to validate
our
password encryption scheme.  Using the User ID, password, and seeds given,
we
can produce the encrypted password given in that example.

With the above PTFs installed, we can successfully bypass the sign-on screen
when
we use a valid clear-text password as the IBMSUBSPW value.  However, when we
use our validated encryption algorithm on a valid password and pass the
encrypted
password as the IBMSUBSPW value, the AS/400 fails to bypass the sign-on
screen.

In APAR 10918, it states that the above AS/400 PTFs are required to support
bypass
of the signon screen, but no mention is made of support for password
encryption.
Also, password encryption was not mentioned in the "5250 Telnet
Enhancements"
until the second revision (draft-murphy-tn5250e-01.txt).

Given all of this, it seems that support for "Enhanced Display Auto-Signon
and
Password Encryption," as described in the second revision of the
above-mentioned
document, is not present on our V4R2 AS/400, and that there are no PTFs
currently
available with this support.  Is this a valid conclusion?  Is there, or will
there be, an
AS/400 PTF that adds support for TN5250e auto-signon password encryption?

L Kaatz

---

From: Jeffrey Stevens <[email-masked]>
Date: Thu, 25 Jun 1998 17:28:55 -0500

I'm guessing maybe you need to byte stuff (x'FF') or escape (x'02') some of
your seed or encrypted password bytes. Did your sample have any x'FF',
x'00', x'01', x'02', or x'03' octets anywhere in either the client seed or
the substitute password?

> Subject: TN5250E - Encrypted Password
>
> Hi Jeffrey,
>
> correspondence entitled "Working Example of Encrypted Password" to validate our
> password encryption scheme.  Using the User ID, password, and seeds given, we
> With the above PTFs installed, we can successfully bypass the sign-on screen when
> encrypted password as the IBMSUBSPW value, the AS/400 fails to bypass the sign-on
> screen.
>
> In APAR 10918, it states that the above AS/400 PTFs are required to support bypass
> of the signon screen, but no mention is made of support for password encryption.
> Also, password encryption was not mentioned in the "5250 Telnet Enhancements"
> Given all of this, it seems that support for "Enhanced Display Auto-Signon and
> Password Encryption," as described in the second revision of the above-mentioned
> document, is not present on our V4R2 AS/400, and that there are no PTFs currently
> there be, an AS/400 PTF that adds support for TN5250e auto-signon password encryption?
>
> L Kaatz

--
J.S. (Jeffrey) Stevens      AS/400 TCP/IP          (Telnet/WSG/LPD)
Work:  [email-masked]        Personal:  [email-masked]