Subject: 5250 Telnet enhancements

From: "Preston Sights" <[email-masked]>
Date: Mon, 9 Mar 1998 16:27:59 +0000

I read with interest the draft "5250 Telnet Enhancements" dated
23 Feb 1998.   I am new to this list and did not see any answers
to my questions in the digests so I thought I would ask for
clarification here.  If this is wrong, please let me know and I
will refrain from doing so again.

I should say first that the draft is easy to read and clear.
Thank you very much(!) for the included hex streams in
addition to the verbage on the conversations, that is a nice
touch.  I just had a few questions that were not directly
answered for me in the draft (or were outside the scope
of the draft).

Regarding section 6, "Enhanced Display Auto-Signon
and Password Exchange".

1) I am assuming that the IBMRSEED is a derivation of
"Random Seed" and IBMSUBSPW represents a
"substitute password".  As such the sign-on password
would be the substitute password scheme that employs
DES as discussed in other IBM documents??    If not,
then is it clear text or some other scheme??  Is there
a clear text option at all?? (not that clear text would be a
wise thing to implement - it wouldn't).

2) What causes the host (AS/400) to initiate the
USERVAR "IBMRSEEDxxxxxxx"
frame -- is it a previous
VAR "USER" VALUE "JONES"
or similar that triggers the process??

I understand that the functionality is available in OS/400
V4R2.  Question 3 is outside of the scope of the
draft, but I thought I would ask it anyway.

3) does IBM have any firm statement or projections on
PTFs for earlier releases?? (I have heard they intend to support
V3R2 to year 2000 as the last release for old CISC equipment).
If so, what release(s) and what PTFs will give this functionality??
(and of course - when).

Thank you very much for your time.

Best regards,
Preston Sights
[email-masked]

---

From: Jeffrey Stevens <[email-masked]>
Date: Thu, 12 Mar 1998 14:39:17 -0500

Hello Preston,

First, thank you for your kind words about our first pass attempt at
creating a draft RFC.  It did not go unnoticed!

Now, to answer your questions about our 5250 Telnet Enhancements:

1) Yes, your assumptions about the IBMRSEED being defined as a random
   seed and the IBMSUBSPW being defined as a substitute password are
   correct. We we will be releasing an update about how to use these
   variables at a later date. Our initial objective with our RFC was
   to get a draft out by the end of February.  As we continue
   with this, we expect to fully disclose this part of the interface
   at a later date.

   The IBMSUBSPW accepts clear-text passwords, with the understanding that
   clear-text can be ok under certain circumstances, such as over
   protected networks, intranets, etc.  The Server will know it is clear
   text by the fact that no client seed value is returned or a seed with
   hexadecimal zeroes is returned.

2) The host AS/400 TELNET server will always send a USERVAR
   "IBMRSEEDxxxxxxx" frame as part of the initial negotiation - there is
   nothing on the client side that triggers this exchange.  Again,
   more specifics will be released at a later date.

3) This support will be retrofited to V3R2, V3R7 and V4R1.  It is already
   included in V4R2 and up.  The planned time frame is:

       V3R7       -> 1Q98  (will require 5 PTF's)
       V3R2, V4R1 -> 2Q98  (will require 5 PTF's)

    PTF number information is not ready at this time, but I will post
    later when we do have this information.

Jeffrey Stevens - AS/400 TCP/IP (LPD/WSG/TELNET)
Internet: [email-masked]  Phone: 607-752-5488  Fax: 607-752-5421

--- Forwarded by Jeffrey Stevens/Endicott/IBM on 03-12-98 11:19 AM ---

From: "Preston Sights" <[email-masked]>
To: [email-masked]
Subject: 5250 Telnet enhancements

2) What causes the host (AS/400) to initiate the
   USERVAR "IBMRSEEDxxxxxxx" frame -- is it a previous
   VAR "USER" VALUE "JONES" or similar that triggers the process??

I understand that the functionality is available in OS/400
V4R2.  Question 3 is outside of the scope of the draft, but I
thought I would ask it anyway.

Best regards,
Preston Sights
[email-masked]

---

From: Jeffrey Stevens <[email-masked]>
Date: Thu, 12 Mar 1998 14:40:04 -0500

Hello Preston,

Jeffrey Stevens - AS/400 TCP/IP (LPD/WSG/TELNET)
Internet: [email-masked]

--- Forwarded by Jeffrey Stevens/Endicott/IBM on 03-12-98 11:19 AM ---

Best regards,
Preston Sights
[email-masked]

---

From: Dave Close <[email-masked]>
Date: Tue, 17 Mar 1998 15:14:22 +0000

I have a couple of comments about the draft "5250 Telnet
enhancements" dated 23 Feb 1998.

1)  Why is the Client reply to the IAC DO NEW-ENVIRON delayed until
after the TERMINAL-TYPE has been exchanged ?  Surely it would be
normal for a Client to send the  IAC WILL NEW-ENVIRON immediately,
before the IAC WILL TERMINAL-TYPE ?  [NB. Since this does not mean
that the IAC SB NEW-ENVIRON SEND ........IAC SE must be sent
immediately by the Server - it is the start of a new request.]

2) (Page 11) The way the IBMRSEEDxxxxxxxx is illustrated conflicts
with the RFC1572 specification - the Client should be including
           USERVAR "IBMRSEEDxxxxxxxx" [VALUE ...]
in the  IAC SB NEW-ENVIRON IS ........ reply ?

Cheers
Dave Close
Dave Close
Pericom Software PLC
The Priory, Cosgrove
MILTON KEYNES MK19 7JJ
Tel: +44 (0)1908 265533
Fax: +44 (0)1908 265534