Subject: [Tools-discuss] tooling: Change of address Q.

From: Toerless Eckert <[email-masked]>
Date: Wed, 26 May 2021 19:50:01 +0200

So, i run repeatedly into the problem of co-authors or just
contributors to my WG changing association/email-address, and i am
right now not 100% sure about the BCP how they should deal with it.

So, https://www.ietf.org/mailman/options/ietf/<email address>
and global change is clearly part of the BCP.

But in my past experience, it seems that this will not change the email
addresses of the collaborator on draft-ietf-wg-whatever. And i don't
even know if/how there is a way to change those email addresses. Is there
any tool for WG chairs or the contributor themselves to bulk change
the email adress on those draft aliases ? (even a single draft has
quite a few aliases created).

Cheers
    Toerless

---

From: Robert Sparks <[email-masked]>
Date: Wed, 26 May 2021 15:11:45 -0500

The draft-<foo>[email-masked] and <acronym>[email-masked] aliases are 
regenerated on-demand, or with a high refresh rate (hourly).

If the collaborator changes their preferred email address in the 
datatracker, it will be used in all of those aliases after the next 
generation.

RjS

On 5/26/21 12:50 PM, Toerless Eckert wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 26 May 2021 16:48:56 -0700

Hi Robert,
I've chosen to list two email addresses, the feature that is supported in
XMLv3. I wanted the correspondence addressed to draft-<foo>@ietf.org to be
directed at both. But, as I see it, the datatracker uses only one,
whichever is listed first. Do you of any plans to modify that behavior in
the datatracker?

Regards,
Greg

On Wed, May 26, 2021 at 1:12 PM Robert Sparks <[email-masked]> wrote:

> > List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Robert Sparks <[email-masked]>
Date: Thu, 27 May 2021 09:40:18 -0500

No - we've had a lot of pressure from people that led to using the 
marked primary email address.

We could consider adding an "always CC" flag to the email configuration 
or something like it if there's enough demand, but it would be a large 
change to do so.

What is your use case? Would it satisfy your needs to add the addresses 
to the documents Notify field (on the document's main page). Any 
addresses there will be copied in correspondence from the datatracker, 
and will appear in the draft-<name>-notify and draft-<name>-all aliases.

RjS

On 5/26/21 6:48 PM, Greg Mirsky wrote:
> Hi Robert,
> I've chosen to list two email addresses, the feature that is supported 
> in XMLv3. I wanted the correspondence addressed to 
> draft-<foo>@ietf.org <http://ietf.org> to be directed at both. But, as 
> I see it, the datatracker uses only one, whichever is listed first. Do 
> you of any plans to modify that behavior in the datatracker?
>
> Regards,
> Greg
>
> On Wed, May 26, 2021 at 1:12 PM Robert Sparks <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     The draft-<foo>[email-masked] <http://ietf.org> and
>     <acronym>[email-masked] <mailto:[email-masked]> aliases are
>     > So, https://www.ietf.org/mailman/options/ietf/
>     <https://www.ietf.org/mailman/options/ietf/><email address>
>     <mailto:[email-masked]>
>     > * Report datatracker and mailarchive bugs to:
>     [email-masked] <mailto:[email-masked]>
>     > * Report tools.ietf.org <http://tools.ietf.org> bugs to:
>     [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tools-discuss>
>
>     <mailto:[email-masked]>
>     * Report datatracker and mailarchive bugs to:
>     [email-masked] <mailto:[email-masked]>
>     * Report tools.ietf.org <http://tools.ietf.org> bugs to:
>     [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tools-discuss>
>
>

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 27 May 2021 16:51:54 +0200

Ah, ok...

Algo sounds ok.  Thanks for explaining.

I think the last collaborators where i had the problem might not have/had
datatracker accounts. Luckily th next one will be fine then wrt to this issue.

Guess there is still the problem of one not being able to update one's
own draft without help from others after having changed affiliations and
hence not being able to validate the dataracker upload approval email
on the old email. Or is there an algo for that as well ?

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Thu, 27 May 2021 09:55:18 -0500

> on the old email. Or is there an algo for that as well ?

If you can still log into the datatracker, you can add new email 
addresses for yourself, and leave others either marked as active, or 
inactive, and those addresses will be recognized as you during submission.

RjS

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 27 May 2021 17:35:42 +0200

Cool!

So, is changing email on https://www.ietf.org/mailman/options/ietf still necessary,
or would all those subscriptions be also changed when changing datatracker preferred email ?

Cheers
    Toerless

On Thu, May 27, 2021 at 09:40:18AM -0500, Robert Sparks wrote:
> No - we've had a lot of pressure from people that led to using the marked
> primary email address.
> 
> We could consider adding an "always CC" flag to the email configuration or
> something like it if there's enough demand, but it would be a large change
> to do so.
> 
> What is your use case? Would it satisfy your needs to add the addresses to
> the documents Notify field (on the document's main page). Any addresses
> there will be copied in correspondence from the datatracker, and will appear
> in the draft-<name>-notify and draft-<name>-all aliases.
> 
> RjS
> 
> 
> > in XMLv3. I wanted the correspondence addressed to draft-<foo>@ietf.org
> > <http://ietf.org> to be directed at both. But, as I see it, the
> > datatracker uses only one, whichever is listed first. Do you of any
> > plans to modify that behavior in the datatracker?
> > 
> > Regards,
> > Greg
> >

---

From: Robert Sparks <[email-masked]>
Date: Thu, 27 May 2021 10:49:29 -0500

> or would all those subscriptions be also changed when changing datatracker preferred email ?

It's still necessary to manage mailman separately.

In the long run we're looking at more integration, but that isn't likely 
to happen until we move to mailman3 (which is still not looking to be a 
trivial move).

RjS

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 27 May 2021 17:54:14 +0200

Would be great to capture these three data points somewhere.
Maybe add an info paragraph to https://datatracker.ietf.org/accounts/profile/

 "Change of affiliation / retiring a (primary) email"
  - auto-update of datatracker generated emails ([email-masked])
  - auto-recognition of new email for approval of new draft submissions
  - mailman URL for update of any self-created mailing list subscriptions

Cheers
    toerless

On Thu, May 27, 2021 at 10:49:29AM -0500, Robert Sparks wrote:
> In the long run we're looking at more integration, but that isn't likely to
> happen until we move to mailman3 (which is still not looking to be a trivial
> move).
> 
> RjS
> 
> > 
> > Cheers
> >      Toerless
> > 

-- 
---
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Thu, 27 May 2021 08:25:35 -0400

> datatracker, it will be used in all of those aliases after the next

So, the emails are generated from the DT, not from the drafts themselves?

1) draft emails -> DT identity (according to whole set of emails)
2) DT identity -> aliases using "primary" email.

A downside seems to be that I think that I can't have drafts with different
email addresses (representing wearing different hats), concurrently being used.
I don't have this requirement, but I just wanted to be clear about how it works.
It might be surprising to some.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 27 May 2021 12:52:03 -0700

Hi Robert,
thank you for suggesting the use of the "Send notices to" field. Can it be
automatically populated with all e-mail addresses listed in an author's
contact info? Or an author can add it manually?

Regards,
Greg

On Thu, May 27, 2021 at 7:40 AM Robert Sparks <[email-masked]> wrote:

> there will be copied in correspondence from the datatracker, and will
> appear in the draft-<name>-notify and draft-<name>-all aliases.
>
> RjS
>
>
> XMLv3. I wanted the correspondence addressed to draft-<foo>@ietf.org to
> be directed at both. But, as I see it, the datatracker uses only one,
>> [email-masked]
>> [email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Thu, 27 May 2021 15:19:01 -0500

On 5/27/21 2:52 PM, Greg Mirsky wrote:
> Hi Robert,
> thank you for suggesting the use of the "Send notices to" field. Can 
> it be automatically populated with all e-mail addresses listed in an 
> author's contact info? Or an author can add it manually?

At the moment, you would need to ask the secretariat (or an AD, or a wg 
chair if the document has been adopted by a wg) to add it for you.

RjS

>
> Regards,
> Greg
>
> On Thu, May 27, 2021 at 7:40 AM Robert Sparks <[email-masked] 
>     We could consider adding an "always CC" flag to the email
>     configuration or something like it if there's enough demand, but
>     it would be a large change to do so.
>
>     What is your use case? Would it satisfy your needs to add the
>     addresses to the documents Notify field (on the document's main
>     page). Any addresses there will be copied in correspondence from
>     the datatracker, and will appear in the draft-<name>-notify and
>     draft-<name>-all aliases.
>
>     RjS
>
>
>>     I've chosen to list two email addresses, the feature that is
>>     supported in XMLv3. I wanted the correspondence addressed to
>>     draft-<foo>@ietf.org <http://ietf.org> to be directed at both.
>>     But, as I see it, the datatracker uses only one, whichever is
>>     listed first. Do you of any plans to modify that behavior in the
>>     datatracker?
>>
>>     Regards,
>>     Greg
>>
>>     On Wed, May 26, 2021 at 1:12 PM Robert Sparks
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>         <mailto:[email-masked]>
>>         <mailto:[email-masked]>
>>     Tools-discuss mailing list [email-masked]  <mailto:[email-masked]>
>>     * Report datatracker and mailarchive bugs to:[email-masked]  <mailto:[email-masked]>
>>     * Reporttools.ietf.org  <http://tools.ietf.org>  bugs to:[email-masked]  <mailto:[email-masked]>
>>     * Report all other bugs or issues to:[email-masked]  <mailto:[email-masked]>
>>     List info (including how to Unsubscribe):https://www.ietf.org/mailman/listinfo/tools-discuss  <https://www.ietf.org/mailman/listinfo/tools-discuss>
>

---

From: Robert Sparks <[email-masked]>
Date: Thu, 27 May 2021 15:48:26 -0500

> It might be surprising to some.

Well, things are always more complicated than they first seem, and this 
post made me go look more closely, and I'll backtrack a little, changing 
what I've said earlier.

The code for generating the aliases is here:

https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/doc/management/commands/generate_draft_aliases.py

The salient part for the draft-<name>@ alias (as opposed to the 
draft-<name>-[ad|shepherd|notify|all]@ aliases) is at

https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/doc/management/commands/generate_draft_aliases.py#L129

and in particular

https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/doc/management/commands/generate_draft_aliases.py#L54

Which takes its data from the addresses taken from the drafts:

https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/doc/models.py#L605

Note that the DocumentAuthor object only allows for a single address. It 
would be a big change for it to allow multiples.

So - your draft specific emails will still be used for the various 
aliases (but only one address will be used from the draft).

What I've said about the addresses that get used (only using the 
Preferred address) is true for mail the datatracker sends though.

Greg - apologies that I wasn't completely correct in my earlier responses.

RjS

---

From: Michael Richardson <[email-masked]>
Date: Thu, 27 May 2021 20:16:44 -0400

Robert Sparks <[email-masked]> wrote:
    >> A downside seems to be that I think that I can't have drafts with
    >> different email addresses (representing wearing different hats),
    >> concurrently being used.  I don't have this requirement, but I just
    >> wanted to be clear about how it works.  It might be surprising to
    >> some.

    > post made me go look more closely, and I'll backtrack a little,
    > changing what I've said earlier.

    > https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/doc/management/commands/generate_draft_aliases.py

ps: had to login to trac to be allowed to see this.
I'm not sure if my login was special having done ietfdb work, or if anyone
will work.

    > Which takes its data from the addresses taken from the drafts:

So, they aren't passed through the DT identities first.

    > Greg - apologies that I wasn't completely correct in my earlier

Thanks for digging though!