Subject: [Tools-discuss] consensus="true" ?

From: Paul Wouters <[email-masked]>
Date: Tue, 4 May 2021 21:27:41 -0400 (EDT)

Hi,

My local xml2rfc warns me with:

Warning: Setting consensus="true" for IETF STD document (this is not the schema default, but is the only value permitted for this type of document)

When I add consensus="true" to the rfc tag, the warning goes away. But
the version running on the datatracker than warns me with:

One or more XML validation errors occurred when processing the XML file:

draft-ietf-ipsecme-labeled-ipsec-05.xml: Line 26: Value "true" for attribute consensus of rfc is not among the enumerated set

Which one is right, and who has the power to fix the one that is wrong?  :)

Paul

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 05 May 2021 13:00:01 +1000

I suppress this warning deliberately, because it is impossible to satisfy without causing more problems (as you found).

I believe that the right answer is to fix the rules for the attribute in the schema.  We use the format for drafting and the schema (and tools) need to support that.  There is a team working in the dark on updating RFC 7991, who should be aware of this issue already.

On Wed, May 5, 2021, at 11:27, Paul Wouters wrote:
> Warning: Setting consensus="true" for IETF STD document (this is not 
> the schema default, but is the only value permitted for this type of 
> document)
> 
> draft-ietf-ipsecme-labeled-ipsec-05.xml: Line 26: Value "true" for 
> attribute consensus of rfc is not among the enumerated set
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: 
> [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): 
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 5 May 2021 05:34:52 +0200

Am 05.05.2021 um 05:00 schrieb Martin Thomson:
> ...

-> <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/420>

Best regards, Julian

---

From: Jay Daley <[email-masked]>
Date: Wed, 5 May 2021 16:21:26 +1200

> On 5/05/2021, at 3:00 PM, Martin Thomson <[email-masked]> wrote:
> 

The mailing list for this team is viewable https://mailarchive.ietf.org/arch/browse/xml-sg-cmt/

Jay

-- 
Jay Daley
IETF Executive Director

> * Report datatracker and mailarchive bugs to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 5 May 2021 06:39:39 +0200

> The mailing list for this team is viewable https://mailarchive.ietf.org/arch/browse/xml-sg-cmt/

So we reply to these messages here in tools-discuss?

Grüße, Carsten