Subject: draft-ietf-trade-iotp-v1.0-dsig-01.txt

From: "Kent M. Davidson" <[email-masked]>
Date: Wed, 02 Jun 1999 19:03:22 -0700

I've made some minor edits to the 1.0 DSIG document for IOTP based on suggestions from the list. I've submitted the original to Donald who will publish it in a form for all to view shortly. This is more of a publication for those who made comments and want to know the resolution.

Changes in draft-ietf-trade-iotp-v1.0-dsig-01.txt:

- Fixed typo "Sigantures" -> "Signatures"
- Updated file name to reflect revision
- Section 4.3.2: <Manifest LocatorHrefBase='iotp:globally-unique-tid#'>, added end quote (Kawatsura)
- Section 6: Updated example to "quote" correctly, minor errors (Kawatsura)
- Section 3.2: Removed reference to Resource element, fixed example (Kawatsura)
- Section 4.2, and 7: exchange the order between Signature Component and Certificate
     Component (Kawatsura)
- Changed Attributes? -> Attribute*, removed Attributes section (Kawatsura)
- Updated author's address at end of document
- Removed 4.3.5 Attributes, shifted 4.3.6-4.3.8 numbers
- Updated DTD to comply with parsing engines
- Resolution on required algorithms: Suggestions to change requirement to "should", also remove "MD5". No change, language updated to say "MUST". Don't want to remove MD5 as it is the most standard digest used and most widely available algorithm.
- Added language to 4.3.1 to augment: Sign the manifest element itself, Description of signing.

-Kent.

_____________________________________________________________
Kent M. Davidson
VP Engineering
Differential, Inc.
http://www.differential.com
main (650)426-1100
fax  (650)426-1101

-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: Yoshiaki KAWATSURA <[email-masked]>
Date: Thu, 01 Jul 1999 12:33:37 +0900 (JST)

Kent,
I have a quick comment and question for your draft.

1. Comment
I do not know why but it seems to me that your draft has dropped "="
in the whole your XML example
for example:
   <Digest DigestAlgorithmRef "D.1">
       <Locator href "resource locator"/>
       <Value>
            (Digest value)
       </Value>
   </Digest>  .

You should revise this for conforming to XML Specification as follows;
   <Digest DigestAlgorithmRef="D.1">
       <Locator href="resource locator"/>
       <Value>
            (Digest value)
       </Value>
   </Digest>  .

Additional,
In 4.3.8 Prameter:
   <Algorithm ID A1 type "digest" name "urn:ibm:dom-hash">
           <Parameter type 'AlgorithmRef'>A2</Parameter>
   </Algorithm>
   <Algorithm ID A2 type "digest" name "urn:fips:sha1">
   </Algorithm>
   <Algorithm ID A3 type "signature" name "urn:ibm:hmac">
           <Parameter type 'AlgorithmRef'>A1</Parameter>
   </Algorithm>

This has been dropped quotation. Please change as follows:

   <Algorithm ID="A1" type="digest" name="urn:ibm:dom-hash">
           <Parameter type='AlgorithmRef'>A2</Parameter>
   </Algorithm>
   <Algorithm ID="A2" type="digest" name="urn:fips:sha1">
   </Algorithm>
   <Algorithm ID="A3" type="signature" name="urn:ibm:hmac">
           <Parameter type='AlgorithmRef'>A1</Parameter>
   </Algorithm>

2. Question(1)
In 4.3.8 Parameter:

On one hand, the type attribute is defined as PCDATA in 4.3.8, on the
other hand, this attribute is defined as CDATA in Chapter7(Signature
DTD)
Which is correct?

3. Question(2)
In 5.1.2 SHA1:
--
5.1.2 SHA1

   Surface string digest algorithm designed by hte US government for use
                                               ^^^
   with the Digital Signature Standard. This algorithm produces a 160-
   bit hash value.
--
What does "hte" mean?

Thanks,
--
Yoshiaki Kawatsura, Hitachi, Ltd.