Subject: RE: The "Colon" Problem...

From: [email-masked]
Date: Tue, 29 Jun 1999 23:04:10 +0100

Yoshiaki

Understand the problem NMTOKEN has been changed to CDATA as follows ...

From ...

<!ELEMENT PackagedContent (#PCDATA) >
<!ATTLIST PackagedContent
 Name             NMTOKEN   #IMPLIED
 Content          NMTOKEN   "PCDATA"
 Transform (NONE|BASE64)    "NONE" >

 ... to ...

<!ELEMENT PackagedContent (#PCDATA) >
<!ATTLIST PackagedContent
 Name             CDATA     #IMPLIED
 Content          NMTOKEN   "PCDATA"
 Transform (NONE|BASE64)    "NONE" >

... and from ...

<!ELEMENT Brand (ProtocolBrand*, PackagedContent*) >
<!ATTLIST Brand
 ID                 ID      #REQUIRED
 xml:lang           NMTOKEN #IMPLIED
 BrandId            CDATA   #REQUIRED
 BrandName          CDATA   #REQUIRED
 BrandLogoNetLocn   CDATA   #REQUIRED
 BrandNarrative     CDATA   #IMPLIED
 ProtocolAmountRefs IDREFS  #REQUIRED
 ContentSoftwareId  CDATA   #IMPLIED >

... to ...

> ----------
> From: 	Yoshiaki KAWATSURA[SMTP:[email-masked]]
> Sent: 	29 June 1999 05:55
> To: 	[email-masked]
> Cc: 	[email-masked]
> Subject: 	The "Colon" Problem...
> 
> David,
> 
> Could you change the ProtocolBrandID and Name element in
> PackagedContent from NMTOKEN to CDATA?
> 
> Currently, ProtocolBrandId and Name element in PackagedContent are
> defined as NMTOKEN in XML DTD.
> NMTOKEN is defined as Name in XML specification.
> Name in XML arrows ":",".","-" and "_" so we defined ProtocolBrandId
> and Name element in PackagedContent by using ":" in the SET/IOTP and
> Payment API such as "Visa:Gold" or "Payment:SET-OD".
> But I recognized that the colon can not use when the XML namespace is
> used.  This is specified in XML Namespace Specification Chapter6:
> ----
> An XML document conforms to this specification if all other tokens in
> the document which are required, for XML conformance, to match the XML
> production for Name, match this specification's production for NCName.
> 
> The effect of conformance is that in such a document: 
> 
>  All element types and attribute names contain either zero or one colon. 
>  No entity names, PI targets, or notation names contain any colons. 
> 
> Strictly speaking, attribute values declared to be of types ID,
> IDREF(S), ENTITY(IES), and NOTATION are also Names, and thus should be
> colon-free.
> ^^^^^^^^^^
> ----
> As the above, we have to change Name to NCName(No Colon Name) when we
> want to use the XML namespace.
> So currently I change from ":" to ".."(double comma)....
> 
> If you can change, I will revise the original description.
> 
> Regards,
> --
> Yoshiaki Kawatsura
> 
> 
> 
> 

**********************************************************************************************

This Email and any attached files are confidential and may also be privileged. 
If you are not the intended recipient, please notify the postmaster using email 
address [email-masked] or call +44 171 557 5000 and ask for the 
IT Helpdesk.  You should not copy this email and any attached files, use them 
for any purpose or disclose the contents to any other person; all copies of the 
Email and associated files in your possession should be destroyed.

Mondex International Limited
47-53 Cannon Street
London EC4M 5SQ
United Kingdom
Registered No: 3122085, England

Phone:          +44 171 557 5000
Fax:            +44 171 557 5200
Email:          [email-masked]
WebSite:        http://www.mondexinternational.com

*********************************************************************************************
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: Yoshiaki KAWATSURA <[email-masked]>
Date: Wed, 30 Jun 1999 07:51:23 +0900 (JST)

David,
Could you also change ProtocolBrandId in the ProtocolBrand Component
                      ~~~~~~~~~~~~~~~
from NMTOKEN to CDATA?

Regards,
--
Yoshiaki Kawatsura   Hitachi, Ltd.

>>>>> Tue, 29 Jun 1999 23:04:10 +0100,
	[email-masked] said:

David.Burdett> Yoshiaki
David.Burdett> 
David.Burdett> Understand the problem NMTOKEN has been changed to CDATA as follows ...
David.Burdett> 
David.Burdett> >From ...
David.Burdett> 
David.Burdett> <!ELEMENT PackagedContent (#PCDATA) >
David.Burdett> <!ATTLIST PackagedContent
David.Burdett>  Name             NMTOKEN   #IMPLIED
David.Burdett>  Content          NMTOKEN   "PCDATA"
David.Burdett>  Transform (NONE|BASE64)    "NONE" >
David.Burdett> 
David.Burdett>  ... to ...
David.Burdett> 
David.Burdett> <!ELEMENT PackagedContent (#PCDATA) >
David.Burdett> <!ATTLIST PackagedContent
David.Burdett>  Name             CDATA     #IMPLIED
David.Burdett>  Content          NMTOKEN   "PCDATA"
David.Burdett>  Transform (NONE|BASE64)    "NONE" >
David.Burdett> 
David.Burdett> ... and from ...
David.Burdett> 
David.Burdett> <!ELEMENT Brand (ProtocolBrand*, PackagedContent*) >
David.Burdett> <!ATTLIST Brand
David.Burdett>  ID                 ID      #REQUIRED
David.Burdett>  xml:lang           NMTOKEN #IMPLIED
David.Burdett>  BrandId            CDATA   #REQUIRED
David.Burdett>  BrandName          CDATA   #REQUIRED
David.Burdett>  BrandLogoNetLocn   CDATA   #REQUIRED
David.Burdett>  BrandNarrative     CDATA   #IMPLIED
David.Burdett>  ProtocolAmountRefs IDREFS  #REQUIRED
David.Burdett>  ContentSoftwareId  CDATA   #IMPLIED >
David.Burdett> 
David.Burdett> ... to ...
David.Burdett> 
David.Burdett> 
David.Burdett> > ----------
David.Burdett> > From: 	Yoshiaki KAWATSURA[SMTP:[email-masked]]
David.Burdett> > Sent: 	29 June 1999 05:55
David.Burdett> > To: 	[email-masked]
David.Burdett> > Cc: 	[email-masked]
David.Burdett> > Subject: 	The "Colon" Problem...
David.Burdett> > 
David.Burdett> > David,
David.Burdett> > 
David.Burdett> > Could you change the ProtocolBrandID and Name element in
David.Burdett> > PackagedContent from NMTOKEN to CDATA?
David.Burdett> > 
David.Burdett> > Currently, ProtocolBrandId and Name element in PackagedContent are
David.Burdett> > defined as NMTOKEN in XML DTD.
David.Burdett> > NMTOKEN is defined as Name in XML specification.
David.Burdett> > Name in XML arrows ":",".","-" and "_" so we defined ProtocolBrandId
David.Burdett> > and Name element in PackagedContent by using ":" in the SET/IOTP and
David.Burdett> > Payment API such as "Visa:Gold" or "Payment:SET-OD".
David.Burdett> > But I recognized that the colon can not use when the XML namespace is
David.Burdett> > used.  This is specified in XML Namespace Specification Chapter6:
David.Burdett> > ----
David.Burdett> > An XML document conforms to this specification if all other tokens in
David.Burdett> > the document which are required, for XML conformance, to match the XML
David.Burdett> > production for Name, match this specification's production for NCName.
David.Burdett> > 
David.Burdett> > The effect of conformance is that in such a document: 
David.Burdett> > 
David.Burdett> >  All element types and attribute names contain either zero or one colon. 
David.Burdett> >  No entity names, PI targets, or notation names contain any colons. 
David.Burdett> > 
David.Burdett> > Strictly speaking, attribute values declared to be of types ID,
David.Burdett> > IDREF(S), ENTITY(IES), and NOTATION are also Names, and thus should be
David.Burdett> > colon-free.
David.Burdett> > ^^^^^^^^^^
David.Burdett> > ----
David.Burdett> > As the above, we have to change Name to NCName(No Colon Name) when we
David.Burdett> > want to use the XML namespace.
David.Burdett> > So currently I change from ":" to ".."(double comma)....
David.Burdett> > 
David.Burdett> > If you can change, I will revise the original description.
David.Burdett> > 
David.Burdett> > Regards,
David.Burdett> > --
David.Burdett> > Yoshiaki Kawatsura
David.Burdett> > 
David.Burdett> > 
David.Burdett> > 
David.Burdett> > 
David.Burdett> 
David.Burdett> **********************************************************************************************
David.Burdett> 
David.Burdett> This Email and any attached files are confidential and may also be privileged. 
David.Burdett> If you are not the intended recipient, please notify the postmaster using email 
David.Burdett> address [email-masked] or call +44 171 557 5000 and ask for the 
David.Burdett> IT Helpdesk.  You should not copy this email and any attached files, use them 
David.Burdett> for any purpose or disclose the contents to any other person; all copies of the 
David.Burdett> Email and associated files in your possession should be destroyed.
David.Burdett> 
David.Burdett> Mondex International Limited
David.Burdett> 47-53 Cannon Street
David.Burdett> London EC4M 5SQ
David.Burdett> United Kingdom
David.Burdett> Registered No: 3122085, England
David.Burdett> 
David.Burdett> Phone:          +44 171 557 5000
David.Burdett> Fax:            +44 171 557 5200
David.Burdett> Email:          [email-masked]
David.Burdett> WebSite:        http://www.mondexinternational.com
David.Burdett> 
David.Burdett> *********************************************************************************************
David.Burdett> 
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]