Subject: Minor Change Requests for the TradingRole Element.

From: Yoshiaki KAWATSURA <[email-masked]>
Date: Wed, 09 Jun 1999 16:56:25 +0900 (JST)

David,

The current specification(6.5.2) describes about the CancelNetLocn and
ErrorNetLocn in TradingRole element as follows:

--
CancelNetLocn:
     This attribute:
  o must not be present when TradingRole is set to Consumer role,
  o must be present when TradingRole is set to Merchant,
     PaymentHandler or DeliveryHandler.

ErrorNetLocn
    This attribute:
 o must not be present when TradingRole is set to Consumer role,
 o must be present when TradingRole is set to Merchant,
   PaymentHandler or DeliveryHandler.
--

I think the DelivTo role also must not be present at both Locations.

Additionaly, the current DTD definition of TradingRole is as follows:

<!ELEMENT TradingRole EMPTY >
<!ATTLIST TradingRole
 ID              ID      #REQUIRED
 TradingRole        NMTOKEN #REQUIRED
 CancelNetLocn      CDATA   #REQUIRED
 ErrorNetLocn       CDATA   #REQUIRED
 ErrorLogNetLocn CDATA   #IMPLIED >

I think this should be changed as follows:

<!ELEMENT TradingRole EMPTY >
<!ATTLIST TradingRole
 ID              ID      #REQUIRED
 TradingRole        NMTOKEN #REQUIRED
 CancelNetLocn      CDATA   #IMPLIED
                            ~~~~~~~~
 ErrorNetLocn       CDATA   #IMPLIED
                            ~~~~~~~~
 ErrorLogNetLocn CDATA   #IMPLIED >

Regards,

----
Yoshiaki Kawatsura : E-mail [email-masked]
 Business & Information Systems Development Division, Hitachi,Ltd.
Voice: +81-44-549-1713(direct) Fax: +81-44-549-1721
-----------------------------------------------------------------------
Message addressed to: [email-masked]
Archive available at: http://www.elistx.com/archives/ietf-trade/
To (un)subscribe send a message with "subscribe" or "unsubscribe" in the
body to: [email-masked]

---

From: David Burdett <[email-masked]>
Date: Wed, 9 Jun 1999 22:01:31 +0100

Yoshiaki

I agreee with your comments. Changes will be made to the DTD and to the
write up in the specification.

Note that the defintion of the TradingRole element is now ...

 IotpMsgIdPrefix    NMTOKEN #REQUIRED <----------NOTE

Note especially that IotpMsgIdPrefix is now in TradingRole rather than the
Organisation component. See Chris Smith's email dated 21 May, titled
"Implementation Results and IOTP Items -OrgID / Role / Prefix" for the
reason.

David

> ----------
> From: 	Yoshiaki KAWATSURA[SMTP:[email-masked]]
> Sent: 	09 June 1999 00:56
> To: 	[email-masked]
> Cc: 	[email-masked]; [email-masked]
> Subject: 	Minor Change Requests for the TradingRole Element.
> 
> David,
> 

**********************************************************************************************

This Email and any attached files are confidential and may also be privileged. 
If you are not the intended recipient, please notify the postmaster using email 
address [email-masked] or call +44 171 557 5000 and ask for the 
IT Helpdesk.  You should not copy this email and any attached files, use them 
for any purpose or disclose the contents to any other person; all copies of the 
Email and associated files in your possession should be destroyed.

Mondex International Limited
47-53 Cannon Street
London EC4M 5SQ
United Kingdom
Registered No: 3122085, England

Phone:          +44 171 557 5000
Fax:            +44 171 557 5200
Email:          [email-masked]
WebSite:        http://www.mondexinternational.com

*********************************************************************************************