Subject: Re: ECML2-Req-01

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Tue, 03 Apr 2001 17:51:48 -0400

The description you quote from IFX sounds extraordinarily broad.  ECML
started as version 1, which was focused on standardizing payment
related merchant HTML forms.  While it is intended that ECML V2
broaden that and be XML oriented, as indicated in the specification, I
view it as still linked to payment.

Thanks,
Donald

From:  "E. Peter McKinney" <[email-masked]>
Date:  Tue, 03 Apr 2001 16:41:44 -0400
X-Sender:  [email-masked]@mail.praxinet.com
To:  [email-masked]
Message-id:  <[email-masked]>

>Sirs,
>
>How does this draft relate to the work executed by IFX Forum in their 
>production of an XML specification for "business message formats and 
>transmission protocol for for the electronic exchange of data" ?
>
>The draft appears to be focussed on payments, whereas IFX is more broadly 
>oriented.
>
>http://www.ifxforum.org
>
>Best regards,
>
>Peter

---

From: "E. Peter McKinney" <[email-masked]>
Date: Tue, 03 Apr 2001 16:41:44 -0400

Sirs,

http://www.ifxforum.org

Best regards,

Peter

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Tue, 03 Apr 2001 23:34:19 -0400

From:  "E. Peter McKinney" <[email-masked]>
Message-Id:  <[email-masked]>
X-Sender:  [email-masked]@mail.praxinet.com
Date:  Tue, 03 Apr 2001 23:15:00 -0400
To:  "Donald E. Eastlake 3rd" <[email-masked]>
Cc:  [email-masked]
In-Reply-To:  <[email-masked]>
References:  <Your message of "Tue, 03 Apr 2001 16:41:44 EDT." <[email-masked]>

>Donald
>
>Fair enough. That is why I brought it up. I am glad that this is the focus. 
>IFX *is* quite broad. As I am involved in payments oriented systems, where 
>XML is part of the equation, this effort is of much interest.
>
>The IFX specification documentation is 200+ pages long. After all it does 
>come from bankers <grin> As a former auditor, I am used to it.
>
>BTW, the IFX proposal covers registration, enquiries, statements, etc. 
>Somewhat akin to what we are working on.
>
>What I would like to do is examine further the content of this draft 
>against the IFX document and provide some more comment, if that is appropriate?

Sure, you're welcome to comment.

>By the way, why ECML? That name sounds broad in and of itself, when the 
>focus here is on payments? Just a new arrival's question.

The name ECML / Electronic Commerce Modeling Language was arrived at
the the ECML Alliance which did ECML v1 and v1.1.  Technical work has
moved to the IETF and the ECML Alliance has surrendered change control
to the IETF.

Thanks,
Donald

>Thanks
>
>Peter
>
>At 05:51 PM 4/3/01, Donald E. Eastlake 3rd wrote:
>

---

From: "E. Peter McKinney" <[email-masked]>
Date: Tue, 03 Apr 2001 23:43:22 -0400

><snip all the other stuff already posted>

Hmmmm, so a name change is possible? Perhaps PPML - Payments Process 
Modeling Language? To recognize the fact that we is to be achieved is to 
capture the process of payment systems by being generic. Transport and 
business neutral. No?

>Thanks,
>Donald
>
> >Thanks
> >
> >Peter
><snip even older stuff, already posted>

---

From: "E. Peter McKinney" <[email-masked]>
Date: Tue, 03 Apr 2001 23:15:00 -0400

Donald

Thanks

Peter

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Sun, 08 Apr 2001 00:42:08 -0400

Hi,

From:  "E. Peter McKinney" <[email-masked]>
Message-Id:  <[email-masked]>
Date:  Tue, 03 Apr 2001 23:43:22 -0400
To:  "Donald E. Eastlake 3rd" <[email-masked]>
Cc:  [email-masked]
In-Reply-To:  <[email-masked]>
References:  <Your message of "Tue, 03 Apr 2001 23:15:00 EDT." <[email-masked]>

>capture the process of payment systems by being generic. Transport and 

Sure, a change is "possible" if there is a working group consensus to
make such a change.  But some effort went into the selection of ECML,
to determine that, at the time, it was not in wide use for anything
else and that it didn't have any bad connotation in any major culture
present on the Internet.

According to <http://www.gca.org/papers/xmleurope2000/abs/s23-01.html>:
    PPML (Personalized Print Markup Language) [is]
    a new XML-based industry standard print language

Donald

---

From: "E. Peter McKinney" <[email-masked]>
Date: Mon, 09 Apr 2001 08:59:44 -0400

Donald,

Thanks for the clarification.

Interesting background that helps me understand.

Best regards,

Peter

At 12:42 AM 4/8/01, Donald E. Eastlake 3rd wrote:
>References:  <Your message of "Tue, 03 Apr 2001 23:15:00 EDT." 
><[email-masked]>
>