Subject: Working Group Last Call, ECML v2 Requirements

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Fri, 11 May 2001 15:32:04 -0400

Hi,

I'd like to advance the following draft as an Informational RFC.
Please send any comments to the list by May 25th.

Thanks,
Donald

Message-Id:  <[email-masked]>
From:  [email-masked]
Subject:  I-D ACTION:draft-ietf-trade-ecml2-req-02.txt
Date:  Wed, 09 May 2001 09:32:04 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Internet Open Trading Protocol Working Group of the IETF.

	Title		: Electronic Commerce Modeling Language (ECML):Version 2
                          Requirements
	Author(s)	: J. Parsons, D. Shepherd, D. Eastlake
	Filename	: draft-ietf-trade-ecml2-req-02.txt
	Pages		: 10
	Date		: 08-May-01
	
This document lists the design principles, scope, and requirements
for the Electronic Commerce Modeling Language (ECML) version 2
specification. It includes requirements as they relate to XML syntax,
data model, format, payment processing, and external requirements.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-trade-ecml2-req-02.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-trade-ecml2-req-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-trade-ecml2-req-02.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

---

From: "Lewis, Tony" <[email-masked]>
Date: Mon, 14 May 2001 09:02:25 -0700

I have comments regarding the three requirements in section 3.4
Implementation.

1b. What does "Check against representative LOC, ACH, eCheck, Mobile Phone
and PDA processes" mean? If it means to find out if there are other
applications to be added to the list, I recommend either adding a specific
list of applications or deleting the text prior to publication of the
requirements. The requirements should be explicit about what applications
should be supported. The preface to this requirement will allow the working
group to add support for any other applications it identifies.

2. "inculded" should be "included in"; and "insure" should be "ensure".

3. Recommend changing preface to "In accordance with the standard's goals,
ensure complete support for the following:"
_________________________________________________________________
Tony Lewis ([email-masked])
Chief Systems Architect, Internet Commerce
Visa International Service Association

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Wed, 16 May 2001 16:19:50 -0400

Hi Tony,

Thanks for your comments.

On 1b, I guess I agree that making it more definite would be better...what would you think about saying: "ACH, eCheck, and Mobile Phone payment setup" ?

Thanks,
Donald