Subject: Re: [tram] TURN server discovery (please discuss!)

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Fri, 21 Mar 2014 07:36:56 +0000

From: Cb B [mailto:[email-masked]] 
Sent: Thursday, March 20, 2014 10:49 PM
To: Tirumaleswar Reddy (tireddy)
Cc: Simon Perreault; [email-masked]
Subject: RE: [tram] TURN server discovery (please discuss!)

On Mar 20, 2014 7:48 AM, "Tirumaleswar Reddy (tireddy)" <[email-masked]> wrote:
>
> Just adding a data point, mobile networks generally don't use dhcp so that limits the scope of dhcp as an option.
>
> I anticipate mobile networks will need TURN.
>
> CB
>
> [TR]
>
>  
>
> we had discussed similar problem to discover PCP servers in Mobile Networks (http://tools.ietf.org/html/draft-chen-pcp-mobile-deployment-04#section-4) sometime back. Based on the discussion
>
> 1)DHCPv6 stateless configuration information is supported by 3GPP specification (http://tools.ietf.org/html/rfc6459#section-5.2)
>
> 2)Since DHCPv4 is not widely used, possible solutions discussed to solve the problem are anycast, enhancing PCO to provide TURN {PCP} server IP address
>
>  
>
> -Tiru 
> I dont know any deployed mobile network where those will work today.
> Today with IMS in mobile networks, NAPTR is used in DNS, so in would suggest that as a viable path 
> CB

Even the TURN discovery draft is using NAPTR http://tools.ietf.org/html/draft-patil-tram-turn-serv-disc-00#section-4.2; But DHCP is used to get the domain name to be used for TURN service discovery. 
Is there any other mechanism to get the domain name ?

-Tiru

---

From: Simon Perreault <[email-masked]>
Date: Fri, 21 Mar 2014 09:02:07 -0400

> Is there any other mechanism to get the domain name ?

Yes. Please refer to:
http://tools.ietf.org/html/draft-kist-alto-3pdisc

That discovery mechanism looks up NAPTR records in the
{in-addr,ip6}.arpa zone corresponding to the IP address(es) that the
client was assigned by the network. No DHCP involved.

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca