Subject: Re: [tram] Comment on draft-williams-peer-redirect-01: might it not converge?

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Wed, 30 Jul 2014 06:40:40 +0000

> The one thing we need to do is update ICE to allow the CONTROLLING side to make dynamic decisions about which pair to use, instead of being forced to use PRIORITY (which is what 5245 says). 

The dynamic decision of changing priority in certain scenarios  should be confined to an interface. For example when cost saving is taken into account in multi-interface scenario, candidates from an interface which offers least cost would have higher priority than candidates from other interfaces. 

-Tiru

---

From: Justin Uberti <[email-masked]>
Date: Wed, 30 Jul 2014 00:10:08 -0700

On Tue, Jul 29, 2014 at 11:40 PM, Tirumaleswar Reddy (tireddy) <
[email-masked]> wrote:

> > The one thing we need to do is update ICE to allow the CONTROLLING side
> to make dynamic decisions about which pair to use, instead of being forced
> to use PRIORITY (which is what 5245 says).
>
> The dynamic decision of changing priority in certain scenarios  should be
> confined to an interface. For example when cost saving is taken into
> account in multi-interface scenario, candidates from an interface which
> offers least cost would have higher priority than candidates from other
> interfaces.
>

Least cost is one policy that the application could choose. I don't think
it should be the only one.

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Wed, 30 Jul 2014 08:20:59 +0000

Inline [TR]

From: Justin Uberti [mailto:[email-masked]]
Sent: Wednesday, July 30, 2014 12:40 PM
To: Tirumaleswar Reddy (tireddy)
Cc: Jonathan Lennox; Simon Perreault; [email-masked]
Subject: Re: [tram] Comment on draft-williams-peer-redirect-01: might it not converge?

Least cost is one policy that the application could choose. I don't think it should be the only one.

[TR] Agreed.

-Tiru