Subject: [tram] Comments on draft-ietf-tram-auth-problems

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 1 Jul 2014 14:17:18 +0200

Hi,

a few comments on the draft below before we request its publication:

http://datatracker.ietf.org/doc/draft-ietf-tram-auth-problems/

Given that we are not actively working on
draft-thomson-tram-turn-bandwidth, it should not be used as a
justification for this work. Therefore, it should be removed from the
references.

The heading of the draft says it belongs to the BEHAVE WG. Please,
replace BEHAVE with TRAM.

Section 1 (Introduction) talks about P2P applications. Does that refer
to P2P applications in the RFC 5694 sense? Or just to any application
that involves end systems exchanging traffic without a server in
between? Please clarify.

Thanks,

Gonzalo

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 3 Jul 2014 13:46:43 +0000

Hi Gonzalo,

Thanks for the review. Please see inline 

> -----Original Message-----
> From: tram [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> Sent: Tuesday, July 01, 2014 5:47 PM
> To: [email-masked]
> Subject: [tram] Comments on draft-ietf-tram-auth-problems
> 
> Hi,
> 
> Given that we are not actively working on draft-thomson-tram-turn-bandwidth,
> it should not be used as a justification for this work. Therefore, it should be
> removed from the references.

Agreed, removed.

> 
> The heading of the draft says it belongs to the BEHAVE WG. Please, replace
> BEHAVE with TRAM.

Fixed.

> 
> Section 1 (Introduction) talks about P2P applications. Does that refer to P2P
> applications in the RFC 5694 sense? 
> Or just to any application that involves end
> systems exchanging traffic without a server in between? Please clarify.

It could be any P2P application and not restricted to the definition in RFC 5694. From the definition of RFC 5694 looks like WebRTC, SIP applications are not categorized as P2P, but applications using peer to peer streaming protocol (PPSP) will be categorized as P2P. TURN server could be used with all these type of applications. http://tools.ietf.org/html/rfc5128#section-2.7 defines P2P application similar to your latter explanation, will add reference to this RFC.

-Tiru

> 
> Thanks,
> 
> Gonzalo
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram