Subject: Re: [tram] FW: New Version Notification for draft-reddy-tram-token-metadata-00.txt

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 31 Aug 2015 13:09:30 +0000

I took a quick look at the document and it looks good. One comment at this
time.

-A diagram showing the sequence of messages between TURN Client, TURN
server and Introspection endpoint ( Authorization Server) will be useful.
For example, the flow can show TURN client can use RFC 7635 and this works
together.

Regards,

Ram

-----Original Message-----
From: tram <[email-masked]> on behalf of "Tirumaleswar Reddy
(tireddy)" <[email-masked]>
Date: Saturday, 29 August 2015 10:15 am
To: "[email-masked]" <[email-masked]>
Subject: [tram] FW: New Version Notification for
draft-reddy-tram-token-metadata-00.txt

>This document proposes a mechanism for the TURN server to introspect the
>access token to retrieve any policy restrictions imposed by the
>authorization server on the TURN server resources assigned to the client.
>Comments and suggestions are welcome.
>
>-Tiru
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Saturday, August 29, 2015 10:09 AM
>To: Brandon Williams; Tirumaleswar Reddy (tireddy); Dan Wing (dwing); Dan
>Wing (dwing); Suhas Nandakumar (snandaku); Suhas Nandakumar (snandaku);
>Tirumaleswar Reddy (tireddy); Brandon Williams
>Subject: New Version Notification for
>draft-reddy-tram-token-metadata-00.txt
>
>
>A new version of I-D, draft-reddy-tram-token-metadata-00.txt
>has been successfully submitted by Tirumaleswar Reddy and posted to the
>IETF repository.
>
>Name:		draft-reddy-tram-token-metadata
>Revision:	00
>Title:		Metadata discovery for third party authorized TURN session
>Document date:	2015-08-28
>Group:		Individual Submission
>Pages:		9
>URL:            
>https://www.ietf.org/internet-drafts/draft-reddy-tram-token-metadata-00.tx
>t
>Status:         
>https://datatracker.ietf.org/doc/draft-reddy-tram-token-metadata/
>Htmlized:       
>https://tools.ietf.org/html/draft-reddy-tram-token-metadata-00
>
>
>Abstract:
>   The operator of the TURN server might want to have fine grained
>   control on the clients usage of the server resources for providing
>   features such as limiting the bandwith usage, number of allocations
>   and so on.  This document proposes a generic mechanism for the
>   operator to introspect the access token to retrieve any policy
>   restrictions imposed by the authorization server on the TURN server
>   resources assigned to the client.
>
>                  
>        
>
>
>Please note that it may take a couple of minutes from the time of
>submission
>until the htmlized version and diff are available at tools.ietf.org.
>
>The IETF Secretariat
>
>_______________________________________________
>tram mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/tram

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 31 Aug 2015 15:38:30 +0000

> From: Ram Mohan R (rmohanr)
> Sent: Monday, August 31, 2015 6:40 PM
> To: Tirumaleswar Reddy (tireddy); [email-masked]
> Subject: Re: [tram] FW: New Version Notification for draft-reddy-tram-token-
> metadata-00.txt
> 

Okay, will add diagram in the next revision.

Cheers,
-Tiru
> Subject: [tram] FW: New Version Notification for draft-reddy-tram-token-
> metadata-00.txt
> 
> >This document proposes a mechanism for the TURN server to introspect
> >the access token to retrieve any policy restrictions imposed by the
> >To: Brandon Williams; Tirumaleswar Reddy (tireddy); Dan Wing (dwing);
> >Dan Wing (dwing); Suhas Nandakumar (snandaku); Suhas Nandakumar
> >(snandaku); Tirumaleswar Reddy (tireddy); Brandon Williams
> >submission until the htmlized version and diff are available at
> >tools.ietf.org.
> >
> >The IETF Secretariat
> >