Subject: [tram] RFC 7635 on Session Traversal Utilities for NAT (STUN) Extension for Third-Party Authorization

From: [email-masked]
Date: Wed, 26 Aug 2015 19:55:48 -0700 (PDT)

A new Request for Comments is now available in online RFC libraries.

        RFC 7635

        Title:      Session Traversal Utilities for NAT 
                    (STUN) Extension for Third-Party Authorization 
        Author:     T. Reddy, P. Patil,
                    R. Ravindranath, J. Uberti
        Status:     Standards Track
        Stream:     IETF
        Date:       August 2015
        Mailbox:    [email-masked], 
                    [email-masked], 
                    [email-masked],
                    [email-masked]
        Pages:      24
        Characters: 51753
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-tram-turn-third-party-authz-16.txt

        URL:        https://www.rfc-editor.org/info/rfc7635

        DOI:        http://dx.doi.org/10.17487/RFC7635

This document proposes the use of OAuth 2.0 to obtain and validate
ephemeral tokens that can be used for Session Traversal Utilities for
NAT (STUN) authentication.  The usage of ephemeral tokens ensures
that access to a STUN server can be controlled even if the tokens are
compromised.

This document is a product of the TURN Revised and Modernized Working Group of the IETF.

This is now a Proposed Standard.

STANDARDS TRACK: This document specifies an Internet Standards Track
protocol for the Internet community, and requests discussion and suggestions
for improvements.  Please refer to the current edition of the Official
Internet Protocol Standards (https://www.rfc-editor.org/standards) for the 
standardization state and status of this protocol.  Distribution of this 
memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  https://www.ietf.org/mailman/listinfo/ietf-announce
  https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see https://www.rfc-editor.org/search
For downloading RFCs, see https://www.rfc-editor.org/rfc.html

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: Oleg Moskalenko <[email-masked]>
Date: Thu, 27 Aug 2015 00:50:20 -0700

With this RFC 7635 issued, we now have a conflict with STUN attributes
in different documents.

RFC 7635 suggest 0x802E attribute for THIRD-PARTY-AUTHORIZATION.

The same value is used for MOBILITY-TICKET in TURN-mobility draft:

https://tools.ietf.org/html/draft-wing-tram-turn-mobility-03

That has to be fixed.

Thanks
Oleg

On Wed, Aug 26, 2015 at 7:55 PM,  <[email-masked]> wrote:
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 27 Aug 2015 09:05:55 +0000

> -----Original Message-----
> From: tram [mailto:[email-masked]] On Behalf Of Oleg Moskalenko
> Sent: Thursday, August 27, 2015 1:20 PM
> To: [email-masked]
> Subject: Re: [tram] RFC 7635 on Session Traversal Utilities for NAT (STUN)
> Extension for Third-Party Authorization
> 
> With this RFC 7635 issued, we now have a conflict with STUN attributes in
> different documents.
> 

Yes, fixed in my local copy (assigned 0x802F).

-Tiru

> > NAT (STUN) authentication.  The usage of ephemeral tokens ensures that
> > access to a STUN server can be controlled even if the tokens are
> > compromised.
> >
> > protocol for the Internet community, and requests discussion and
> > suggestions for improvements.  Please refer to the current edition of
> > the Official Internet Protocol Standards
> > (https://www.rfc-editor.org/standards) for the standardization state
> > and status of this protocol.  Distribution of this memo is unlimited.
> >
> > author of the RFC in question, or to [email-masked].
> > Unless specifically noted otherwise on the RFC itself, all RFCs are
> > for unlimited distribution.
> >
> >
> > The RFC Editor Team

---

From: Oleg Moskalenko <[email-masked]>
Date: Thu, 27 Aug 2015 05:07:28 -0700

Tiru, thanks for the fix (I suppose that the new Mobility document,
version 04 to be published).

But in the coturn server, I still have a conflict problem. It is
implementing the ORIGIN draft, too; and for the ORIGIN attribute, I
currently have 0x802F tentatively assigned.

I understand that we do not know when and if IANA will ever assign
real numbers for those attributes because I am not sure which one
document will ever become an RFC.

I know that there are people who are using implementation of those
drafts for experimental purposes. Can we avoid that new conflict ?
Could you please assign a different number to MIBILITY-TICKET ? I
suppose that any number is going to be temporary, anyway, and
everything has to go through the normal IANA application etc. In
coturn, I have 0x8030 available - can we use that for MIBILITY-TICKET
?

Thanks !
Oleg

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 27 Aug 2015 12:13:11 +0000

> From: Oleg Moskalenko [mailto:[email-masked]]
> Sent: Thursday, August 27, 2015 5:37 PM
> To: Tirumaleswar Reddy (tireddy)
> Cc: [email-masked]
> Tiru, thanks for the fix (I suppose that the new Mobility document, version 04
> to be published).
> 
> But in the coturn server, I still have a conflict problem. It is implementing the
> ORIGIN draft, too; and for the ORIGIN attribute, I currently have 0x802F
> tentatively assigned.
> 
> I understand that we do not know when and if IANA will ever assign real
> numbers for those attributes because I am not sure which one document will
> ever become an RFC.
> 
> I know that there are people who are using implementation of those drafts
> for experimental purposes. Can we avoid that new conflict ?
> Could you please assign a different number to MIBILITY-TICKET ? I suppose
> that any number is going to be temporary, anyway, and everything has to go
> through the normal IANA application etc. In coturn, I have 0x8030 available -
> can we use that for MIBILITY-TICKET ?

Yes, updated draft.

-Tiru

> >> Subject: Re: [tram] RFC 7635 on Session Traversal Utilities for NAT
> >> With this RFC 7635 issued, we now have a conflict with STUN
> >> attributes in different documents.
> >>
> >> > ephemeral tokens that can be used for Session Traversal Utilities
> >> > for NAT (STUN) authentication.  The usage of ephemeral tokens
> >> > ensures that access to a STUN server can be controlled even if the
> >> > tokens are compromised.
> >> >
> >> > This document is a product of the TURN Revised and Modernized
> >> > Working
> >> Group of the IETF.
> >> >
> >> > STANDARDS TRACK: This document specifies an Internet Standards
> >> > Track protocol for the Internet community, and requests discussion
> >> > and suggestions for improvements.  Please refer to the current
> >> > edition of the Official Internet Protocol Standards
> >> > (https://www.rfc-editor.org/standards) for the standardization
> >> > state and status of this protocol.  Distribution of this memo is unlimited.
> >> >

---

From: Oleg Moskalenko <[email-masked]>
Date: Thu, 27 Aug 2015 05:19:16 -0700

cool, thanks !

Oleg