Subject: [tram] HMAC and SHA2 Truncation for STUNbis

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 18 Jul 2016 16:53:16 +0000

https://tools.ietf.org/html/rfc7518#section-5.2.3 and https://tools.ietf.org/html/rfc7252#section-9.1.3.2.1

-Tiru

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 19 Jul 2016 15:48:33 +0200

Hi Tiru,

On 07/18/2016 06:53 PM, Tirumaleswar Reddy (tireddy) wrote:
> https://tools.ietf.org/html/rfc7518#section-5.2.3 and
> https://tools.ietf.org/html/rfc7252#section-9.1.3.2.1
>
> -Tiru
>

Thank you for the pointers.  We choose to use 128 bits as the minimum because of the 4 bytes padding in attribute, and we aligned the direction of truncation to what is used in the RFC.

This is for MESSAGE-INTEGRITY-256, but I completely forgot in my slides that we are also proposing to do the same for MESSAGE-INTEGRITY.  Would you have some guidance also for SHA-1, or do you (and the WG) think that we should restrict truncation only to the new MESSAGE-INTEGRITY-286 attribute?

Thanks.

---

From: Jonathan Lennox <[email-masked]>
Date: Wed, 20 Jul 2016 08:36:12 +0000

> On Jul 19, 2016, at 3:48 PM, Marc Petit-Huguenin <[email-masked]> wrote:
> 
> Hi Tiru,
> 

I think we should consider MESSAGE-INTEGRITY a legacy feature, and base any protocol enhancements only on MESSAGE-INTEGRITY-SHA256.

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Wed, 20 Jul 2016 09:22:56 +0000

+1

-G

> On Jul 20, 2016, at 10:36 AM, Jonathan Lennox <[email-masked]> wrote:
> 
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram