Subject: Re: [tram] I-D Action: draft-ietf-tram-turnbis-12.txt

From: Brandon Williams <[email-masked]>
Date: Sun, 12 Nov 2017 13:03:47 -0500

Hi Tiru,

I just finished a comprehensive review of the cumulative diffs against 
RFC5766. See attached (let me know if you prefer me to resend as e-mail 
body for list purposes).

You indicate that you addressed Marc's dual allocation related comments, 
but this draft doesn't address his comprehensive review comments, right?

Please let me know a target for addressing the rest of his comments and 
mine so I can try to stay on top of the shepherding work for the draft.

Thanks,
--Brandon
________________________________________
From: Konda, Tirumaleswar Reddy <[email-masked]>
Sent: Monday, October 23, 2017 2:48 AM
To: [email-masked]
Subject: Re: [tram] I-D Action: draft-ietf-tram-turnbis-12.txt

This revision addresses comments from Brandon and dual allocation 
related comments from Mark.

-Tiru

> -----Original Message-----
> From: tram [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Monday, October 23, 2017 12:14 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [tram] I-D Action: draft-ietf-tram-turnbis-12.txt
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the TURN Revised and Modernized WG of the
> IETF.
>
>         Title           : Traversal Using Relays around NAT (TURN): Relay Extensions
> to Session Traversal Utilities for NAT (STUN)
>         Authors         : Tirumaleswar Reddy
>                           Alan Johnston
>                           Philip Matthews
>                           Jonathan Rosenberg
>       Filename        : draft-ietf-tram-turnbis-12.txt
>       Pages           : 83
>       Date            : 2017-10-22
>
> Abstract:
>    If a host is located behind a NAT, then in certain situations it can
>    be impossible for that host to communicate directly with other hosts
>    (peers).  In these situations, it is necessary for the host to use
>    the services of an intermediate node that acts as a communication
>    relay.  This specification defines a protocol, called TURN (Traversal
>    Using Relays around NAT), that allows the host to control the
>    operation of the relay and to exchange packets with its peers using
>    the relay.  TURN differs from some other relay control protocols in
>    that it allows a client to communicate with multiple peers using a
>    single relay address.
>
>    The TURN protocol was designed to be used as part of the ICE
>    (Interactive Connectivity Establishment) approach to NAT traversal,
>    though it also can be used without ICE.
>
>    This document obsoletes [RFC5766] and [RFC6156].
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-tram-turnbis/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-tram-turnbis-12
> https://datatracker.ietf.org/doc/html/draft-ietf-tram-turnbis-12
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-tram-turnbis-12
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram

_______________________________________________
tram mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tram

-- 
Brandon Williams; Chief Architect
Cloud Networking; Akamai Technologies Inc.

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 13 Nov 2017 11:01:42 +0000

> From: Brandon Williams [mailto:[email-masked]]
> Sent: Sunday, November 12, 2017 11:34 PM
> To: Konda, Tirumaleswar Reddy <[email-masked]>;
> [email-masked]
> Cc: [email-masked]

Thanks for the review. I will try to address Marc's and your comments in the next 3 weeks.

Cheers,
-Tiru

> This revision addresses comments from Brandon and dual allocation related
> comments from Mark.
> 
> -Tiru
> 
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >