Subject: [Trigtran] FW: [dhcwg] Announce: BoF Proposal: Detecting Network Attachment

From: [email-masked]
Date: Wed, 11 Jun 2003 11:09:22 +0300

Hi all,

I noticed this BOF announcement, does anyone think that
this is related to the 'link-up' work?

thanks,
John

-----Original Message-----
From: ext Greg Daley [mailto:[email-masked]]
Sent: 11 June, 2003 09:56
To: [email-masked]
Subject: [dhcwg] Announce: BoF Proposal: Detecting Network Attachment

Hi,

There has been some interest in various IETF WGs
regarding what to do when attaching to a network,
and how to distinguish if a host has attached to
a currently configured network or a new one.

I believe that in DHC, this is being pursued for
the purpose of quickly detecting movement upon
joining a link.

There is currently a BoF proposed for IETF57 which
aims to discuss issues uncovered in DHC, Mobile-IP
and Zeroconf WGs.  The hope is that getting together
people from these (and other) groups who are interested
in the problems may lead to a unified approach
to these problems (or at least only one approach each
for IPv4 and IPv6).

Here is the proposed BoF's description:

Detecting Network Attachment (DNA) Proposed BoF Description:

Network Attachment occurs when a host arrives on a new
IP subnet.  When attaching to a network, a host either
already has a valid configuration for this subnet or
must configure addresses.  A host determines whether
it requires additional configuration by Detecting Network
Attachment.

When a host has existing upper layer protocols sessions,
it is important to receive a timely indication that
attachment has occurred.  This may be the case if a host
is connected intermittently, is moving or has urgent data
to transmit upon attachment to a link.

For these nodes, it is also important detect if an acquired
link is new, or has already been visited. This information
may be used to distinguish between events where
configuration must be initiated, or a host already has
valid configuration.

This meeting hopes to providing a forum for those
interested in developing generic attachment detection
technologies for IPv4 and IPv6.

The BOF aims to:

* Describe existing issues encountered in DHC, ZEROCONF
   and Mobileip WGs, which could benefit from work on
   detecting network attachment.

* Define the problem scope, and environments where network
   attachment detection is desirable.

* Determine if sufficient interest exists to form a
   Working Group on this topic.

* Reach consensus on the area of work for a potential WG,
   including which problems are outside scope.
---

If you are interested in this topic, and contributing to
an agenda for the proposed BoF, please subscribe to
the mailing list:  [email-masked]

You may subscribe by sending an email to:

[email-masked]

with the words:

subscribe dna

in the body of the email.

More information is available at the website:

http://www.ctie.monash.edu.au/dna/

Greg Daley

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg
_______________________________________________
Trigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/trigtran

---

From: "Spencer Dawkins" <[email-masked]>
Date: Sun, 15 Jun 2003 21:29:59 -0500

Dear John,

I'm trading e-mail with Greg Daley, and I do believe there is a linkage,
although DNA is focused below transport - they are more about address
management, for instance, than about transport notification. I look forward
to sitting in on their BoF in Vienna.

Thanks for bringing this to the attention of the mailing list - I was off
the net for a week in New Mexico (there are still some places that don't
have phones or cell coverage)...

Spencer

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, June 11, 2003 3:09 AM
Subject: [Trigtran] FW: [dhcwg] Announce: BoF Proposal: Detecting Network
Attachment