Subject: RE: [Trigtran] FW: [dhcwg] Announce: BoF Proposal: Detecting Network Attachment

From: [email-masked]
Date: Mon, 16 Jun 2003 10:08:30 +0300

Hi Spencer,

> I'm trading e-mail with Greg Daley, and I do believe there is a linkage,
> although DNA is focused below transport - they are more about address
> management, for instance, than about transport notification. I look forward
> to sitting in on their BoF in Vienna.

Definately some relations, esp. when viewing the (sordid) history
of Trigtran (aka l2 triggers).
 
> Thanks for bringing this to the attention of the mailing list - I was off
> the net for a week in New Mexico (there are still some places that don't
> have phones or cell coverage)...

I'm not sure that is a bad thing.

John
_______________________________________________
Trigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/trigtran

---

From: Alper Yegin <[email-masked]>
Date: Mon, 16 Jun 2003 20:49:02 -0700

> of Trigtran (aka l2 triggers).

It'd be useful to separate some of the terms here. TRRIGTRAN is not same as
l2 triggers.

The linkage between TRIGTRAN and DNA is the link-layer triggers. Both are
(potential) consumers of link-layer triggers. TRIGTRAN uses link-layer
triggers for enhancing transport protocols. DNA can use these triggers to
expedite the network attachment discovery (with increased confidence).
Another consumer of the triggers if the FMIP work.

Alper

---

From: Greg Daley <[email-masked]>
Date: Tue, 17 Jun 2003 15:14:09 +1000

Hi All,

Sorry for this non-member posting.

> Another consumer of the triggers if the FMIP work.

I think that if we're interested in maintaining the distinction
between Link-Layer and Network-Layer triggers, then TRIGTRAN
work (like spencers) may become a client for Network Layer triggers
instead.   This allows decisions to be made based on
network layer information (possibly relayed in some cases
from the link-layer).

For example, it would allow simple distinction between
"Attached to New network" and "Reattached to Old network"
triggers.  This information is able to be determined
using such techniques as router discovery or DHC at the
network layer.

While this may not be the most efficient delivery mechanism
available, it simplifies interfaces to L2/L3 and L3/L4.

Greg Daley