Subject: [rbridge] Use of the term "campus"

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Thu, 22 Jun 2006 15:27:17 -0400

Guillermo,

	It's not particularly useful to try to resolve all of
these terminology inconsistencies in any general sense.

	For example, the argument that "campus" as used to mean
"site" is more consistent with "bridge connected network" than
"LAN" is, makes some stark assumptions about how someone sets
up their network within a site and/or across multiple sites.

	I've certainly seen networks where a single site has
many different IP subnets (frequently separated by routers), 
and I've even seen a few networks where a single LAN spans 
several sites. (What is a L2VPN for, otherwise?)

	What I'm trying to do is to get us using some terms
consistently - without necessarily making up some non-sense
syllables as we go along.

	I believe "LAN" as I described it is consistent in 
comparison with "VLAN" - meaning that a LAN is a single
broadcast domain in the normal sense but this may change
as a result of virtualization.

	But if nobody else agrees with this, then somebody
needs to suggest an alternative term to replace campus in
the sense that we've been discussing it on this list for 
about a year now.  If not, then I guess I'll have to make 
something up.

	One thing we keep losing sight of here is that this
solution is supposed to support VLANs, which is not at all
the same as "not support anything else."

--
Eric

--> -----Original Message-----
--> From: Guillermo Ib??ez [mailto:gibanez at it.uc3m.es] 
--> Sent: Thursday, June 22, 2006 3:05 PM
--> To: Radia Perlman
--> Cc: Joe Touch; Gray, Eric; rbridge at postel.org
--> Subject: Re: [rbridge] Use of the term "campus"
--> 
--> I meant routers in the sense tthat current campus networks include 
--> routers/multilayer switches. I agree with Radia that in the 
--> Rbridges 
--> context the routers are at the edge of campus.
--> The term corporate network is used sometimes for a network covering 
--> different distant sites. Intranet might coincide in 
--> coverage, although 
--> in meaning usually is used as oposed to extranet or Internet.
--> Guillermo
--> 
--> Radia Perlman wrote:
--> 
--> > I agree with Guillermo...that "campus" covers not just 
--> the rbridges, 
--> > but the LAN segments and the attached nodes.
--> > But I wouldn't include segments connected via routers. For that, 
--> > perhaps "corporate network" or "intranet".
--> >
--> > (I did reply, but I said "reply" rather than "reply 
--> all"...I forgot 
--> > that this mailing list no longer has "reply-to"
--> > set to the list).
--> >
--> > Radia
--> >
--> > Guillermo Ib??ez wrote:
--> >
--> >> Eric,
--> >> The usual meaning of  campus network IMHO, refers to a  
--> set of  LANs 
--> >> covering several buildings, normally including routers 
--> or multilayer 
--> >> switches, switches and end nodes.
--> >> To use a campus for the set of RBridges on a segment seems a bit 
--> >> confusing.  The  LAN segment term seems correct.
--> >> Regards
--> >> Guillermo
--> >> Joe Touch wrote:
--> >>
--> >>> Gray, Eric wrote:
--> >>>  
--> >>>
--> >>>> Radia,
--> >>>>
--> >>>>     I am having some trouble resolving the use of "campus"
--> >>>> in the currently available protocol specification with 
--> the way that 
--> >>>> it has been used in other documents, mailing list
--> >>>> discussion, etc.
--> >>>>
--> >>>>     In the protocol specification, "campus" is defined as
--> >>>> synonymous with the usual definition of "LAN".  Is this use
--> >>>> central to the rest of the document?  If so, can we use the
--> >>>> word "LAN" instead?
--> >>>>   
--> >>>
--> >>>
--> >>>
--> >>> I thought:
--> >>>
--> >>>     - segment
--> >>>         what 802 refers to when describing an ethernet LAN
--> >>>         or a single VLAN on a VLAN-capable network
--> >>>
--> >>>     - campus
--> >>>         the set of rbridges on a segment that cooperate
--> >>>         together
--> >>>
--> >>> I don't know if 802 has a term that describes the set 
--> of all VLANs that
--> >>> share an infrastructure.
--> >>>
--> >>> I would avoid the term LAN, as it could mean VLAN or 
--> segment, and I
--> >>> don't think that's the intent.
--> >>>
--> >>> Joe
--> >>>
--> >>>  
--> >>>
--> >>> 
--> ------------------------------------------------------------
--> ------------ 
--> >>>
--> >>>
--> >>> _______________________________________________
--> >>> rbridge mailing list
--> >>> rbridge at postel.org
--> >>> http://mailman.postel.org/mailman/listinfo/rbridge
--> >>>  
--> >>>
--> >
-->

---

From: gibanez at it.uc3m.es (Guillermo Ibáñez)
Date: Thu, 22 Jun 2006 22:36:11 +0200

Eric,
The term LAN seems the closest. If new terms are allowed, what about 
campuswide LAN (CLAN) ?  
Regards
Guillermo

---

From: touch at ISI.EDU (Joe Touch)
Date: Thu, 22 Jun 2006 13:46:06 -0700

I'd prefer using an existing term for an exisitng idea; so far, we're
either talking about an ethernet segment (i.e., a broadcast domain) or a
LAN.

Joe

Guillermo Ib??ez wrote:
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://mailman.postel.org/mailman/listinfo/rbridge

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 250 bytes
Desc: OpenPGP digital signature
Url : http://mailman.postel.org/pipermail/rbridge/attachments/20060622/7bcfa3c6/signature.bin

---

From: riw at cisco.com (Russ White)
Date: Thu, 22 Jun 2006 20:25:57 -0400

LAN seems to me to be the best term, or "broadcast domain," but then,
that's too long, probably.

:-)

Russ