Subject: [rbridge] Some comments on RBridge

From: HealthingHearts at ieee.org (Yang Yang)
Date: Tue, 11 Jul 2006 08:14:59 +0800

Hello,
   RBridge tries to adopt MPLS header. Are there any benefit to do so? IMO,
the forwarding behavior of RBridge is totally different from MPLS. It's not
possible to use the same forwarding componments.

   Best Regards!
       Yang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.postel.org/pipermail/rbridge/attachments/20060711/12c3e73b/attachment.html

---

From: Donald.Eastlake at motorola.com (Eastlake III Donald-LDE008)
Date: Tue, 11 Jul 2006 09:23:05 -0400

Yes, RBridge forwarding is completely different from MPLS forwarding.
But the argument has been that a lot of effort has been invested in
hardware to efficiently process the MPLS header at high speed.
Therefore, it will be helpful to more rapid deployment and the more
widespread attainment of the prospective advantages of TRILL to re-use
the MPLS header format.
 
Donald

________________________________

From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On
Behalf Of Yang Yang
Sent: Monday, July 10, 2006 8:15 PM
To: rbridge at postel.org
Subject: [rbridge] Some comments on RBridge

Hello,
   RBridge tries to adopt MPLS header. Are there any benefit to do so?
IMO, the forwarding behavior of RBridge is totally different from MPLS.
It's not possible to use the same forwarding componments. 
 
   Best Regards!
       Yang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.postel.org/pipermail/rbridge/attachments/20060711/b4ce731b/attachment.html

---

From: Radia.Perlman at sun.com (Radia Perlman)
Date: Tue, 11 Jul 2006 07:16:15 -0700

It seemed like at the meeting some people were saying if we don't use 
the same Ethertype to specify "MPLS
encoding", that there isn't any advantage to using this format, and 
others were saying that using the same Ethertype
is asking for trouble because the label space would be overlapping. I 
suspect this is very implementation
dependent, and there might be some implementations that would benefit 
from this encodings, and others it wouldn't
help.

So the advantages of the MPLS-like format (with new Ethertype) is:

a) shorter (less overhead) than 8 bytes (which is probably what we'd use 
for an RBridge ID, a hop count, and
perhaps a priority field)
b) perhaps it would make some implementations easier
c) as long as we have to come up with a shim format, might as well use 
this encoding, since it has everything we want

The disadvantages are:
a) more complicated (because of the nickname acquisition protocol)...I 
don't think the nickname acquisition
protocol is all that complicated, but admittedly, with enough "let's do 
this one extra thing because it's not that hard"
can add up

I can't think of any other disadvantages. People can feel free to add to 
either list. But at any rate I don't think
it matters a lot, and we should just pick one and not waste much time on 
this.

Radia

Eastlake III Donald-LDE008 wrote:

> ------------------------------------------------------------------------
> *From:* rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] 
> *On Behalf Of *Yang Yang
> *Sent:* Monday, July 10, 2006 8:15 PM
> *To:* rbridge at postel.org
> *Subject:* [rbridge] Some comments on RBridge
>
> Hello,
> IMO, the forwarding behavior of RBridge is totally different from 
> MPLS. It's not possible to use the same forwarding componments.
>  
>    Best Regards!
>        Yang
>
>------------------------------------------------------------------------
>
>_______________________________________________
>rbridge mailing list
>rbridge at postel.org
>http://mailman.postel.org/mailman/listinfo/rbridge
>  
>