Subject: [rbridge] How to deal with RBridge-Rbridge link metrics ?

From: caitlinb at broadcom.com (Caitlin Bestler)
Date: Thu, 13 Jul 2006 12:49:48 -0700

rbridge-bounces at postel.org wrote:
> Guillermo,
> 
> Thinking top of my head there, but, in your particular case,
> where there is only one bridge in the middle, you could rely on what
> follows : 
> 
> RBridgeA has a link metric of x,
> RBridgeB has a link metric of y < x.
> 
> All the RBridges detect an asymetrical link metric, consider
> the largest, x, as the metric for RbridgeA->RBridgeB and
> RbridgeB->RBridgeA so that no one will consider that the link A->B is
> a 1Gbps link. 
> 
> Once you have two bridges in the middle, I don't see how to
> make the metric be accurate without a manual configuration...
> 

I think the more relevant question is how to support manual
configuration *and* zero-configuration. More precisely, how 
do you know that a given manual configuration is still relevant
after zero-configuration detects a change?

---

From: gibanez at it.uc3m.es (Guillermo Ibáñez)
Date: Fri, 14 Jul 2006 07:35:07 +0200

Caitlin,
        My understanding for manual configuration consist in that costs 
are configured my management. Once a cost is configured, defaul cost 
(zero configuration cost) is overriden. Zero configuration does not 
react to cost changes. Only the protocol will react to cost changes if 
shortest paths are different.
Guillermo