Subject: [rbridge] nickname-less RBs?

From: "Jeff Pickering" <[email-masked]>
Date: Mon, 3 Aug 2009 04:46:52 -0700

The following text has been removed from section 3.7.3 of the latest spec:

   An RBridge that will not act as an ingress, egress, or tree root need
   not have a nickname.

Does this mean nicknames are now reqiured? If so, it should be explicitly stated. Personally, I really

liked the option to not give an RB a nickname if not needed to cut down on routing table size. In the fat tree case,

this amount to around a 60% savings.

Jeff

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 3 Aug 2009 09:35:23 -0400

How would you send a management message to an RBridge without a
nickname, even assuming you are using SNMP over Ethernet? Would you
require an adjacent RBridge to have a nickname? Would you have some
way to address a frame to a System ID? This seems to rapidly get
pretty messy.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-634-2066 (home)
 155 Beaver Street
 Milford, MA 01757 USA
 [email-masked]

On Mon, Aug 3, 2009 at 7:46 AM, Jeff Pickering<[email-masked]> wrote:
> liked the option to not give an RB a nickname if not needed to cut down on
> routing table size. In the fat tree case,
>

---

From: Radia Perlman <[email-masked]>
Date: Mon, 03 Aug 2009 08:38:50 -0700

Right. That was why we removed it, because we couldn't figure out how to
send a management message to a nickname-less RBridge.

Jeff-- when you say "60% savings", do you mean 60% fewer nicknames used?
Are we worried about running out of nicknames?

The only way I can think of perhaps talking to a nickname-less RBridge would
be sending a message to its MAC address as a multicast, and then having
nickname-less RBridges look inside all multicast packets to check if the 
(inner) MAC
address is theirs.

Radia

---

From: "Jeff Pickering" <[email-masked]>
Date: Mon, 3 Aug 2009 12:33:05 -0700

I am worried about running out of hw fdb space. But your point is well taken.
By definition the is an "end station", the rb itself attached to every device.

Jeff

-----Original Message-----
From: Radia Perlman [mailto:[email-masked]] 
Sent: Monday, August 03, 2009 11:39 AM
To: Donald Eastlake
Cc: Jeff Pickering; [email-masked]
Subject: Re: [rbridge] nickname-less RBs?

Radia