Subject: Re: [rbridge] ESADI question

From: Radia Perlman <[email-masked]>
Date: Sat, 01 Aug 2009 14:55:04 -0700

I don't completely understand the question either, but let me make a 
stab at it.

First, a clarification -- it's not the DRB that advertises ESADI  for 
VLAN x, it is the Designated Forwarder for
VLAN x.
Keeping in mind that ESADI is optional, and if implemented, may contain 
any subset of the attached "endnodes",
it would be legal for R1, if it is Designated Forwarder for VLAN x on 
one or more links, to advertise
MAC addresses of any attached VLAN x nodes, including neighbor RBridges. 
It wouldn't cause
any confusion.

The "system ID" of neighbor RBridge R2 is advertised in TRILL IS-IS, but 
R2's system ID is not
necessarily the same as R2's MAC address, especially since R2 might have 
different MAC addresses
on each of its links.

I could imagine some failure scenarios in which R2 might not be 
reachable through its system ID, and
it might be useful to be able to reach a specific one of R2's ports 
through R1, which has
advertised that particular MAC address through ESADI.

Radia

Donald Eastlake wrote:
> Hi,
>
> I don't quite understand your question. Are you talking about IS-IS
> DRBs or EASDI virtual link DRBs? In any case, what difference does
> being a DRB or non-DRB make? The EASDI LSPs distribute end stations
> MAC addresses, not RBridge MAC addresses.
>
> Thanks,
> Donald
>
> =============================
>  Donald E. Eastlake 3rd   +1-508-634-2066 (home)
>  155 Beaver Street
>  Milford, MA 01757 USA
>  [email-masked]
>
>
> On Thu, Jul 30, 2009 at 3:15 AM, Balaji Swaminathan<[email-masked]> wrote:
>   
>> Hi,
>>
>>      The ESADI information is carried in Level1 LSPs as a separate TLV. Will
>> the ESADI information contain the MAC addresses of the non DRBs also OR is
>> it not needed since the non-DRB information is exchanged using the other
>> TLVs of the LSP?
>>
>> Thanks,
>> Balaji.
>>     
>
> _______________________________________________
> rbridge mailing list
> [email-masked]
> http://mailman.postel.org/mailman/listinfo/rbridge
>   

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Balaji Swaminathan <[email-masked]>
Date: Tue, 4 Aug 2009 18:17:29 +0530

Thanks Radia, for your explanation. It answered my question.

Thanks,
Balaji.

-----Original Message-----
From: Radia Perlman [mailto:[email-masked]]
Sent: Sunday, August 02, 2009 3:25 AM
To: Donald Eastlake
Cc: Balaji Swaminathan; [email-masked]
Subject: Re: [rbridge] ESADI question

Radia

> MAC addresses, not RBridge MAC addresses.

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only. 
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates. 
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------