Subject: [rbridge] RBridge Channel: A change re Hop Count

From: Donald Eastlake <[email-masked]>
Date: Mon, 30 May 2011 14:47:25 -0400

Reviewing draft-ietf-trill-rbridge-channel-00, I notice that it says
that RBridge Channel messages MUST be sent with the maximum Hop Count
of 0x3F. That's useful for checking the a message has only gone one
hop or the like. However, for channel messages to be useful for some
applications like traceroute, they need to be sent with other Hop
Counts values. So I think that provision needs an escape and needs to
say they MUST be sent with a maximum Hop Count unless a particular
channel protocol specifies otherwise.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street
 Milford, MA 01757 USA
 [email-masked]

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Vishwas Manral <[email-masked]>
Date: Mon, 30 May 2011 12:14:54 -0700

Hi Donald,

You are right.

Thanks,
Vishwas

---

From: Joe Touch <[email-masked]>
Date: Mon, 30 May 2011 14:27:25 -0700

Any number other than max means MUST is irrelevant since you can't know what app/service sent the packet. I think that's OK, but then IMO just omit the MUST. 

Joe

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 30 May 2011 18:34:11 -0400

Maybe the wording should be something like "... by default the Hop
Count is set to 0x3F but channel protocols MAY specify that it be set
to other values..."

Thanks,
Donald

On Mon, May 30, 2011 at 5:27 PM, Joe Touch <[email-masked]> wrote:
> Any number other than max means MUST is irrelevant since you can't know what
> app/service sent the packet. I think that's OK, but then IMO just omit the
> MUST.
> Joe
>

---

From: Joe Touch <[email-masked]>
Date: Mon, 30 May 2011 16:05:17 -0700

That sounds better; it's useful to have a default.

Joe

On 5/30/2011 3:34 PM, Donald Eastlake wrote:
> On Mon, May 30, 2011 at 5:27 PM, Joe Touch<[email-masked]>  wrote:
>> On May 30, 2011, at 12:14 PM, Vishwas Manral<[email-masked]>  wrote:
>>
>> Hi Donald,
>>
>> You are right.
>>
>> Thanks,
>> Vishwas
>> On Mon, May 30, 2011 at 11:47 AM, Donald Eastlake<[email-masked]>  wrote:
>>>

---

From: Dinesh Dutt <[email-masked]>
Date: Tue, 31 May 2011 12:17:26 -0700

Agreed,

Dinesh